Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Администрирование и интеграция

Войти
Регистрация
Восстановить пароль
 
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 26
#1

Пройти авторизацию на сайте и заполнить форму - 1С

30.12.2016, 10:08. Просмотров 622. Ответов 6
Метки нет (Все метки)

Доброго времени суток!

Есть задача: необходимо пройти авторизацию на сайте и заполнить пустые поля на форме. И все это необходимо сделать программно.

У меня нет опыта в решении таких задач.

Как это можно реализовать?

Если получиться на 1С очень хорошо. А если не получиться то какие технологии задействовать?

Заранее спасибо!

П.С.: Данные для заполнения формы, естественно, надо брать из 1С.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.12.2016, 10:08
Здравствуйте! Я подобрал для вас темы с ответами на вопрос Пройти авторизацию на сайте и заполнить форму (1С):

1C 8.x Открыть форму из другой формы и заполнить ее табличную часть - 1С
Здравствуйте. Прошу помощи. Задача такая... Есть форма документа и текстовое поле ФИО, куда пользователь вводит Ф.И.О. плательщика....

Пройти авторизацию на сайте - Delphi
http://profiwm.ru/log.in.php ппц,не выходит нифига...

Не получается пройти авторизацию на сайте - C#
подскажите почему у меня выводит страницу с ошибкой авторизации...хотя логин и пароль верный: public string send(string url, string...

Пройти авторизацию на сайте (Synapse) - Delphi
Через синапс пытаюсь пройти авторизацию за сайте Возвращает страницу с не пройденной авторизацией HTTP.Headers.Clear; ...

Как программно пройти авторизацию на сайте - C#
Добрый день! Есть сайт site.ru, там авторизация на сайт через соц.сеть ВКонтакте, как мне в программе на c# сделать авторизацию на этот...

Как программно пройти авторизацию на сайте - Visual Basic
Всем привет! Изучаю азы программирования в Visual Basic. Хотел написать простую программу для авторизации с применением логина и пароля...

6
Dethmontt
Модератор
Эксперт 1С
2533 / 2341 / 377
Регистрация: 10.03.2011
Сообщений: 8,230
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 10:17 #2
Визард, а почему это нужно именно из 1С ?
0
GreenkA
Модератор
Эксперт 1С
1764 / 1260 / 444
Регистрация: 25.06.2009
Сообщений: 3,355
30.12.2016, 10:50 #3
Визард, как пример - форма для авторизации на сайте: реквизиты формы ПолеСодержание, АдресСайта, ИмяПользователя, Пароль - типы Строка. На форме ПолеСодержание - Поле HTML документа, АдресСайта - поле ввода с адресом, ИмяПользователя и Пароль - поля ввода.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
//Чтение страницы:
&НаКлиенте
Процедура Прочитать(Команда)
    ПолеСодержание = АдресСайта;
    ПодключитьОбработчикОжидания("Ожидание", 1);
КонецПроцедуры
 
&НаКлиенте
Процедура   Ожидание()
    Если Элементы.ПолеСодержание.Документ.readyState = "complete" Тогда     
        ОтключитьОбработчикОжидания("Ожидание");
        Форма_Авторизации = Элементы.ПолеСодержание.Документ.forms(1);
        Логин_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("RUser");            
        Пароль_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("RPassword");
        Кнопка_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("submit");
        Если Логин_Авторизации <> Неопределено 
            И  Пароль_Авторизации <> Неопределено  
            И Кнопка_Авторизации<> Неопределено Тогда
            Попытка
                Логин_Авторизации.Item(0).value = ИмяПользователя;
                Пароль_Авторизации.Item(0).value = Пароль;
                КнопкаАвторизации.Item(0).click();
                //ПодключитьОбработчикОжидания("ОжиданиеРеализации", 1);
            Исключение
                Сообщить("Авторизация не выполнена.");
            КонецПопытки;
        КонецЕсли;
    КонецЕсли;  
КонецПроцедуры
Вообще надо конечно смотреть на структуру страницы.
0
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 26
30.12.2016, 13:03  [ТС] #4
Dethmontt, я не говорил только из 1С. Если есть другие варианты, например dll, тоже было бы неплохо.

Добавлено через 1 минуту
GreenkA, спасибо. Только вот страницу надо открыть с помощью браузера. Если IE, то 11 версией. Chrome тоже подходит.
0
Dethmontt
Модератор
Эксперт 1С
2533 / 2341 / 377
Регистрация: 10.03.2011
Сообщений: 8,230
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 13:55 #5
Визард, делфи
0
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 26
30.12.2016, 14:15  [ТС] #6
Dethmontt, можно подробнее? Может есть какие-то мануалы?
0
Dethmontt
Модератор
Эксперт 1С
2533 / 2341 / 377
Регистрация: 10.03.2011
Сообщений: 8,230
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 15:15 #7
Цитата Сообщение от Визард Посмотреть сообщение
можно подробнее? Может есть какие-то мануалы?
А что подробнее то и мануалы чего тебе нужны, по делфи?

Добавлено через 40 секунд
тут вот даже пример для 1С есть

1C + asp net web api
0
30.12.2016, 15:15
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.12.2016, 15:15
Привет! Вот еще темы с ответами:

Пройти авторизацию на сайте с помощью стим аккаунта программно - C#
Здравствуйте, друзья. У меня такой интересный вопрос, так что попробую изложить по порядку. 1. Можно ли манипулировать куки браузера в...

Заполнить форму на сайте - Objective-C
Надо заполнить форму логин пароль используя введенные в текст бокс слова. Загружаю в webview страницу, где нужно ввести логин\пароль и...

Заполнить форму на сайте - Windows Phone
Надо заполнить форму логин пароль используя введенные в текст бокс слова. Загружаю в webview страницу, на которой нужно ввести...

Не могу пройти авторизацию в VS - Visual Studio
Добрый день. Скачал как то VS да всё руки не доходили до неё. А на днях нужно было пару строчек написать, открываю я значит, просит войти,...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.