Форум программистов, компьютерный форум CyberForum.ru

1С: Администрирование и интеграция

Войти
Регистрация
Восстановить пароль
 
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 22
#1

Пройти авторизацию на сайте и заполнить форму - 1С

30.12.2016, 10:08. Просмотров 248. Ответов 6
Метки нет (Все метки)

Доброго времени суток!

Есть задача: необходимо пройти авторизацию на сайте и заполнить пустые поля на форме. И все это необходимо сделать программно.

У меня нет опыта в решении таких задач.

Как это можно реализовать?

Если получиться на 1С очень хорошо. А если не получиться то какие технологии задействовать?

Заранее спасибо!

П.С.: Данные для заполнения формы, естественно, надо брать из 1С.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.12.2016, 10:08     Пройти авторизацию на сайте и заполнить форму
Посмотрите здесь:

C# Как программно пройти авторизацию на сайте
Visual Basic Как программно пройти авторизацию на сайте
Delphi Пройти авторизацию на сайте
Как сделать внешнюю печатную форму из стандартной в 1С 1С 1C 8.x
Не получается пройти авторизацию на сайте C#
1С Встроить форму WinForms или WPF (C#) в окно 1с?
Пройти авторизацию на сайте (Synapse) Delphi
После регистрации реклама в сообщениях будет скрыта и будут доступны все возможности форума.
Dethmontt
Модератор
Эксперт 1С
2374 / 2183 / 324
Регистрация: 10.03.2011
Сообщений: 7,647
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 10:17     Пройти авторизацию на сайте и заполнить форму #2
Визард, а почему это нужно именно из 1С ?
GreenkA
Модератор
Эксперт 1С
1573 / 1066 / 364
Регистрация: 25.06.2009
Сообщений: 2,732
30.12.2016, 10:50     Пройти авторизацию на сайте и заполнить форму #3
Визард, как пример - форма для авторизации на сайте: реквизиты формы ПолеСодержание, АдресСайта, ИмяПользователя, Пароль - типы Строка. На форме ПолеСодержание - Поле HTML документа, АдресСайта - поле ввода с адресом, ИмяПользователя и Пароль - поля ввода.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
//Чтение страницы:
&НаКлиенте
Процедура Прочитать(Команда)
    ПолеСодержание = АдресСайта;
    ПодключитьОбработчикОжидания("Ожидание", 1);
КонецПроцедуры
 
&НаКлиенте
Процедура   Ожидание()
    Если Элементы.ПолеСодержание.Документ.readyState = "complete" Тогда     
        ОтключитьОбработчикОжидания("Ожидание");
        Форма_Авторизации = Элементы.ПолеСодержание.Документ.forms(1);
        Логин_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("RUser");            
        Пароль_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("RPassword");
        Кнопка_Авторизации = Элементы.ПолеСодержание.Документ.getElementsByName("submit");
        Если Логин_Авторизации <> Неопределено 
            И  Пароль_Авторизации <> Неопределено  
            И Кнопка_Авторизации<> Неопределено Тогда
            Попытка
                Логин_Авторизации.Item(0).value = ИмяПользователя;
                Пароль_Авторизации.Item(0).value = Пароль;
                КнопкаАвторизации.Item(0).click();
                //ПодключитьОбработчикОжидания("ОжиданиеРеализации", 1);
            Исключение
                Сообщить("Авторизация не выполнена.");
            КонецПопытки;
        КонецЕсли;
    КонецЕсли;  
КонецПроцедуры
Вообще надо конечно смотреть на структуру страницы.
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 22
30.12.2016, 13:03  [ТС]     Пройти авторизацию на сайте и заполнить форму #4
Dethmontt, я не говорил только из 1С. Если есть другие варианты, например dll, тоже было бы неплохо.

Добавлено через 1 минуту
GreenkA, спасибо. Только вот страницу надо открыть с помощью браузера. Если IE, то 11 версией. Chrome тоже подходит.
Dethmontt
Модератор
Эксперт 1С
2374 / 2183 / 324
Регистрация: 10.03.2011
Сообщений: 7,647
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 13:55     Пройти авторизацию на сайте и заполнить форму #5
Визард, делфи
Визард
0 / 0 / 0
Регистрация: 08.05.2016
Сообщений: 22
30.12.2016, 14:15  [ТС]     Пройти авторизацию на сайте и заполнить форму #6
Dethmontt, можно подробнее? Может есть какие-то мануалы?
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.12.2016, 15:15     Пройти авторизацию на сайте и заполнить форму
Еще ссылки по теме:

Авторизация в 1C 8.3 из формы на сайте 1С 1С Web
Нет авторизации на сайте 1С
1С Внешнее событие из библиотеки классов в 1C-форму
1С 1C 8.x Обмен 1С УТ 10.3 с сайтом: после выгрузки из 1С перезаписываются поля, измененные на сайте
1С Авторизация на сайте через пользователей в 1с

Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
Dethmontt
Модератор
Эксперт 1С
2374 / 2183 / 324
Регистрация: 10.03.2011
Сообщений: 7,647
Записей в блоге: 1
Завершенные тесты: 1
30.12.2016, 15:15     Пройти авторизацию на сайте и заполнить форму #7
Цитата Сообщение от Визард Посмотреть сообщение
можно подробнее? Может есть какие-то мануалы?
А что подробнее то и мануалы чего тебе нужны, по делфи?

Добавлено через 40 секунд
тут вот даже пример для 1С есть

1C + asp net web api
Yandex
Объявления
30.12.2016, 15:15     Пройти авторизацию на сайте и заполнить форму
Ответ Создать тему
Опции темы

Текущее время: 06:54. Часовой пояс GMT +3.
КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Рейтинг@Mail.ru