Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/12: Рейтинг темы: голосов - 12, средняя оценка - 4.58
Thomas.Angelo
6 / 6 / 3
Регистрация: 24.12.2011
Сообщений: 257
1

Печать X-отчета из 1С Управление Торговлей 10.3

26.04.2017, 11:35. Просмотров 2314. Ответов 5
Метки нет (Все метки)

Добрый день.
Платформа 8.3.9.2170.
Конфигурация 1С Управление торговлей 10.3.41.1
После подключения онлайн-кассы АТОЛ 55Ф к базе 1С - не можем распечатать X-отчет из меню "Документы" -> "Розница" -> "Отчет кассовой смены без гашения". При нажатии на кнопку печати X-отчета ничего не происходит.
Специалисты центра техобслуживания рекомендуют печатать X-отчет через драйвер кассы, но этот способ не годится, так как COM-порт уже занят программой 1С, и чтобы драйвер получил доступ к порту, необходимо каждый раз закрывать 1С, чтобы напечатать X-отчет. Ранее, при использовании обычной кассы ККМ - X-отчет из 1С печатался.
В чем может быть причина, что при использовании онлайн-кассы X-отчет не печатается?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
26.04.2017, 11:35
Ответы с готовыми решениями:

С Управление торговлей 11
Здравствуйте,, обладаю правами администратора, но после записи элемента...

Управление торговлей 11
Помогите как и с чего нужно писать и какой код для этой кнопки..я не понимаю но...

управление торговлей
В общем то суть вопроса в следующем: 1) научите как сделать акт на передачу...

Управление торговлей
У меня магазин по продажам авто запчастей. Я виду свой бизнес как ИП...

1С V8 Управление торговлей
Здраствуйте, погогите пожалуйста, ответив на один мой вопрос. 1С v8 Управление...

5
Xomych
598 / 535 / 73
Регистрация: 01.11.2012
Сообщений: 1,905
26.04.2017, 18:42 2
Отладчиком проверьте где затык
0
Thomas.Angelo
6 / 6 / 3
Регистрация: 24.12.2011
Сообщений: 257
27.04.2017, 04:30  [ТС] 3
Отладчиком не получится. На сайтах 1С и Атола пишут, что в 1С УТ 10 еще нет поддержки печати Х-отчета для онлайн касс. Его только через тест драйвера можно напечатать. И его название изменили, теперь это не Х-отчет, а "Отчет о состоянии счетчиков без гашения". Я подумал может можно узнать команду, которую надо передать из 1С на кассу ККТ, чтобы касса распечатала этот отчет. Кто-нибудь знает, где можно найти инструкцию с командами, которые передаются на кассу ККТ для выполнения действий (например, открытие смены, открытие денежного ящика и т.д.)? На сайте Атола скачал всю доступную документацию, но в ней команд нет.

Добавлено через 39 минут
Руководство программиста нашел.
0
Thomas.Angelo
6 / 6 / 3
Регистрация: 24.12.2011
Сообщений: 257
29.08.2018, 05:02  [ТС] 4
Задачу решил следующим образом.
На форму списка документов "Кассовые смены" добавил кнопку для печати Х-отчета.
При нажатии на эту кнопку на клиенте выполняем следующий код:
Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
&НаКлиенте
Процедура МК_ОтчетБезГашения(Команда)
    
    ОбработкаОбслуживания = Неопределено;
    ОбъектДрайвера = Неопределено;
    
    МассивККТ = ПолучитьСерверТО().ПолучитьСписокУстройств(
        ПредопределенноеЗначение("Перечисление.ВидыТорговогоОборудования.ККТ"), КассаККМШапка);
        
    КоличествоККТ = МассивККТ.Количество();
    Если КоличествоККТ = 0 Тогда
        ТекстСообщения = НСтр("ru='Отсутствуют доступные фискальные устройства'");
        ОбщегоНазначения.СообщитьИнформациюПользователю(ТекстСообщения);
    ИначеЕсли КоличествоККТ = 1 Тогда
        ККТ = МассивККТ[0];
    Иначе
        ПредставлениеУстройства = "";
        ВидУстройства = "";
        СписокККТ = Новый СписокЗначений;
 
        Для Каждого Устройство Из МассивККТ Цикл
            ПолучитьСерверТО().ПолучитьПредставлениеУстройства(Устройство, ВидУстройства, ПредставлениеУстройства);
            СписокККТ.Добавить(Устройство, ПредставлениеУстройства);
        КонецЦикла;
 
        ККТ = СписокККТ.ВыбратьЭлемент("Необходимо выбрать фискальное устройство");
        Если ККТ <> Неопределено Тогда
            ККТ = ККТ.Значение;
        КонецЕсли;
    КонецЕсли;
    
    Если ККТ = NULL ИЛИ ККТ = Неопределено Тогда
        Возврат;
    КонецЕсли;
 
    
    ПолучитьСерверТО().ПолучитьОбъектДрайвера(ККТ, ОбработкаОбслуживания, ОбъектДрайвера);
    
    Если ОбработкаОбслуживания = Неопределено Тогда
        ОбщегоНазначения.СообщитьОбОшибке("Ошибка получения обработки обслуживания");
    Иначе
        
        РезультатВыполнения = ОбработкаОбслуживания.XОтчет(ОбъектДрайвера, "", "", "");
 
     КонецЕсли;
    
КонецПроцедуры
0
Dethmontt
29.08.2018, 12:51
  #5

Не по теме:

Thomas.Angelo, Х-отчет это Хреновый Отчет?

0
Thomas.Angelo
6 / 6 / 3
Регистрация: 24.12.2011
Сообщений: 257
31.08.2018, 12:35  [ТС] 6
На данным момент эта кнопка уже работает типовым образом. 1С допилили эту функцию для онлайн ККТ в типовой конфигурации Управление Торговлей 10.3.
0
31.08.2018, 12:35
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.08.2018, 12:35

1С управление торговлей
Друзья! Помогите пожалуйста Проблема вот в чем: После исправления ошибок в...

1с предприятие управление торговлей 8.3
Добрый вечер! Мне нужно &quot;1с предприятие управление торговлей 8.3&quot;. Везде оно...

1cv8 УПРАВЛЕНИЕ ТОРГОВЛЕЙ
Я НОВИЧОК! ПОДСКАЖИТЕ ПОЖАЛУЙСТА КАК В 1CV8 УПРАВЛЕНИЕ ТОРГОВЛЕЙ ДЛЯ БЕЛАРУСИИ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru