Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.82/11: Рейтинг темы: голосов - 11, средняя оценка - 4.82
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
1

Отправка GET запроса из 1С

27.06.2017, 21:14. Просмотров 2231. Ответов 8
Метки нет (Все метки)

Доброго времени суток. Столкнулся с такой трудностью - не могу отправить запрос на сайт. Нашел такую штуку:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаКлиенте
Процедура ВыполнитьЗапрос(Команда)
// Создаем HTTPСоединение, указываем сервер
Соединение = Новый HTTPСоединение(СерверДляЗапроса);
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
// Запросим имя файла, который будет сохранен. По умолчанию расширение png
СтрФильтр = НСтр(«ru = ‘Файл'») + «(*.»+»png»+»)|*.»+ «png»;
ДиалогОткрытияФайла.Фильтр = СтрФильтр;
ДиалогОткрытияФайла.Заголовок = «Укажите имя файла»;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
Если ДиалогОткрытияФайла.Выбрать() Тогда
// Выполнить GET запрос:
Соединение.Получить(ТекстДляЗапроса, ДиалогОткрытияФайла.ПолноеИмяФайла);
Сообщить(«Удачно выполнен GET запрос!»);
Иначе
Сообщить(«Не выбран файл!»);
КонецЕсли;
КонецПроцедуры
 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
СерверДляЗапроса = «programmist1s.ru»;
ТекстДляЗапроса = «/wp-content/themes/govpress-new/images/GOODWILL.png»;
КонецПроцедуры
Нов в СП как-то расплывчато написано про данный метод. Не могу понять, как это применить.
Мне нужно отправить запросом строку вида "МойСайт.ru/sms/?параметр1&параметр2&параметр3". То есть сымитировать ввод данной строки в браузере. При переходе в браузере по данной ссылке отправляется смс на номер с текстом (параметры в строке). Пытался пихать эту строку в параметр
1C
1
СерверДляЗапроса
- не прокатывает. Подскажите, пожалуйста.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
27.06.2017, 21:14
Ответы с готовыми решениями:

Отправка GET запроса
Всем привет! Java для меня не является специализированным языком, поэтому вопрос нубский до...

Отправка запроса
var reg = "{\"s\":}"; richTextBox1.AppendText(reg); HttpWebRequest GRep =...

Отправка get запроса
Здравствуйте. Уже который день бьюсь с отправкой get запроса и получения ответа. Делаю примерно...

Отправка GET запроса
Здравствуйте есть такой код. <input type="text" name="mail" required="required"/><a...

Отправка GET запроса
Здравствуйте. Нужно сделать что бы когда я что то вёл в поле pol и нажал на кнопку, запрос...

8
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
28.06.2017, 00:01 2
Roman2408, пихать надо в
1C
1
ТекстДляЗапроса
1
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
28.06.2017, 10:43  [ТС] 3
Спасибо! Отправить получилось, но теперь другой вопрос. Мне не нужен диалог открытия файла, не надо ничего сохранять. Нужно просто отправить запрос. Как это сделать? Пробую просто
1C
1
Соединение.Получить(ИтоговыйТекст);
но так ругается.
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
28.06.2017, 14:36 4
Roman2408,
1C
1
Ответ = Соединение.Получить(ИтоговыйТекст);
Добавлено через 40 секунд
Roman2408, платформа какой версии?
0
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
28.06.2017, 15:20  [ТС] 5
Вообще 8.3.10.2168, но в базе стоит совместимость с 8.3.6

Добавлено через 11 минут
Ошибка при вызове метода контекста (Получить)
1C
1
2
3
    Ответ = Соединение.Получить(ИтоговыйТекст);      
по причине:
Неправильный путь к файлу. Схема не зарегистрирована
Пробовал с фейковым именем файла. Выдает
1C
1
2
3
4
 Ошибка при вызове метода контекста (Получить)
    Ответ = Соединение.Получить(ИтоговыйТекст, "1");      
по причине:
Ошибка доступа к файлу '1'
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
28.06.2017, 16:00 6
тогда уж так
1C
1
Ответ = Соединение.Получить(ИтоговыйТекст, "");
0
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
28.06.2017, 16:06  [ТС] 7
ругается так же, как и без указания имени файла - Неправильный путь к файлу. Схема не зарегистрирована
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
28.06.2017, 16:18 8
Roman2408, вот синтаксис
HTTPСоединение (HTTPConnection)
Получить (Get)
Синтаксис:

Получить(<HTTPЗапрос>, <ИмяВыходногоФайла>)
Параметры:

<HTTPЗапрос> (обязательный)

Тип: HTTPЗапрос.
HTTP-запрос.
<ИмяВыходногоФайла> (необязательный)

Тип: Строка.
Имя файла, в который помещаются данные полученного ресурса. Если не указан или содержит пустую строку, то тело ответа может быть получено из объекта HTTPОтвет.
Возвращаемое значение:

Тип: HTTPОтвет.

Описание:

Получает данные с HTTP-сервера, используя GET-запрос.

Добавлено через 3 минуты
Roman2408, первый параметр метода Получить() должен быть типа HTTPЗапрос

Первый параметр может быть строкой только при указании второго параметра (оставлено для совместимости и специально нигде не описано что бы не использовали!!!)

Добавлено через 42 секунды
А вообще ctrl+f1 в помощь...
1
Roman2408
4 / 4 / 1
Регистрация: 04.04.2013
Сообщений: 117
28.06.2017, 16:45  [ТС] 9
Спасибо, разобрался!
1C
1
Ответ = Соединение.Получить(Новый HTTPЗапрос(ИтоговыйТекст));
Вот так заработало.
0
28.06.2017, 16:45
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
28.06.2017, 16:45

Отправка запроса
Как отправить такой запрос ? Хттп веб реквест не помог (не удалось подклчюить ) и свойствое креате...

Отправка запроса
Может тупой вопрос , но как перехватить данные которые отправляются по типу ...

Отправка GET запроса
Доброго дня! HELP! Есть поля &lt;input type=&quot;text&quot; name=&quot;phone&quot; placeholder=&quot;Укажите телефон&quot; /&gt;...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru