Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Администрирование и интеграция
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
Motor1
1 / 1 / 2
Регистрация: 01.04.2011
Сообщений: 76
1

Выгрузка из 1с авто-альфа в Битрикс

06.08.2017, 09:25. Просмотров 933. Ответов 2

Добрый день возник вопрос.
Есть 1с с авто-альфа.
Задача выгрузить товар и картинки на сайт.
Есть стандартная выгрузка она выгружает товар на сайт цены и картинки к товару, но не выгружает картинки разделов.

Раздел приходит вот так
1C
1
2
3
4
<Группа>
<Ид>85d09bca-0166-11e6-80f3-001999ef1bb7</Ид>
<Наименование>Сопутствующие товары</Наименование>
</Группа>
Как я понимаю должно быть вот так

1C
1
2
3
4
5
<Группа>
<Ид>85d09bca-0166-11e6-80f3-001999ef1bb7</Ид>
<Наименование>Сопутствующие товары</Наименование>
<Картинка>import_files/56/56944960-93a7-11e3-80be-001999ef1bb7.jpeg</Картинка>
</Группа>
приходит товар

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
<Товар>
            <Ид>56944960-93a7-11e3-80be-001999ef1bb7</Ид>
            <Артикул>406</Артикул>
            <Наименование>Кронштейн-крепление баллона 100-130 л.</Наименование>
            <Производитель>БАЖ</Производитель>
            <БазоваяЕдиница Код="ЦБ000296" НаименованиеПолное="Штука" МеждународноеСокращение="PCE">шт</БазоваяЕдиница>
            <Группы>
               <Ид>a79b96aa-0243-11e6-80f3-001999ef1bb7</Ид>
            </Группы>
            <Картинка>import_files/56/56944960-93a7-11e3-80be-001999ef1bb7.jpeg</Картинка>
            <ЗначенияРеквизитов>
               <ЗначениеРеквизита>
                  <Наименование>ВидНоменклатуры</Наименование>
                  <Значение>Товар</Значение>
               </ЗначениеРеквизита>
               <ЗначениеРеквизита>
                  <Наименование>ТипНоменклатуры</Наименование>
                  <Значение>Товар</Значение>
               </ЗначениеРеквизита>
               <ЗначениеРеквизита>
                  <Наименование>Полное наименование</Наименование>
                  <Значение>Кронштейн универсальный 100-130 л.(Воронеж)</Значение>
               </ЗначениеРеквизита>
               <ЗначениеРеквизита>
                  <Наименование>Вес</Наименование>
                  <Значение>0</Значение>
               </ЗначениеРеквизита>
            </ЗначенияРеквизитов>
         </Товар>
Вопрос такой как сделать чтобы отправлялась картинка раздела?
В модуле интеграции я нашел

1C
1
2
3
4
5
6
7
8
Процедура ВыгрузитьОсновныеРеквизитыГруппыДляКлассификатора(ОбъектCML, Группа)
   
   ИдГруппы = СформироватьИдентификаторТовара(Группа.Ссылка);
   ЗаписатьТекстовойУзел(ОбъектCML, "Ид", ИдГруппы);
   ИмяГруппы = Группа.Наименование;
   ЗаписатьТекстовойУзел(ОбъектCML, "Наименование", ФорматНаименованияДляCML(ИмяГруппы));
   
КонецПроцедуры
И нашел вот это

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
Функция ВыгрузитьКартинку(Номенклатура, КаталогНаДиске);
   
   СтруктураРезультата = Новый Структура();
   СтруктураРезультата.Вставить("Адрес",  "");
   СтруктураРезультата.Вставить("Формат", Строка(ФорматКартинки.НеизвестныйФормат));
   СтруктураРезультата.Вставить("Размер", "0");
   
   // Получим картинку
   НаборКартинок = РегистрыСведений.КартинкиИФайлы.СоздатьНаборЗаписей();
   НаборКартинок.Отбор.Объект.Установить(Номенклатура);
   НаборКартинок.Прочитать();
   Если ( НаборКартинок.Количество() = 0 ) Тогда
      Возврат СтруктураРезультата;
   Иначе
      Картинка = НаборКартинок[0].Данные.Получить();
   КонецЕсли;   
   
   Если ( ТипЗнч(Картинка) <> Тип("Картинка") ) Тогда
      Возврат СтруктураРезультата;
   КонецЕсли;
   
   Попытка
      
      ФорматКартинкиОбъекта = Картинка.Формат();
      Если ( ФорматКартинкиОбъекта = ФорматКартинки.НеизвестныйФормат ) Тогда
         СообщитьПользователю("У товара обнаружено основное изображение неизвестного формата: " + Номенклатура, Истина, СтатусСообщения.Информация, 1);
         Возврат СтруктураРезультата;   
      КонецЕсли;
         
      ФорматКартинкиРазрешен = Истина;
      Если ( НЕ (ФорматКартинкиОбъекта = ФорматКартинки.GIF
          ИЛИ ФорматКартинкиОбъекта = ФорматКартинки.JPEG
          ИЛИ ФорматКартинкиОбъекта = ФорматКартинки.PNG) ) Тогда
          
         Попытка
            ФорматКартинкиОбъекта = Картинка.Преобразовать(ФорматКартинки.JPEG);       
         Исключение
            СообщитьОбИсключительнойОшибке(Истина, "Не удалось преобразовать картинку для " + Номенклатура + " из " + Строка(ФорматКартинкиОбъекта) + " в JPEG");
            ФорматКартинкиРазрешен = Ложь;
         КонецПопытки;
         
      КонецЕсли;    
      
      Если ( НЕ ФорматКартинкиРазрешен ) Тогда Возврат СтруктураРезультата; КонецЕсли;
      
   Исключение
      
      СообщитьОбИсключительнойОшибке(Истина, "Не удалось выгрузить картинку для товара: " + Номенклатура + " " + ОписаниеОшибки());
      ФорматКартинкиРазрешен = Ложь;
      
   КонецПопытки;
      
   РасширениеФайлаКартинки    = "." + НРег(Строка(ФорматКартинкиОбъекта));
   ИмяФайлаКартинки           = Строка(Номенклатура.УникальныйИдентификатор()) + РасширениеФайлаКартинки;
   КаталогПоИмени            = Лев(ИмяФайлаКартинки, 2);
   КаталогКартинки            = КаталогНаДиске + "" + ПодкаталогКартинок + "" + КаталогПоИмени;
   СоздатьКаталог(КаталогКартинки);
   ПолноеИмяФайлаКартинки     = КаталогКартинки + "" + ИмяФайлаКартинки;
   ФайлКартинкиНаДиске       = Новый Файл(ПолноеИмяФайлаКартинки);
   
   Картинка.Записать(ПолноеИмяФайлаКартинки);      
   
   СтруктураРезультата.Адрес  = ПодкаталогКартинок + "/" + КаталогПоИмени + "/" + ИмяФайлаКартинки;
   СтруктураРезультата.Формат = Строка(ФорматКартинкиОбъекта);
   СтруктураРезультата.Размер = Формат(ФайлКартинкиНаДиске.Размер(), "ЧГ=");
   
   Возврат СтруктураРезультата;
   
КонецФункции
Вопрос как сделать выгрузку картинок раздела?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.08.2017, 09:25
Ответы с готовыми решениями:

Альфа-авто
Доброго всем времени суток! Кто может подружить альфа-авто и автософт? + настроить выгрузку прайс...

Альфа-авто vs 1С:Автосервис
Здравствуйте господа! Нужно автоматизировать небольшой автосервис: 10 мастеров, объём номенклатуры...

Зависание конфы альфа авто
День добрый имеется конфа &quot;Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ. Редакция 5...

Отправка смс, конфигурация Альфа-авто автосалон
Ни когда не задавался этим вопросом (наверно бы и не задался, если меня не спросили бы), попросили...

Не могу победить битрикс. Выгрузка
Люди добрые подскажите пожалуйста.. имеется УТ11,3 с битриксом. Когда выгружаю на сайт товары с...

2
Dethmontt
Модератор
Эксперт 1С
2697 / 2461 / 432
Регистрация: 10.03.2011
Сообщений: 8,911
Записей в блоге: 1
Завершенные тесты: 1
07.08.2017, 02:00 2
Цитата Сообщение от Motor1 Посмотреть сообщение
В модуле интеграции я нашел
Загрузить в КД 3.0, подправить правило выгрузки разделов, результат вставить обратно в модуль интеграции
0
Motor1
1 / 1 / 2
Регистрация: 01.04.2011
Сообщений: 76
07.08.2017, 21:07  [ТС] 3
Цитата Сообщение от Dethmontt Посмотреть сообщение
Загрузить в КД 3.0, подправить правило выгрузки разделов, результат вставить обратно в модуль интеграции
Добрый день
А можно более подробно?
Вот модуль обработки
Модуль обработки.zip
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
07.08.2017, 21:07

Выгрузка заказов с сайта Битрикс в УТ 10.3
Добрый день! Пользуюсь стандартным модулем &quot;Обмен данными с Web-сайтом&quot;. Товары выгружаются...

Выгрузка дополнительного реквизита заказа в модуле 1С-Битрикс
Добрый день, коллеги, профессионалы!))) У меня в 1С, у каждого заказа есть поле, которое...

Сложно ли сделать выгрузку на сайт из "Альфа-Авто"?
Хочу попробовать сделать вызрузку в каталог сайта информации из &quot;Альфа-авто&quot; (это аналог 1-С 8). ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.