Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
1

Все значения восстанавливаются, а ФИО нет

29.12.2013, 00:09. Просмотров 573. Ответов 13
Метки нет (Все метки)

Здравствуйте,

Есть форма, на ней есть ТабличноеПоле

пытаюсь вписать в него строки с сохраненными данными (сохраненные ранее из этого же Табл.Поля)
1C
1
2
3
4
5
НоваяСтрока = ЭтотОбъект.АВТ.Добавить();
//НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоНаименованию(Строка(Запись.РегФИО));
НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоКоду("002");
НоваяСтрока.Часы = Запись.РегЧасы;
НоваяСтрока.Личное = Запись.РегЛичное;
все столбцы заполняются правильно, а вот с ФИО никак не выходит

Пробовал и по Наименованию искать и по Коду
При этом в отладчике если смотреть, то
по наименованию вообще ничего не находит
По коду - находит фио, но при этом столбец ФИО в ТабличномПоле пустой

че не так делаю?
0
Миниатюры
Все значения восстанавливаются, а ФИО нет  
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.12.2013, 00:09
Ответы с готовыми решениями:

Возможно ли сделать при выборе с поля со списком ФИО, попадая в поле ФИО все буквы были заглавными
Подскажите подалуйста возможно ли сделать при выборе с поля со списком ФИО...

Не восстанавливаются все данные из бекапа
У меня БД Oracle 11g. Год назад я сделал бекап всей БД, точнее это был...

Дан файл записей. Одно из полей записи ФИО. Вывести все записи в виде таблицы в алфавитном порядке ФИО
Я сделал ввод файла, а вот как сделать такой вывод не знаю. Помогите...

В поиске добавить код если нет такого значения в стринггрид то вывести ошибку такого значения нет, если находит то вывод
procedure TForm1.Button5Click(Sender: TObject); var i,j,k:integer;S:string;...

Массив: Cоздать массив, содержащий все значения из массива Б, которых нет в массиве А.
На основе двух массивов А и Б (Размеры вводит пользователь, значение заполняет...

13
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.12.2013, 00:35 2
Тип у колонки "ФИО" какой? Они совпадают?
По наименованию может и не находить - плюс минус пробел и все, до свидания.
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.12.2013, 00:50 3
1C
1
НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоКоду("002").наименование;
типа что-то так
1
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 01:02  [ТС] 4
Цитата Сообщение от duk337 Посмотреть сообщение
1C
1
НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоКоду("002").наименование;
типа что-то так
не, так даже в отладчике не находит

Добавлено через 6 минут
однако...
поместил на форму ПолеВвода и таким же образом присвоил значение
и не зависимо от типа значения (строка или СправочникСсылка.ФИО) без проблем присваивает значение

видимо закавырка в ТабличномПоле
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.12.2013, 01:05 5
внятность=0%
0
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 01:11  [ТС] 6
Цитата Сообщение от duk337 Посмотреть сообщение
внятность=0%
что именно?
если про полеввода, то всмысле, просто для проверки на форму поместил новое ПолеВвода и таким же образом:
1C
1
НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоКоду("002");
присвоил ему значение
1C
1
ЭлементыФормы.ПолеВвода1.Значение = Справочники.ФИО.НайтиПоКоду("002");
и все присвоилось.
но это я просто для проверки сделал... проблема все еще осталась.
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
29.12.2013, 01:15 7
имелись в виду типы данных. Система иногда в стринг подсовывает Представление. Не обольщайтесь
0
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 10:19  [ТС] 8
По поводу реквизитов и типов:
Скрин1
у нее "Данные" это реквизит ТабличнойЧасти, а реквизит в свою очередь это "СправочникСсылка.ФИО"

П.С.
в ручную ФИО подтягивается без проблем
Скрин 2
0
Миниатюры
Все значения восстанавливаются, а ФИО нет   Все значения восстанавливаются, а ФИО нет  
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.12.2013, 10:46 9
А весь код можете привести?
У вас дальше нигде не очищается?

Добавлено через 1 минуту
А попробуйте код элемента не руками вбить, а скопипастить из справочника. Может пробелы какие затесались...

Добавлено через 25 секунд
И заодно заскриньте структуру самого справочника.)
0
Xomych
617 / 551 / 78
Регистрация: 01.11.2012
Сообщений: 1,969
29.12.2013, 10:48 10
Скидывай конфу, разберемся
0
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 11:18  [ТС] 11
Цитата Сообщение от OrkVasya Посмотреть сообщение
А весь код можете привести?
У вас дальше нигде не очищается?
про то, код через заднее место написан можно не упоминать... я институтов не кончал )
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Процедура ПриОткрытии()
    НаборЗаписей = РегистрыСведений.РаспределениеПланов.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    Колво = НаборЗаписей.Количество();
    а = 0;
    Для Каждого Запись Из НаборЗаписей Цикл
        а = а + 1;
        Если а < Колво Тогда 
            НоваяСтрока = ЭтотОбъект.АВТ.Добавить();
 
            Нашел = Справочники.ФИО.НайтиПоНаименованию(Строка(Запись.регФИО));
            НоваяСтрока.ФИО = Нашел.Ссылка;
            //НоваяСтрока.ФИО = Справочники.ФИО.НайтиПоКоду("002");
 
            НоваяСтрока.Часы = Запись.РегЧасы;
            НоваяСтрока.Личное = Запись.РегЛичное;
            НоваяСтрока.ТО = Запись.РегТО;
            НоваяСтрока.ПДУ = Запись.РегПДУ;
            НоваяСтрока.ГСД = Запись.РегГСД;
            НоваяСтрока.АКС = Запись.РегФИО;
            НоваяСтрока.ФИО = Запись.РегАкс;
        Иначе
            ЭлементыФормы.АВТТО.Значение = Запись.РегТО;
            ЭлементыФормы.АВТПДУ.Значение = Запись.РегПДУ;
            ЭлементыФормы.АВТГСД.Значение = Запись.РегГСД;
            ЭлементыФормы.АВТАкс.Значение = Запись.РегАкс;
        КонецЕсли;
    КонецЦикла;
КонецПроцедуры
Цитата Сообщение от OrkVasya Посмотреть сообщение
А попробуйте код элемента не руками вбить, а скопипастить из справочника. Может пробелы какие затесались...
1) вставлял копипастом
2) значение НоваяСтрока.ФИО присваивается верное... в отладчике проверял, но в ТабличномПоле не присваивается

Цитата Сообщение от OrkVasya Посмотреть сообщение
И заодно заскриньте структуру самого справочника.)
скрин
0
Изображения
 
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 11:20  [ТС] 12
Цитата Сообщение от Xomych Посмотреть сообщение
Скидывай конфу, разберемся
в разделе "Обработки"
0
Вложения
Тип файла: zip 1Cv8.zip (36.2 Кб, 1 просмотров)
OrkVasya
о_____О
Эксперт 1С
219 / 219 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
29.12.2013, 11:24 13
Цитата Сообщение от SanSaySP Посмотреть сообщение
НоваяСтрока.ФИО = Запись.РегАкс;
Оно же у вас дальше перезаписывается.
1
SanSaySP
21 / 21 / 1
Регистрация: 14.12.2013
Сообщений: 406
29.12.2013, 11:28  [ТС] 14
Цитата Сообщение от OrkVasya Посмотреть сообщение
Оно же у вас дальше перезаписывается.
ппц, перекопипастил
спс )
0
29.12.2013, 11:28
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.12.2013, 11:28

Сравнение данных ФИО и выдача сообщения, что данные ФИО не найдены
Помогите реализовать сложную для меня задачу. Есть две таблицы с ФИО: Табл1 в...

Определите функцию, печатающую ФИО в строку, а вывод ФИО в столбец
Доброе время суток, прошу помочь в написании программы. Задание: ...

При изменении ФИО в первом листе добавить новую ячейку с ФИО во второй лист
Как сделать чтобы при изменении ФИО в первом листе добавлялась новая ячейка с...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
14
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru