Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.58/19: Рейтинг темы: голосов - 19, средняя оценка - 4.58
Антон Машенцев
0 / 0 / 0
Регистрация: 01.10.2013
Сообщений: 102
1

Как Скрыть кнопку в форме Документа

14.03.2014, 10:28. Просмотров 3658. Ответов 9
Метки нет (Все метки)

Подскажите пожалуйста как скрыть кнопку формы документа для определенного пользователя

Добавлено через 12 минут
Обычная форма
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.03.2014, 10:28
Ответы с готовыми решениями:

Как отобразить картинку статуса в форме списка документа
Подскажите пожалуйста, если возможность в форме списка документа отображать...

Как отобразить в Форме Документа (создать тонкую форму в толстом приложении)
Как отобразить в Форме Документа 1С:Предприятие 8.2 окно, в котором есть...

Создать программно табличную часть в форме документа как приставлено на последем скрине
Народ помогите мне пожалуйста создать программно табличную часть в форме...

Отбор в форме документа
День добрый. Делаю документ, добавил реквизит "ДокументОснование", и в модуле...

Операции с реквизитами в форме Документа
В документе "РасходнаяНакладная" имеется реквизит "Валюты", который берется из...

9
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
14.03.2014, 10:43 2
Лучший ответ Сообщение было отмечено Антон Машенцев как решение

Решение

1C
1
2
3
4
5
Процедура ПриОткрытии()
    Если ПользователиИнформационнойБазы.ТекущийПользователь().Имя = "Вася" Тогда
        ЭлементыФормы.ИмяТвоейКнопки.Видимость = Ложь
    КонецЕсли;
.........
1
Антон Машенцев
0 / 0 / 0
Регистрация: 01.10.2013
Сообщений: 102
14.03.2014, 11:14  [ТС] 3
чет не хочет работать(((

Добавлено через 12 минут
Цитата Сообщение от Антон Машенцев Посмотреть сообщение
чет не хочет работать(((
Все понял!!! кнопка находится не на форме а на ОСновныеДействияФормы. теперь ни как ее не спрятать!?
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
14.03.2014, 11:31 4
ЭлементыФормы.ОСновныеДействияФормы.Кнопки.ИмяТвоейКнопки.Видимость = Ложь

Добавлено через 1 минуту
если руками писать (а не копипастить с форумов) - после каждой точки подсказка вылазит

Добавлено через 50 секунд
до определенного уровня вложенности...
0
Антон Машенцев
0 / 0 / 0
Регистрация: 01.10.2013
Сообщений: 102
14.03.2014, 11:45  [ТС] 5
Спасибо за помощь!!! я не копипастю и про подсказку я знаю))) дело в том что как оказалось свойство ВИДИМОСТЬ, для элемнтов расположеных не в форме , применить нельзя

Добавлено через 8 минут
Заменил ВИДИМОСТЬ на ДОСТУПНОСТЬ и ВУАЛЯЯ!!!!! РАБОТАЕТ
1C
1
2
3
4
Если ПользователиИнформационнойБазы.ТекущийПользователь().ПолноеИмя="ИмяПользователя" Тогда
                  ЭлементыФормы.ОсновныеДействияФормы.Кнопки.Записать.Доступность =Ложь;  
                          ЭлементыФормы.ОсновныеДействияФормы.Кнопки.Печать.Доступность=Ложь// таким образом кнопки не доступны
        КонецЕсли;
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,594
Записей в блоге: 1
Завершенные тесты: 1
14.03.2014, 12:02 6
А если Петя зайдет?
0
Антон Машенцев
0 / 0 / 0
Регистрация: 01.10.2013
Сообщений: 102
14.03.2014, 12:05  [ТС] 7
Цитата Сообщение от Dethmontt Посмотреть сообщение
А если Петя зайдет?
кстати этот вопрос актуален...я подумаю
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,594
Записей в блоге: 1
Завершенные тесты: 1
14.03.2014, 12:10 8
Цитата Сообщение от Антон Машенцев Посмотреть сообщение
кстати этот вопрос актуален...я подумаю

Не по теме:

Красавчик... :rofl:

0
Антон Машенцев
0 / 0 / 0
Регистрация: 01.10.2013
Сообщений: 102
14.03.2014, 12:11  [ТС] 9
Может вместо имени использовать РОЛЬ???
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
14.03.2014, 12:44 10
РольДоступна (IsInRole)
Синтаксис:

РольДоступна(<Роль>)
Параметры:

<Роль> (обязательный)

Тип: Строка; ОбъектМетаданных: Роль.
Название роли как она задана в конфигураторе или объект описания метаданного роли.
Возвращаемое значение:

Тип: Булево.
Истина - роль доступна текущему пользователю; Ложь - в противном случае.
Описание:

Определяет доступность указанной роли текущему пользователю.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Пример:

Если Не РольДоступна("Менеджер") Тогда
Сообщить("Просмотр заявок от покупателей не разрешен!");
КонецЕсли;
0
14.03.2014, 12:44
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
14.03.2014, 12:44

Время на печатной форме документа в ТиС 7.7
Доброго всем дня! Помогите пожалуйста вывести время проведения документа (Чек...

Заполнение на форме данными из другого документа
Здравствуйте! Перейду собственно к проблеме - имеется два документа (Допустим...

Автозаполнение нескольких реквизитов в форме документа
Добрый день.(8.3, УФ) Возникла нужда заполнить несколько реквизитов (ИНН и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru