Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.68/19: Рейтинг темы: голосов - 19, средняя оценка - 4.68
Gokusa
Заблокирован
1

Множественный выбор из списка

31.03.2014, 18:38. Просмотров 3890. Ответов 8
Метки нет (Все метки)

есть форма, в ней списокЗначений регистра.
к нему применяется некий отбор или даже множественный выбор.
при нажатии на кнопку завершить выбор, как получить данные списка соответсвующие отображаемым данным.
или лучше использовать набор записей регистра вместо списка для таких целей.
единственное что пришло в голову,
на основании . отбор, создать массив условий и в цикле менять текст результирующего запроса к регистру чтобы получить набор записей соответствующий выбранным записям.
но наверняка есть способ проще, и скорее всего даже "зашитый " в систему.
кто-нить, подскажите мне этот способ))
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.03.2014, 18:38
Ответы с готовыми решениями:

Множественный выбор
При нажатии на кнопку происходит вызов процедуры, которая формирует новый документ, но перед тем,...

Множественный выбор
Подскажите как реализовать множественный выбор или как правильно сделать.Нужно чтобы в поле...

Множественный выбор в Таблицу значений
Доброго времени суток УТ 10.3 (Обычное приложение, 8.1) Вопрос такой: Есть ТаблицаЗначений на...

Иерархический справочник с колонкой флажка в форме (множественный выбор)
Доброго времени, помогите решить задачу, Нужно вывести список номенклатуры так так выводится в...

Выбор из списка
Добрый день. Если возможность при выборе поля ввода допустим Наименование, что будут преложены уже...

8
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
31.03.2014, 20:17 2
текст требует перевода.
Цитата Сообщение от Gokusa Посмотреть сообщение
списокЗначений регистра.
Цитата Сообщение от Gokusa Посмотреть сообщение
как получить данные списка соответсвующие отображаемым данным.
Цитата Сообщение от Gokusa Посмотреть сообщение
массив условий
ну и т.д. И вопрос:
Чем не устраивает отбор?

Уточнить режим формы.
0
Gokusa
Заблокирован
31.03.2014, 21:11  [ТС] 3
а как я с отбора передам данные?
отбор относится к элементам формы, а не к данным формы, или я что-то путаю?
режим обычный.

Добавлено через 2 минуты
вот пример:
отобразил списокзаписей регистрасведений.
применил к нему отбор, на форме отображается- красота.
захожу в шифт ф9, там весь регистр без отбора.
т.е. чтобы получить отобранные данные нужно опять делать запрос к базе?
или как ?

Добавлено через 1 минуту
мысль тока такая:
получить отбор, из него сделать запрос и запросом получить данные для окончательной работы с ними.
а как еще можно это сделать?

Добавлено через 2 минуты
иными словами:
че вот мне даст отбор, кроме отображения на форме картинки?
ну картинка, ну записи в виде картинки и че, с ними все равно ниче сделать нельзя по этой картинке.
обойти их нельзя.
какой имеется смысл у отбора кроме как картинки рисовать?
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
31.03.2014, 21:26 4
Gokusa, а СоздатьНаборЗаписей(), установить отбор по нужным полям и Прочитать() этот набор?
1
31.03.2014, 21:26
Gokusa
Заблокирован
31.03.2014, 21:37  [ТС] 5
а метод недоступен для данного объекта потому что 1 измерение
(в смысле добавить элемент отбора для регистра)

Добавлено через 1 минуту
неужели вариант с загонянием отбора в запрос- единственный????

Добавлено через 9 минут
а может я туплю
))))
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
31.03.2014, 21:38 6
Gokusa, какой регистр? сведений? какая структура? и как вы устанавливаете отбор?
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
31.03.2014, 22:00 7
скрипты секретные, судя по всему. Я вижу одно: в рассуждениях нет системы
Цитата Сообщение от Gokusa Посмотреть сообщение
отбор относится к элементам формы, а не к данным формы, или я что-то путаю?
да. Для таб поля отбор иногда существует, но и то, как бонус разработчиков, а в случае данных регистрСвСписок - однозначно отбор относится к данным. Настройка отбора - да, к таб.полю.
0
Gokusa
Заблокирован
31.03.2014, 22:12  [ТС] 8
отбор ставлю типа такого:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Отбор = ЭлементыФормы.ЗаписиРегистра.ОтборСтрок;
    Отбор.период.значение = НачалоМесяца(Отчетныйпериод);
    Для каждого ЭлементОтбора из Отбор цикл
        Если Не ЗначениеЗаполнено(ЭлементОтбора.значение) тогда 
            отбор.удалить(отбор.индекс(ЭлементОтбора));
            Если значениеЗаполнено(ЭлементОтбора) тогда 
                НовЭлОтбора = ЗаписиРегистра.Отбор.Добавить( ,ЭлементОтбора.Имя,);
                НовЭлОтбора.ВидСравнения = ЭлементОтбора.ВидСравнения;
                НовЭлОтбора.Значение = ЭлементОтбора.Значение;
                НовЭлОтбора.Использование = ЭлементОтбора.Использование;
                НовЭлОтбора.ТипЗначения = ЭлементОтбора.ТипЗначения;
                НовЭлОтбора.Представление = ЭлементОтбора.Представление;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
    ЗаписиРегистра.Прочитать();
думаю нужно попробовать через получит поля отбора.
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,806
31.03.2014, 22:33 9
Лучший ответ Сообщение было отмечено Gokusa как решение

Решение

Gokusa,
1C
1
2
3
    ЗаписиРегистра = РегистрыСведений[ИмяРегистра].СоздатьНаборЗаписей(); //в случае, если тип ЗаписиРегистра = РегистрыСведений[ИмяРегистра].НаборЗаписей, то опускаем
    ЗаписиРегистра.Отбор[ИмяИзмерения].Установить(ЗначениеОтбора);
    ЗаписиРегистра.Прочитать();
1
31.03.2014, 22:33
StackOverflow
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.03.2014, 22:33

Выбор из списка
Подскажите что не так. Мне нужно вывести в колонку Улицу, дом и корпус Процедура...

Выбор документов из списка
Подскажите пожалуйста, как проверить список документов за определённый период (месяц) на одинаковые...

Выбор документа из списка
Добрый день! Нужна помощь в решении данной задачи: Как мне реализовать в конфигураторе, на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru