Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
fat0001
0 / 0 / 0
Регистрация: 12.07.2013
Сообщений: 4
1

Переделка внешнего обработчика для УПП 1с 8.2

16.04.2014, 11:17. Просмотров 519. Ответов 6
Метки нет (Все метки)

Приветствую имеется внешняя обработка для УНФ позволяющая создать несколько заказов на производство на основании заказов от покупателя. Писалась и тестировалась для релиза 1.3.2.5 как ее переделать для УПП 8.2 код модуля прилагаю.


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
Функция СведенияОВнешнейОбработке() Экспорт
   
   РегистрационныеДанные = Новый Структура;
   РегистрационныеДанные.Вставить("Наименование", "Создание заказов на производство");
   РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
   РегистрационныеДанные.Вставить("Версия", "1.0");
   РегистрационныеДанные.Вставить("Вид", "СозданиеСвязанныхОбъектов");
   РегистрационныеДанные.Вставить("Информация", "Создание заказов на производство на основании заказа покупателя");
   
   /////////////// команды /////////////////////////
   
   тзКоманд = Новый ТаблицаЗначений;
   тзКоманд.Колонки.Добавить("Идентификатор");
   тзКоманд.Колонки.Добавить("Представление");
   тзКоманд.Колонки.Добавить("Модификатор");
   тзКоманд.Колонки.Добавить("ПоказыватьОповещение");
   тзКоманд.Колонки.Добавить("Использование");
   
   строкаКоманды = тзКоманд.Добавить();
   строкаКоманды.Идентификатор = "Создать";
   строкаКоманды.Представление = "Создать заказы на производство";
   строкаКоманды.ПоказыватьОповещение = Истина;
   
   строкаКоманды.Использование = "ВызовКлиентскогоМетода";
                                    
   РегистрационныеДанные.Вставить("Команды", тзКоманд);
   
   МассивНазначений = Новый Массив;
   МассивНазначений.Добавить("Документ.ЗаказПокупателя");
   РегистрационныеДанные.Вставить("Назначение", МассивНазначений);
      
   Возврат РегистрационныеДанные;
   
КонецФункции
 
Процедура ПолучитьДанныеПоЗаказам(ОбъектыНазначения,Заказы) Экспорт
   
   Заказы.Очистить();
   
   Запрос = Новый Запрос;
   
   Запрос.УстановитьПараметр("ОбъектыНазначения",ОбъектыНазначения);
               
   Запрос.Текст = "            
       |ВЫБРАТЬ РАЗРЕШЕННЫЕ
      |
      |   ВЫБОР
      |      КОГДА Константы.ФункциональнаяОпцияРезервированиеЗапасов
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка
      |      ИНАЧЕ ЗНАЧЕНИЕ(Документ.ЗаказПокупателя.ПустаяСсылка)
      |   КОНЕЦ КАК ЗаказПокупателя,
      |
      |   ЗаказПокупателяЗапасы.Ссылка.Организация КАК Организация,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи
      |      ИНАЧЕ ЗНАЧЕНИЕ(Справочник.СтруктурныеЕдиницы.ПустаяСсылка)
      |   КОНЕЦ КАК СтруктурнаяЕдиница,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение)
      |            И ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаРезерв = ЗНАЧЕНИЕ(Справочник.СтруктурныеЕдиницы.ПустаяСсылка)
      |            И (ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Склад)
      |               ИЛИ ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения.ТипСтруктурнойЕдиницы = ЗНАЧЕНИЕ(Перечисление.ТипыСтруктурныхЕдиниц.Подразделение))
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаПродажи.ИсточникПеремещения
      |      ИНАЧЕ ЗаказПокупателяЗапасы.Ссылка.СтруктурнаяЕдиницаРезерв
      |   КОНЕЦ КАК СтруктурнаяЕдиницаРезерв,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЗаказПокупателя.ЗаказНаряд)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.Финиш
      |      ИНАЧЕ ЗаказПокупателяЗапасы.ДатаОтгрузки
      |   КОНЕЦ КАК Финиш,
      |
      |   ВЫБОР
      |      КОГДА ЗаказПокупателяЗапасы.Ссылка.ВидОперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийЗаказПокупателя.ЗаказНаряд)
      |         ТОГДА ЗаказПокупателяЗапасы.Ссылка.Старт
      |      ИНАЧЕ ДОБАВИТЬКДАТЕ(ЗаказПокупателяЗапасы.ДатаОтгрузки, ДЕНЬ, -ЗаказПокупателяЗапасы.Номенклатура.СрокПополнения)
      |   КОНЕЦ КАК Старт,
      |
      |   ЗаказПокупателяЗапасы.Номенклатура     КАК Номенклатура,
      |   ЗаказПокупателяЗапасы.Характеристика   КАК Характеристика,
      |   ЗаказПокупателяЗапасы.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
      |   ЗаказПокупателяЗапасы.Количество       КАК Количество,
      |   ЗаказПокупателяЗапасы.Количество       КАК Резерв,
      |   ЗаказПокупателяЗапасы.Спецификация     КАК Спецификация
      |ИЗ
      |   Документ.ЗаказПокупателя.Запасы КАК ЗаказПокупателяЗапасы,
      |   Константы КАК Константы
      |ГДЕ
      |   ЗаказПокупателяЗапасы.Ссылка В (&ОбъектыНазначения)
      |";
   
   Рез = Запрос.Выполнить();
   
   Если Рез.Пустой() Тогда
      Возврат;
   Иначе
      Заказы =  Рез.Выгрузить();
   КонецЕсли;   
   
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.04.2014, 11:17
Ответы с готовыми решениями:

1с v7.7 как выполнить автоматический запуск внешнего обработчика
Добрый день. Надо было запустить 1с каждый день в определенное время. Это сделал при помощи...

Холодильник Liebherr icbn 30560 переделка, переделка с инвертора на обычный
Прошу ногами не пинать сам я не холодильщик нужны разъяснения : Холодильник Liebherr icbn 30560,...

AJAX вместо результата обработчика возвращает, исходный код обработчика
Здравствуйте, начал изучать AJAX и столкнулся с проблемой, при GET запросе в котором я стучу в файл...

Вызов обработчика кнопки из другого обработчика.
Есть кнопка, есть у ней обработчик, который делает нечто полезное. Как вызвать выполнения...

Мощность сервера для 1С УПП 8.1
У меня стоит УПП в количестве двух штук. Одна бухгалтерская, другая управленческая. На совещании...

6
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
17.04.2014, 23:44 2
Проще с нуля написать чем переделывать...
0
fat0001
0 / 0 / 0
Регистрация: 12.07.2013
Сообщений: 4
18.04.2014, 08:07  [ТС] 3
как снуля это будет выглядить
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.04.2014, 09:03 4
Цитата Сообщение от fat0001 Посмотреть сообщение
как снуля это будет выглядить
1. Понять алгоритм.
2. Реализовать его при помощи конструктора запроса или формы отчета.
1
fat0001
0 / 0 / 0
Регистрация: 12.07.2013
Сообщений: 4
18.04.2014, 11:03  [ТС] 5
алгоритм такой на основание заказа покупателя или на основание месечного плана производства создать один план заказа на производства а ролизовать еге надо во внешней обработке
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
18.04.2014, 11:55 6
Цитата Сообщение от duk337 Посмотреть сообщение
1. Понять алгоритм.
2. Реализовать его при помощи конструктора запроса или формы отчета.
fat0001, между п.1 и п.2 надо вставить пункт "найти программиста"?
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.04.2014, 15:00 7
Цитата Сообщение от fat0001 Посмотреть сообщение
на основание заказа покупателя или на основание месечного плана производства
это не одно и то же. Может, Вам во фриланс?
0
18.04.2014, 15:00
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.04.2014, 15:00

Переделка импульсного бп ATX для УНЧ
Всем привет! Как известно для питания УНЧ часто используют импульсные блоки питания. Однако, они не...

Переделка теста для работы в сети
Здравствуйте. Есть тестирующая программа, которая использует БД сделанную Access. Теперь необходимо...

Переделка кода СИ ( для знающих 1 мин. времени)
Переделать код с одного условия на другое. Ключевые слова выделены жирным. Z Найти в каждой...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru