Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/6: Рейтинг темы: голосов - 6, средняя оценка - 4.67
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
1

Ввести число в строке табличного поля

18.04.2014, 12:49. Просмотров 1108. Ответов 4
Метки нет (Все метки)

Ввести число в строке табличного поля, ввожу и ничего не изменяется...(((

1C
1
2
3
4
5
6
7
8
9
10
    ТзНакл = Новый ТаблицаЗначений;
    Н = 1;
    Если ПроставитьРазвоз Тогда
        Если ВвестиЧисло(Н,"Введите порядковый номер текущей накладной в развозе") = 1  Тогда Возврат КонецЕсли;                
        Для Каждого Строка из ТзНакл.Колонки.Количество()-1   Цикл
            СтрокаТз = Строка.Получить(Н);
 
        КонецЦикла;
            Н = Н + 1;
    КонецЕсли;
Добавлено через 9 минут
В табличном поле есть число, его просто надо заменить на другую
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
18.04.2014, 12:49
Ответы с готовыми решениями:

Отчет СКД. Пересчет значения поля табличного документа при изменении другого поля
Народ, есть отчет без СКД, нужно разрешить ввод пользователем 5 графы отчета, и на основе...

Разные типы цен в одной строке табличного поля
Платформа 8.2. Необходимо вывести разные типы цен из регистра Цены номенклатуры в табличное поле...

Автозаполнение Табличного Поля
Доброго времени суток! Подскажите как присвоить табличному полю значение реквизита справочника (1С...

Итог по столбцу табличного поля
Доброго времени, нужна помощь, 1С начал познавать совсем недавно, и не по своей воле) конфа 8.3 УТ...

Программное изменение табличного поля
Товарищи, подскажите пожалуйста, возникла такая проблема. В обработке пытаюсь программно создать...

4
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,802
18.04.2014, 15:44 2
felicita_091, тебе надо проставить это введенное число во всех строках таб. поля? Потому что по твоему коду вообще ничего не понятно.
1C
1
2
3
4
5
6
7
8
9
10
  ТзНакл = Новый ТаблицаЗначений; //здесь создается пустая таблица значений, ни колонок, ни строк в ней нет
    Н = 1;
    Если ПроставитьРазвоз Тогда
        Если ВвестиЧисло(Н,"Введите порядковый номер текущей накладной в развозе") = 1  Тогда Возврат КонецЕсли;               
        Для Каждого Строка из ТзНакл.Колонки.Количество()-1   Цикл //Что это?? ТзНакл без колонок и строк вообще.
            СтрокаТз = Строка.Получить(Н); //СтрокаТЗ - это что?
 
        КонецЦикла;
            Н = Н + 1;
    КонецЕсли;
0
Gokusa
Заблокирован
18.04.2014, 16:46 3
я так понял смысл для каждой строки таблицы значений вызвать диалог в котором ввести цифирь.
правильно я понял?
0
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
18.04.2014, 17:13  [ТС] 4
Gokusa, да
0
Gokusa
Заблокирован
18.04.2014, 17:40 5
кароч смысл такой
в цикле, возможно бесконечном, делаем диалог запроса к пользователю возможно через вашу функцию "ВвестиЧисло", если функция возвращает что нужно, добавляем строку к таблице, если не возвращает, то выходим из цикла.
з.ы. че там в функции ввестичисло() я не знаю
1C
1
2
3
4
5
6
7
8
9
10
11
ТЗ = новый таблицазначений;
тз.колонки.добавить("имяколонки");//кажется такой синтаксис
Пока Истина цикл
 
Если ввестичисло(Н,"Введите порядковый номер текущей накладной в развозе") = 1 тогда
//если ввели число тогда добавляем в таблицу новую строку и пишем в колонку этой строки цифирь нашу, куда ////вы там её записали я не знаю
НоваяСтрокаТЗ = ТЗ.добавить();
НоваяСтрокаТЗ.имяколонки = введенноеВамиЧисло;//которое вы получаете или где-то теряете в функции //"Ввестичисло"
иначе прервать;//выход из бесконечного цикла
конецесли;
конеццикла
Добавлено через 2 минуты
возможно:
введенноеВамиЧисло = Н;
1
18.04.2014, 17:40
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
18.04.2014, 17:40

Заполнение табличного поля из запроса
Столкнулся с такой проблемой: есть один документ, у него несколько табличных частей которые...

Как изменить данные табличного поля?
1С 8.2. УПП 1.3 Всем доброго времени суток! Каким образом можно изменить данные табличного...

Привязки (обычная форма) табличного поля
Анамнез: Копированием типовой БП2.Документы.СчетНаОплатуПокупателя.ФормаДокумента создана форма...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru