Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
kaspergreen
0 / 0 / 0
Регистрация: 20.03.2007
Сообщений: 2
1

Получение информации из подчинённого справочника 7.7

21.04.2014, 13:25. Просмотров 557. Ответов 2
Метки нет (Все метки)

Добрый форумчанам день или какое там у вас время суток.

Раньше не приходилось сталкиваться с этой платформой и программировал только на PHP/MySQL/JavaScript.

Понадобилось получать на сайт информацию о номенклатуре из базы 1С, пока всё на, что меня хватило за прошедние пару дней гугления вот:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Процедура Сформировать()
        Запрос = СоздатьОбъект("Запрос");     
        ТекстЗапроса =
            
            "//{{ЗАПРОС(Сформировать)
            |ТекущийЭлемент = Справочник.Номенклатура.ТекущийЭлемент;
            |Наименование = Справочник.Номенклатура.Наименование;
            |Код = Справочник.Номенклатура.Код;    
 
            |ВключатьВВедомость = Справочник.Номенклатура.ВключатьВВедомость;
            |Группировка Наименование Упорядочить По Наименование.Наименование;  
 
            |Условие(ВключатьВВедомость = 1);
            |"//}}ЗАПРОС
 
            ;
 
 
        
        Если Запрос.Выполнить(ТекстЗапроса) = 1 Тогда
            Сообщить(Запрос.Наименование);
        КонецЕсли;  
        
        Пока Запрос.Группировка("Наименование") = 1 Цикл
            Сообщить(Запрос.Наименование);
        КонецЦикла;
КонецПроцедуры
Требуется получить оптовую и розничную цены, и если скулем просто сделал бы джойн по ключу с условием, то здесь работа с подчинёнными справочниками вводит в ступор.

Заранее спасибо.

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.04.2014, 13:25
Ответы с готовыми решениями:

Получение реквизита справочника
в 1с только начинаю разбиратся по работе , так что сильно не пинайте ;-) Есть обработка котрая...

Получение значения из справочника
Добрый день. Заранее прошу прощения за вопрос (он очень легок), но я только начал изучать и не могу...

Получение реквизита из справочника
Знаю, что вопрос очень легкий, и наверняка на него уже есть тысяча ответов, но я с 1C еще не успел...

Отображение информации в списке справочника
Добрый день, подскажите как это реализовать. Есть справочник в нем список из 3 колонок: Дата,...

Получение значения реквизита справочника в документ
Добрый день, есть вопрос Как сделать чтобы реквизит табличной части документа получал данные из...

2
nmcf
6531 / 5755 / 2621
Регистрация: 14.04.2014
Сообщений: 24,493
21.04.2014, 14:17 2
Делай отбор по владельцу.
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
22.04.2014, 00:06 3
Цитата Сообщение от KasperGreen Посмотреть сообщение
сделал бы джойн по ключу с условием
Абсолютно то же, только на русском
ЛЕВОЕ СОЕДИНЕНИЕ ПодчТаблица По ОснТаб.Ссылка=ПодчТаб.Владелец
можно LEFT JOIN.
У подчинённого обязательное поле Владелец, имеющее тип СправочникСсылка

Добавлено через 2 минуты
Ай! Извини, дорогой. Не посмотрел, что 77.
В 77 джойн делает сама система, просто указываешь в одном поле Спр1.Элемент, Спр2.Родитель
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.04.2014, 00:06

Получение значения реквизита справочника
Здравствуйте. Не как не получается в документе выудить данные со справочника. Есть справочник-...

Получение реквизита из справочника в табличную часть документа
Помогите пожалуйста! Как только ни пробовала, не могу понять в чем дело.... Есть справочник...

Получение реквизита из справочника в табличную часть документа
Доброе время суток!Скорее всего мой вопрос очень глупый , но прошу помочь. имеем справочник...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru