Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.63/38: Рейтинг темы: голосов - 38, средняя оценка - 4.63
megabax
7 / 7 / 6
Регистрация: 06.08.2009
Сообщений: 323
1

V8: Как подключиться к COM 7.7. из 8.3?

30.04.2014, 14:12. Просмотров 7274. Ответов 8
Метки нет (Все метки)

Делаю так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
РежимOLE=ложь;
попытка
OLE=Новый COMОбъект("V77S.Application");
Исключение
сообщить("Ошибка, пытаемся по другому "+ОписаниеОшибки());
Попытка 
OLE=Новый COMОбъект("V77.Application");
Исключение
АльтПредупреждение("Ошибка "+ОписаниеОшибки());
КонецПопытки;
КонецПопытки;
Если OLE.Initialize(OLE.RMTrade,?(РежимOLE,"/M","")+" /D"""+СокрЛП(ПутьКБД)+""" /N"+Пользователь+" /P"+СокрЛП(Пароль),"NO_SPLASH_SHOW")=0 Тогда
АльтПредупреждение("Ошибка установки связи с приложением!");
OLE=0;
Возврат;
КонецЕсли;
Говорит:

"Ошибка, пытаемся по другому {ВнешняяОбработка.ЗагрузкаИЗТИС.МодульОбъекта(73)} : Ошибка при вызове конструктора (COMОбъект): -2147467262(0x80004002): Интерфейс не поддерживается : -2147467262(0x80004002): Интерфейс не поддерживается"
"Ошибка {ВнешняяОбработка.ЗагрузкаИЗТИС.МодульОбъекта(77)} : Ошибка при вызове конструктора (COMОбъект): -2147467262(0x80004002): Интерфейс не поддерживается : -2147467262(0x80004002): Интерфейс не поддерживается"
подскажите пожалуйста, как лечить?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.04.2014, 14:12
Ответы с готовыми решениями:

Не могу подключиться к сети Wfi МГТС Gpon. Пишет что винда не может подключиться
Скрины

При попытке подключиться к беспроводной сети пишет: "Windows не удалось подключиться к (имя)"
При попытке подключиться к беспроводной сети пишет: "Windows не удалось подключиться к (имя)"...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
30.04.2014, 16:51 2
В реестре как прописан? V77S или V77?

Добавлено через 2 минуты
у меня на компе V77.Application,
0
Dethmontt
Модератор
Эксперт 1С
2649 / 2439 / 418
Регистрация: 10.03.2011
Сообщений: 8,732
Записей в блоге: 1
Завершенные тесты: 1
30.04.2014, 18:51 3
На клиенте или на сервере?
0
megabax
7 / 7 / 6
Регистрация: 06.08.2009
Сообщений: 323
30.04.2014, 21:38  [ТС] 4
Цитата Сообщение от duk337 Посмотреть сообщение
В реестре как прописан? V77S или V77?
В какой ветви это искать?

Добавлено через 31 секунду
Цитата Сообщение от Dethmontt Посмотреть сообщение
На клиенте или на сервере?
Коннектиться пытается в процедуре, которая выполняется на сервере
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
30.04.2014, 22:01 5
Цитата Сообщение от megabax Посмотреть сообщение
В какой ветви это искать?
ну типа HKCLSRoot.CLSID. Да тупо поиском по v77, пока application не попадётся
0
Dethmontt
Модератор
Эксперт 1С
2649 / 2439 / 418
Регистрация: 10.03.2011
Сообщений: 8,732
Записей в блоге: 1
Завершенные тесты: 1
01.05.2014, 01:19 6
Application не поддерживается на сервер.

Добавлено через 22 секунды
Подключайся &НаКлиенте
0
megabax
7 / 7 / 6
Регистрация: 06.08.2009
Сообщений: 323
01.05.2014, 15:21  [ТС] 7
Цитата Сообщение от Dethmontt Посмотреть сообщение
Application не поддерживается на сервер.
попробовал так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура Проба(Команда)
    //мРубли=Константы.ВалютаРегламентированногоУчета.Получить();
    
    РежимOLE=ложь;
    попытка
        OLE=Новый COMОбъект("V77S.Application");
    Исключение
        сообщить("Ошибка, пытаемся по другому "+ОписаниеОшибки());
        Попытка          
          OLE=Новый COMОбъект("V77.Application");
        Исключение
           сообщить("Ошибка "+ОписаниеОшибки());
        КонецПопытки;
    КонецПопытки;
    Если OLE.Initialize(OLE.RMTrade,?(РежимOLE,"/M","")+" /D"""+СокрЛП(Объект.ПутьКБД)+""" /N"+Объект.Пользователь+" /P"+СокрЛП(Объект.Пароль),"NO_SPLASH_SHOW")=0 Тогда
        Предупреждение("Ошибка установки связи с приложением!");
        OLE=0;
        Возврат;
    КонецЕсли;
КонецПроцедуры
Тоже самое
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
01.05.2014, 17:29 8
убери таки "s" . Это имя ехешника

Добавлено через 50 секунд
А! Виноват, не дочитал

Добавлено через 37 секунд
хотя, лучше исключение не вызывать

Добавлено через 21 минуту
Ты его в реестре-то видел?

Добавлено через 40 секунд
на клиенте
0
Dethmontt
Модератор
Эксперт 1С
2649 / 2439 / 418
Регистрация: 10.03.2011
Сообщений: 8,732
Записей в блоге: 1
Завершенные тесты: 1
02.05.2014, 02:09 9
А 7.7 то установлена?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Загружена = Ложь;
Попытка          
    OLE=Новый COMОбъект("V77.Application");
    Загружена = Истина;
Исключение
     сообщить("Ошибка "+ОписаниеОшибки());
КонецПопытки;
Если Загружена Тогда    
    Если OLE.Initialize(OLE.RMTrade,?(РежимOLE,"/M","")+" /D"""+СокрЛП(Объект.ПутьКБД)+""" /N"+Объект.Пользователь+" /P"+СокрЛП(Объект.Пароль),"NO_SPLASH_SHOW")=0 Тогда
        Предупреждение("Ошибка установки связи с приложением!");
        OLE=0;
        Возврат;
    КонецЕсли;
КонецЕсли;
0
02.05.2014, 02:09
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru