Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/3: Рейтинг темы: голосов - 3, средняя оценка - 4.67
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
1

Процедура документа

30.04.2014, 21:32. Просмотров 630. Ответов 10
Метки нет (Все метки)

Добрый вечер! Помогите пожалуйста переделать этот код на 8.2. с добавлением в него условия, что если количество остаток меньше 10, нужно раскрасить строку красным цветом ((( у самой не получается выполнить процедуру ((((
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
Процедура ОбработкаПроведения(Отказ, Режим)
Запрос=Новый Запрос;
Запрос.Текст="Выбрать
| ЗаказПокупателяСостав.Номенклатура,
| Сумма(ЗаказПокупателяСостав.Количество)КАК Количество,
| ЕСТЬNULL(ОстаткиМатериаловОстатки.КоличествоОстаток,0)
| КАК Остаток,
| ЕСТЬNULL(РезервыНоменклатурыОстатки.КоличествоОстаток,0)
| КАК Резерв
|ИЗ
|Документ.ЗаказПокупателя.Состав КАК ЗаказПокупателяСостав
| Левое Соединение
| РегистрНакопления.ОстаткиМатериалов.Остатки(
| &Момент,
| Материал В (ВЫБРАТЬ РАЗЛИЧНЫЕ
| ЗаказПокупателяСостав.Номенклатура
| ИЗ
| Документ.ЗаказПокупателя.Состав
| КАК ЗаказПокупателяСостав
| ГДЕ
| ЗаказПокупателяСостав.Ссылка=
| &Ссылка))
| КАК ОстаткиМатериаловОстатки
|ПО ЗаказПокупателяСостав.Номенклатура=
| ОстаткиМатериаловОстатки.Материал
| Левое Соединение
| РегистрНакопления.РезервыНоменклатуры.Остатки(
| &Момент,
| Номенклатура В (ВЫБРАТЬ РАЗЛИЧНЫЕ
| ЗаказПокупателяСостав.Номенклатура
| ИЗ
| Документ.ЗаказПокупателя.Состав
| КАК ЗаказПокупателяСостав
| ГДЕ
| ЗаказПокупателяСостав.Ссылка=
| &Ссылка)) КАК РезервыНоменклатурыОстатки
| ПО ЗаказПокупателяСостав.Номенклатура=
| РезервыНоменклатурыОстатки.Номенклатура
| ГДЕ
| ЗаказПокупателяСостав.Ссылка=
| &Ссылка
| СГРУППИРОВАТЬ ПО| ЗаказПокупателяСостав.Номенклатура,
| РезервыНоменклатурыОстатки.КоличествоОстаток,
|ОстаткиМатериаловОстатки.КоличествоОстаток
|ДЛЯ ИЗМЕНЕНИЯ
| РегистрНакопления.РезервыНоменклатуры.Остатки;";
Запрос.УстановитьПараметр("Ссылка" ,Ссылка);
Запрос.УстановитьПараметр("Момент" ,МоментВремени());
Результат=Запрос.Выполнить();
Выборка=Результат.Выбрать();
Пока Выборка.Следующий() Цикл
Нехватка=Выборка.Количество-(Выборка.Остаток-Выборка.Резерв);
Если Нехватка>0 Тогда
Сообщить ("Нехватка товара "+СОКРЛП(Выборка.Номенклатура)+":
"+Нехватка);
Сообщить ("Заказ покупателя " + Номер+"от "+Дата+" документ не
проводится");
Отказ=Истина;
КонецЕсли;
Если Не Отказ Тогда
Движение = Движения.РезервыНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = Выборка.Номенклатура;
Движение.Количество = Выборка.Количество;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
30.04.2014, 21:32
Ответы с готовыми решениями:

Процедура обработки проведения документа
Документ Оказание услуг при оперативном проведение нужно чтобы бролась цена на дату проведения и...

Процедура для переписи строки табличной части документа в поле справочника
Здравствуйте. Пожалуйста помогите. Столкнулся с такой проблемой: существует справочник Сотрудники с...

Оповещение о скором истечении документа, выполнение документа, истечение документа
Плохо разбираюсь в 1С. Помогите пожалуйста реализовать, чтоб когда документ подходил к истечению...

С формы списка документа изменить данные самого документа 1С 8.2 Управляемое приложение
Есть документ ЗаказКлиента с формой документа и с формой списка (формы управляемые). Есть у...

Как изменить текст надписи формы документа при записи документа
Здравствуйте уважаемые, у меня простой вопрос - как мне при записи документа изменить надпись на...

10
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
30.04.2014, 22:08 2
без отладчика геморно
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
30.04.2014, 22:13  [ТС] 3
Вообще никак? Просто это лабораторная... я уже две недели пытаюсь по книжкам найти без результата (((( где вообще эту лабу взяли не понятно
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
30.04.2014, 23:20 4
дык базу выкладывай

Добавлено через 1 минуту
раскрасить - это одно. Причём в толстом и тонком по-разному.
Запрос - это другое, тут вообще без базы делать нефиг

Добавлено через 2 минуты
Или лаба - это текст процедуры, а к ней надо базу присобачить?
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
30.04.2014, 23:32  [ТС] 5
часть 1.doc

часть 2.doc

часть 3.doc
Вот текст лабы, но для 8.1 а базу что то не получается прикрепить(((
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
30.04.2014, 23:34  [ТС] 6
Изначально задание было такое, в своих базах сделать вот этот контроль отрицательных остатков, и когда идет проверка остатков по регистру выделять цветом строку количество которых меньше 10
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
30.04.2014, 23:38  [ТС] 7
вот база8.2. измененная.rar
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
02.05.2014, 18:50  [ТС] 8
Ну так что, вы мне поможете разобраться с процедурой?
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.05.2014, 21:27 9
Цитата Сообщение от kristi48 Посмотреть сообщение
Ну так что, вы мне поможете разобраться с процедурой?
А где Заказ покупателя?
Скопируйте для начала ПриходнуюНакладную (поскольку Реализации нет) и переделайте как хочется, первым делом заменив имя на ЗаказПокупателя. В модуль объекта вставьте приведённый текст.
0
kristi48
0 / 0 / 0
Регистрация: 27.03.2014
Сообщений: 83
02.05.2014, 21:52  [ТС] 10
Я просто хотела это через другие документы сделать, вместо ЗаказПокупателя использовать документ - Договор на производство и отслеживать списание комплектующих в документе Лимитно-Заборная Карта через регистр остатки на складе комплектующих... в итоге я окончательно запуталась, ничего не получается... вроде поменяла названия, в итоге куча ошибок...
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
02.05.2014, 23:49 11
Вам же задание создать новый документ. Зачем ломать существующие?
Уясните алгоритм: заказ покупателя - это реализация. А ЛЗК - это производство. Со складом оно может быть связано только по закупленным комплектующим. А заказывать наверняка будут готовую продукцию.
0
02.05.2014, 23:49
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.05.2014, 23:49

Из одного документа получить данные табличной части другого документа
Добрый день. Сразу оговорюсь 1С только начал изучать, поэтому просьба помидорами не закидывать. ...

Изменить значение реквизитов ТЧ документа по событию проведения другого документа
Здравствуйте.В собственной конфе 1С 8.3 есть документ "ОбъектныйГрафик" с ТЧ "Задания". Также есть...

Как из одного документа перенести значение из табличной части в реквизит другого документа?
Только начинаю осваивать 1С, учебная задача. Есть два документа "Индивидуальный заказ" и...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
11
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru