Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
MDasha
0 / 0 / 1
Регистрация: 22.11.2011
Сообщений: 40
1

Как вывести долг

05.05.2014, 13:43. Просмотров 938. Ответов 4
Метки нет (Все метки)

Подскажите пожалуйста как вывести сумму строк где нет отметки об оплате в поле ДОЛГ
Как вывести долг
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
05.05.2014, 13:43
Ответы с готовыми решениями:

УТ 10.3 Вытащить долг по Таре
Добрый день, вообщем я совсем еще начинающий, учусь так сказать программировать на 1с, дали задание...

Вывести на печать телефонные номера, что начинаются на 22, которые имеют наибольший долг
задание: список абонентов телефонной сети:почтовый номер , ФИО , адрес , номер телефона (ввести по...

Как сделать чтобы выводилось имя и долг человека в конце программы, когда должников не один а несколько?
Это задача в которой ввожу количество пользователей,имя и долг.У кого долг больше 30000...

Долг контрагента
Доброго дня суток! Подскажите пожалуйста! Откуда берется или вычисляется долг контрагента?

Долг Саида хану
Долг Саида хану составляет 900 золотых. За хорошую работу хан каждый год сокращает долг в 3 раза,...

4
nmcf
6525 / 5749 / 2621
Регистрация: 14.04.2014
Сообщений: 24,493
05.05.2014, 15:24 2
Программно, наверное.
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
05.05.2014, 17:43 3
Долг = ?("Оплата" = Пусто, СуммаОплаты , 0 );
0
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
05.05.2014, 18:31 4
Лучший ответ Сообщение было отмечено MDasha как решение

Решение

MDasha, как вариант - на событие изменения табличной части
1C
1
2
3
4
5
6
7
8
9
&НаКлиенте
Процедура ТабличнаяЧастьПриИзменении(Элемент)
 Объект.Долг = 0;//если это реквизит документа, а не формы
 Для Каждого ТекСтр Из ТабличнаяЧасть Цикл
    Если Не ЗначениеЗаполнено(ТекСтр.Оплата) Тогда
       Объект.Долг = Объект.Долг + ТекСтр.СуммаОплаты;
    КонецЕсли;
 КонецЦикла;
КонецПроцедуры
, где ТабличнаяЧасть = имя вашей ТЧ документа.
1
MDasha
0 / 0 / 1
Регистрация: 22.11.2011
Сообщений: 40
05.05.2014, 20:04  [ТС] 5
Спасибо Вам огромнейшее!!!
0
05.05.2014, 20:04
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.05.2014, 20:04

Долг контрагента. Почему?
Помогите пожалуйста.. запросили акт сверки взаиморасчетов. Делаю, а в акте по нашим данным и по...

Вычислить долг предприятия от поставщиков
Здравствуйте, нужна помощь необходимо вычислить долг предприятия от поставщиков не знаю как это...

Оплату и долг отфильтровать по кварталу и году
Добрый вечер, форумчане. У меня такая проблемма. Делаю лабораторную работу, по базам данных и на...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru