Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
1

Процедура на событие отчистки, т.е. вернуть отбор

08.05.2014, 12:18. Просмотров 853. Ответов 12
Метки нет (Все метки)

Подскажите пожалуйста как написать модуль для процедуры отчистки, я написала процедуру на отбор:

1C
1
2
3
4
5
6
7
8
9
10
11
&НаКлиенте
Процедура ТекущийВрачПриИзменении(Элемент)
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Врач");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение=ТекущийВрач; 
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
КонецПроцедуры
А как вернуть отбор незнаю, буду благодарна подсказке, заранее спасибо!
0
Миниатюры
Процедура на событие отчистки, т.е. вернуть отбор  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.05.2014, 12:18
Ответы с готовыми решениями:

Как правильно настроить фильтр Фомы (Событие.Загрузка) + отбор по дате и статусу
Здравствуйте, подскажите пожалуйста Как правильно прописать настройки в VB(или Макросами) при...

Процедура: вернуть сумму и среднее арифметическое элементов массива
Cоздать процедуру, которая для заданного одномерного массива размерностью n элемнтов , возвратит...

цикл отчистки
всем привет, возник вопрос как сделать цикл удаления, а точнее отчистки определённой ячейки во...

Процедура на событие OnClick
Привет! ребята помогите разобраться плз... пишу свой класс, в конструкторе создаю контекстное меню...

Ждать событие и только тогда вернуть значение из функции
public override int Execute() { mouseHook.Start(); return 1; }...

12
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 13:17 2
yuliya1992,
1C
1
Список.Отбор.Элементы.Очистить();
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 13:29  [ТС] 3
Спасибо, сделала, а подскажите еще пожалуйста как сделать чтобы когда я отменяю отбор, мне показывались все записи в списке документа? Ведь так он очищается
0
Миниатюры
Процедура на событие отчистки, т.е. вернуть отбор  
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 13:35 4
yuliya1992, Можете попробовать так: в модуле основной формы на поле "ТекущийВрач" - процедура при очистки - вставьте код
1C
1
Список.Отбор.Элементы.Очистить();
И для ТекущегоПациента тоже самое.
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 13:48  [ТС] 5
Я вставила и он мне просто очищает, а нужно чтобы показывал все созданные документы
0
Миниатюры
Процедура на событие отчистки, т.е. вернуть отбор  
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 13:50 6
yuliya1992, А покажите ваш код этого списка, а то так гадать тяжело...
и запрос динамического списка. Возможно в нем и суть.
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 13:54  [ТС] 7
вот код списка полностью:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
&НаКлиенте
Процедура ТекущийВрачПриИзменении(Элемент)
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Врач");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение=ТекущийВрач; 
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущийПациентПриИзменении(Элемент)
    
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Пациент");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение=ТекущийПациент;
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
    
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущаяДатаПриИзменении(Элемент)
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Дата");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Больше;
    ЭлементОтбора.ПравоеЗначение=НачалоДня(ТекущаяДата);
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
    ЭлементОтбора=Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение=Новый ПолеКомпоновкиДанных("Дата");
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ВидСравнения=ВидСравненияКомпоновкиДанных.Меньше;
    ЭлементОтбора.ПравоеЗначение=НачалоДня(ТекущаяДата)+86400;
    ЭлементОтбора.РежимОтображения=РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Обычный;
    Элементы.Список.Обновить();
 
КонецПроцедуры
 
 
&НаКлиенте
Процедура ТекущийВрачОчистка(Элемент, СтандартнаяОбработка)
    
Список.Отбор.Элементы.Очистить();
 
    КонецПроцедуры
 
 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
ЭлементОформления=Список.УсловноеОформление.Элементы.Добавить();
    ЭлементОтбора=ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Остаток");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.НеРавно;
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ПравоеЗначение=0;
    Элемент=ЭлементОформления.Оформление.Элементы[1];
    Элемент.Использование=Истина;
    Элемент.Значение=Новый Цвет (255,0,0);
    
    ЭлементОформления=Список.УсловноеОформление.Элементы.Добавить();
    ЭлементОтбора=ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Итого");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.Использование=Истина;
    ЭлементОтбора.ПравоеЗначение=0;
    Элемент=ЭлементОформления.Оформление.Элементы[1];
    Элемент.Использование=Истина;
    Элемент.Значение=Новый Цвет (0,0,255);
 
    КонецПроцедуры
 
 
&НаКлиенте
    Процедура ТекущийПациентОчистка(Элемент, СтандартнаяОбработка)
        Список.Отбор.Элементы.Очистить();
    КонецПроцедуры
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.05.2014, 13:58 8
Лучше работать Использование=, а не добавлять/очищать
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 14:06  [ТС] 9
А можно поподробней объяснить
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 14:09 10
yuliya1992,

1C
1
2
3
4
5
6
7
8
9
10
11
12
&НаКлиенте
Процедура ТекущийВрачОчистка(Элемент, СтандартнаяОбработка)
ЭлементыОтбора = Список.Отбор.Элементы;
Для каждого Эл из ЭлементыОтбора Цикл
    
    Если Эл.Представление = "Врач" Тогда 
        Эл.Использование = Ложь;
    КонецЕсли;
 
КонецЦикла;
 
 КонецПроцедуры
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
08.05.2014, 14:16  [ТС] 11
SPR1TE89, не получается, все равно пусто, не выводить обратно список созданных документов
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.05.2014, 16:19 12
yuliya1992, похоже, у Вас элементы отбор не синхронизированы с событиями изменений значений в соотв. полях. То Врач, то Клиент.
Наведите порядок:
Создайте при открытии весь отбор с Использование=Ложь каждого элемента.
Далее, при изменении значений, соответствующих элементам отбора, уже ставьте Использование и значение для своего-каждого отдельно.
пустое значение - Исп=Ложь, Заполнено - Истина и Отбор.ВрачПоциентСестра.Значение=...
0
yuliya1992
0 / 0 / 0
Регистрация: 19.03.2014
Сообщений: 8
10.05.2014, 10:56  [ТС] 13
Спасибо всем! Разобралась!
0
10.05.2014, 10:56
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.05.2014, 10:56

Метод для отчистки текстового файла
Как можно отчистить текстовый документ?

Отбор на быстрый отбор СКД
Всем привет. Подскажите кто-нить, чойта туплю. Есть простой отчет на СКД, в макете компоновки...

Вернуть самое длинное слово, Вернуть словарь-статистику встречаемости букв
Всем добрый день ! Написал 2 функции: def longest_word(text): """Вернуть самое длинное слово...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru