Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.56/9: Рейтинг темы: голосов - 9, средняя оценка - 4.56
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
1

Макет отчета

08.05.2014, 13:50. Просмотров 1768. Ответов 24
Метки нет (Все метки)

Нужно разбить ТипАдреса на Регион и Минск
Например.. В отчете есть колонка Мин и Рег, сумма и количество...Табличное поле есть Тип адреса Минск, регионы и минский район. когда сформулирую отчет, в колонке Мин только Минский район, Минск, сумма и количество, а во втором Только регионы сумма и количество. а у меня там получается все в одном колонке Мин
Пример кода:
Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
Процедура РегионыМинск ()
    
    Таб = Новый ТабличныйДокумент;
    Таб.АвтоМасштаб = Истина;
    Таб.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    //Таб.ОтображатьСетку = Ложь;
    Макет = ПолучитьМакет("СоотношениеПоБренду");
    
    СтруктураПараметровЗаголовки = Новый Структура;
    ЗаголовокМакета = Макет.ПолучитьОбласть("Заголовок");
    ЗаголовокМакета.Параметры.Заполнить(СтруктураПараметровЗаголовки);
    Таб.Вывести(ЗаголовокМакета);
 
    
    ШапкаМакета = Макет.ПолучитьОбласть("Шапка");
    Таб.Вывести(ШапкаМакета);
    
    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Бренды");
    ТЗ.Колонки.Добавить("Адрес");
    ТЗ.Колонки.Добавить("Менеджер");
    ТЗ.Колонки.Добавить("ТипАдреса");
    ТЗ.Колонки.Добавить("КолВо");
    ТЗ.Колонки.Добавить("Сумма");
    ЭлементыФормы.Регионы.Значение = ТЗ;
    ЭлементыФормы.Регионы.СоздатьКолонки();
    
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ОтгрузкаТМЦ.ТМЦ,
    |   ОтгрузкаТМЦ.Регистратор,
    |   ОтгрузкаТМЦ.Количество,
    |   ОтгрузкаТМЦ.СуммаВсего
    |ИЗ
    |   РегистрНакопления.ОтгрузкаТМЦ КАК ОтгрузкаТМЦ
    |ГДЕ
    |   ОтгрузкаТМЦ.Период МЕЖДУ &ДатаНач И &ДатаКон";  
        
 
    Запрос.УстановитьПараметр("ДатаНач",(ЭлементыФормы.НачДата.Значение));           
    Запрос.УстановитьПараметр("ДатаКон",(ЭлементыФормы.КонДата.Значение));  
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();  
    
    Пока Выборка.Следующий() Цикл
        Если ТипЗнч(Выборка.Регистратор ) = Тип("ДокументСсылка.РасходнаяНакладнаяТМЦ") или ТипЗнч(Выборка.Регистратор ) = Тип("ДокументСсылка.ВозвратнаяНакладнаяТМЦ")Тогда            
            ТзСтрока = ТЗ.Добавить();
            ТзСтрока.Бренды = Выборка.ТМЦ.КлассификаторТМЦ;
            ТзСтрока.Адрес = Выборка.Регистратор.Ссылка.Адрес;
            ТзСтрока.Менеджер = Выборка.Регистратор.Ссылка.Менеджер;
            ТзСтрока.ТипАдреса = ТипАдреса(Выборка.Регистратор.Ссылка.Адрес,Выборка.Регистратор.Ссылка.Менеджер);
            ТзСтрока.КолВо = Выборка.Количество;
            ТзСтрока.Сумма = Выборка.СуммаВсего;
        Иначе
            //Сообщить(ТипЗнч(Выборка.Регистратор)) 
        КонецЕсли;
    КонецЦикла;
    
    
    Тз.Свернуть("Бренды,ТипАдреса, Адрес,Менеджер","КолВо,Сумма");
    
 
    //Вывод строки табличного документа
    Для Каждого ТзСтрока Из Тз Цикл
            СтруктураПараметровСтроки = Новый Структура;    
            СтруктураПараметровСтроки.Вставить("Бренды", ТзСтрока.Бренды);
            СтруктураПараметровСтроки.Вставить("Адр",    ТзСтрока.Адрес);
            СтруктураПараметровСтроки.Вставить("Мен",    ТзСтрока.Менеджер);
            СтруктураПараметровСтроки.Вставить("шт",     ТзСтрока.КолВо);
            СтруктураПараметровСтроки.Вставить("сумма",  ТзСтрока.Сумма);
            СтрокаМакета = Макет.ПолучитьОбласть("Строка");
            СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
            Таб.Вывести(СтрокаМакета);
    КонецЦикла;
    
                    
    Таб.Показать("Соотношение по бренду");


Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Функция ТипАдреса(Адрес, Менеджер)   
    
    Если (Найти(Врег(Адрес),"МИНСК ")) или (Найти(Врег(Адрес),"МИНСК,")) или (Найти(Врег(Адрес),"МИНСК.")) Тогда 
        
        Возврат "Минск";
    Иначе
        Если ОтношениеМенеджеров.НайтиПоЗначению(Менеджер)= Неопределено Тогда
            Возврат "Регионы";
        Иначе
            //Сообщить(Адрес);
            Возврат "Минский район";
        КонецЕсли;
        
    //Сообщить (ТзСтрока.ТипАдреса);        
    КонецЕсли;
                                           
 
КонецФункции
0
Миниатюры
Макет отчета   Макет отчета  
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.05.2014, 13:50
Ответы с готовыми решениями:

Макет отчета. Не получается Вывод данных о сумме в макет
Не могу разобраться с применением метода Присоединить к ТабДоку. В частности с выводом данных...

Как написать макет отчета
Подскажите как написать макет отчета? Необходимо чтобы при выборе даты и типа оборудования...

Прикрепить макет оформления к варианту отчета
Я создал отчёт Шахматка,в котором есть 2 варианта его оформления: СводныеПроводки и...

Вывод на макет отчета текущего пользователя
Здравствуйте. Платформа 1С: Предприятие 8.3. Управляемая форма. Подскажите в таком вопросе....

Как сделать свой макет для отчета
Имеется отчет. Данные берутся на основе запроса на скрине. Необходимо сделать шапку отчета не ту,...

24
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
08.05.2014, 13:55  [ТС] 2
Исправила:
0
Миниатюры
Макет отчета  
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 13:55 3
felicita_091, Поставьте условие на проверку адреса, когда выводите данные в табличный документ.
0
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
08.05.2014, 13:58  [ТС] 4
SPR1TE89, пример можно?
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
08.05.2014, 14:16 5
Лучший ответ Сообщение было отмечено felicita_091 как решение

Решение

Цитата Сообщение от felicita_091 Посмотреть сообщение
СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки)
Что-то типо:
1C
1
2
3
4
5
Если ТзСтрока.ТипАдреса = "Минск" Тогда
//Заполнить макет для Минска
Иначе 
//Заполнить макет для не Регионы
КонецЕсли;
И посмотрите параметры в Макете, у вас они не все заполнены скорее всего. Возможно там надо выставить параметры.
1
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
08.05.2014, 14:40  [ТС] 6
SPR1TE89, получилось, почему то по минску все заполнено
0
Миниатюры
Макет отчета   Макет отчета  
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
08.05.2014, 15:13  [ТС] 7
SPR1TE89, все спасибо большое, получилось))

Добавлено через 24 минуты
SPR1TE89, скажи как суммировать сумма+сумма1?
0
Dethmontt
Модератор
Эксперт 1С
2657 / 2445 / 420
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
08.05.2014, 15:37 8
сумма=сумма+сумма1;
0
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
08.05.2014, 15:45  [ТС] 9
Dethmontt, я делала таким способом, неправильно!!! Надо чтоб сумма(10) и сумма1(15) в ответ (25)
0
Dethmontt
Модератор
Эксперт 1С
2657 / 2445 / 420
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
08.05.2014, 15:53 10
1C
1
2
3
4
5
6
7
8
9
10
11
12
Процедура КакаяТО()
Сумма=0;
 
//Много много кода...
////......................
//Место где суммируем
Сумма = Сумма + ТвояЧисловаяПеременная; //(сумма1)
 
//Много кода еще
//Очень много
//.........................
КонецПроцедуры
0
SonicQ
283 / 183 / 18
Регистрация: 20.02.2012
Сообщений: 918
08.05.2014, 16:19 11
где-то тут сделать это

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
СуммаОбщ = 0;
 
Пока Выборка.Следующий() Цикл
        Если ТипЗнч(Выборка.Регистратор ) = Тип("ДокументСсылка.РасходнаяНакладнаяТМЦ") или ТипЗнч(Выборка.Регистратор ) = Тип("ДокументСсылка.ВозвратнаяНакладнаяТМЦ")Тогда            
            ТзСтрока = ТЗ.Добавить();
            ТзСтрока.Бренды = Выборка.ТМЦ.КлассификаторТМЦ;
            ТзСтрока.Адрес = Выборка.Регистратор.Ссылка.Адрес;
            ТзСтрока.Менеджер = Выборка.Регистратор.Ссылка.Менеджер;
            ТзСтрока.ТипАдреса = ТипАдреса(Выборка.Регистратор.Ссылка.Адрес,Выборка.Регистратор.Ссылка.Менеджер);
            ТзСтрока.КолВо = Выборка.Количество;
            ТзСтрока.Сумма = Выборка.СуммаВсего;
 
СуммаОбщ = СуммаОбщ  + Выборка.СуммаВсего;
 
        Иначе
            //Сообщить(ТипЗнч(Выборка.Регистратор)) 
        КонецЕсли;
    КонецЦикла;
а потом выводишь СуммаОбщ
1
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
12.05.2014, 11:23  [ТС] 12
SPR1TE89, как убрать лишнюю столбцу, или заполнить в следующую строку..
Кликните здесь для просмотра всего текста
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
СписокГрупп = Новый ТаблицаЗначений;
        
        
        СписокГрупп.Очистить();
        СписокГрупп = Тз.СкопироватьКолонки();
    
        Для каждого СтрокаТЗ Из Тз Цикл 
            ЗаполнитьЗначенияСвойств(СписокГрупп.Добавить(), СтрокаТЗ) 
        КонецЦикла; 
    
    Тз.Свернуть("Бренды,ТипАдреса","КолВо,Сумма");
    СписокГрупп.Свернуть("Бренды");
 
    //**********************Вывод строки табличного документа
    Для Каждого Группа Из СписокГрупп Цикл
        Сумма = 0;
        СтруктураПараметровСтрокиБренд = Новый Структура;   
        СтруктураПараметровСтрокиБренд.Вставить("Бренды", Группа.Бренды);
        СтрокаМакетаБренд = Макет.ПолучитьОбласть("Строка|Бренд");
        СтрокаМакетаБренд.Параметры.Заполнить(СтруктураПараметровСтрокиБренд);
        Таб.Вывести(СтрокаМакетаБренд); 
        
        
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Сообщить(ТзСтрока.ТипАдреса);
                Если Не(ТзСтрока.ТипАдреса = "Регионы") Тогда
                    Сумма=Сумма + ТзСтрока.Сумма;
                    СтруктураПараметровСтроки = Новый Структура;    
                    СтруктураПараметровСтроки.Вставить("шт",     ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма",  ТзСтрока.Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Мин");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
        
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    Сумма=Сумма + ТзСтрока.Сумма;
                    СтруктураПараметровСтроки = Новый Структура;    
                    СтруктураПараметровСтроки.Вставить("шт1",    ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма1",  ТзСтрока.Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Рег");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;   
        
 
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    СтруктураПараметровСтроки = Новый Структура;
                    СтруктураПараметровСтроки.Вставить("Всего",  Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Все");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
 
            
 
    КонецЦикла;
0
Миниатюры
Макет отчета  
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
12.05.2014, 11:28 13
felicita_091, В макете уберите параметры в этих столбцах. Так не будет лишних столбцов.
0
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
12.05.2014, 11:33  [ТС] 14
SPR1TE89, в макете нет лишних столбцов
0
Миниатюры
Макет отчета  
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
12.05.2014, 11:56 15
Видимо, вы с "Присоединить" перемудрили.
Я бы упростил макет. Снес на фиг имена областей по горизонтали ("Бренд", "мин" и т.д.).
И вместо трех циклов пользовал бы один.
Грубо говоря,
1C
1
2
3
4
5
6
7
8
9
10
 ОбластьСтрока= Макет.ПолучитьОбласть("Строка");
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                //Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                // нужный код по региону / не региону
                    ОбластьСтрока.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Вывести(ОбластьСтрока); 
                //КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
0
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
12.05.2014, 12:23  [ТС] 16
OrkVasya, не получается, подробно можно?

Добавлено через 14 минут
OrkVasya,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
        ОбластьСтрока= Макет.ПолучитьОбласть("Строка");
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    Сумма=Сумма + ТзСтрока.Сумма;
                    СтруктураПараметровСтроки = Новый Структура;
                    СтруктураПараметровСтроки.Вставить("шт",     ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма",  ТзСтрока.Сумма);
                    СтруктураПараметровСтроки.Вставить("шт1",    ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма1", ТзСтрока.Сумма);
                    СтруктураПараметровСтроки.Вставить("Всего",  Сумма);
                 ОбластьСтрока.Параметры.Заполнить(СтруктураПараметровСтроки);
                 Таб.Вывести(ОбластьСтрока); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
штук и штук 1 одинаковы
0
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
12.05.2014, 12:29 17
Мне сложно сказать, я не знаю, что у вас творится.
Посмотрите, как типовые печатные формы формируются и сделайте по такому же принципу.
Обычно делается структура, в которую пишутся все данные, потом уже данные из структуры идут в макет.
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
12.05.2014, 13:15 18
felicita_091,
Вам же вроде разделять надо было? Попробуйте так.
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
        ОбластьСтрока= Макет.ПолучитьОбласть("Строка");
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
              Сумма=Сумма + ТзСтрока.Сумма;
               СтруктураПараметровСтроки = Новый Структура;
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    СтруктураПараметровСтроки.Вставить("шт1",     ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма1",  ТзСтрока.Сумма);
               Иначе
                    СтруктураПараметровСтроки.Вставить("шт",    ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма", ТзСтрока.Сумма);
              КонецЕсли;
                    СтруктураПараметровСтроки.Вставить("Всего",  Сумма);
                    ОбластьСтрока.Параметры.Заполнить(СтруктураПараметровСтроки);
                 Таб.Вывести(ОбластьСтрока); 
                //КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
1
felicita_091
8 / 8 / 2
Регистрация: 24.10.2012
Сообщений: 429
12.05.2014, 13:43  [ТС] 19
SPR1TE89,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
 Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Сообщить(ТзСтрока.ТипАдреса);
                Если Не(ТзСтрока.ТипАдреса = "Регионы") Тогда  // я заменила ТипАдреса на "Минск" убрала Не 
//Если ТзСтрока.ТипАдреса = "Минск"
                    Сумма=Сумма + ТзСтрока.Сумма;
                    СтруктураПараметровСтроки = Новый Структура;    
                    СтруктураПараметровСтроки.Вставить("шт",     ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма",  ТзСтрока.Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Мин");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
        
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    Сумма=Сумма + ТзСтрока.Сумма;
                    СтруктураПараметровСтроки = Новый Структура;    
                    СтруктураПараметровСтроки.Вставить("шт1",    ТзСтрока.КолВо);
                    СтруктураПараметровСтроки.Вставить("сумма1",  ТзСтрока.Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Рег");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;   
        
 
        Для Каждого ТзСтрока Из Тз Цикл
            Если ТзСтрока.Бренды = Группа.Бренды Тогда
                Если ТзСтрока.ТипАдреса = "Регионы" Тогда
                    СтруктураПараметровСтроки = Новый Структура;
                    СтруктураПараметровСтроки.Вставить("Всего",  Сумма);
                    СтрокаМакета = Макет.ПолучитьОбласть("Строка|Все");
                    СтрокаМакета.Параметры.Заполнить(СтруктураПараметровСтроки);
                    Таб.Присоединить(СтрокаМакета); 
                КонецЕсли;  
            КонецЕсли; 
        КонецЦикла;
 
    КонецЦикла;
проблема в том что, столбец Минск заполнено, а по региону не все заполнено, а в Всего(Итого) должна быть прибавить Минск и регионы, если нету по регионам то вывести Минск..
0
Миниатюры
Макет отчета  
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
12.05.2014, 13:49 20
felicita_091, Просто когда вы присоединяете макет у вас и появляются лишние столбцы, вы поставьте верные условия!
И да слишком много вложенных циклов. Попробуйте все упростить до 1 цикла.

Так тяжело помочь не видя что у вас в строках запроса(или таблицы) получается
0
12.05.2014, 13:49
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.05.2014, 13:49

Как вывести таблицы в макет отчета через модуль объекта
Здравствуйте, есть внешний отчет, который читает информацию с документов поступления. У документа...

1C 8.1 Редактирование отчета созданного с помощью универсального отчета
Создал отчет с помощью универсального отчета, все работает, не получается сделать его "красивым"...

Макет
Попросили добавить на страницу еще 1ну копию печатоемого акта(на страница он занимает меньше...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru