Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/2: Рейтинг темы: голосов - 2, средняя оценка - 4.50
shiro93
1 / 1 / 0
Регистрация: 09.11.2011
Сообщений: 199
1

Подчиненные справочники, перечисление в нем и т.д

15.05.2014, 16:05. Просмотров 418. Ответов 1
Метки нет (Все метки)

Проблема с перечислением "Размер", Сообщить(спрДоч.Сотрудник.Размер); - выдает Неизвестный объект...в чем может быть причина
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
спрВлад = СоздатьОбъект("Справочник.ШтатноеРасписание");
    спрДоч = СоздатьОбъект("Справочник.СотрудникиШтатныхЕдиниц");
    ТЗ = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Сотр","Справочник.Сотрудники");
    спрВлад.ВыбратьЭлементы();
    
    Пока спрВлад.ПолучитьЭлемент() = 1 Цикл
        Если ТекущийЭлемент().Подразделение = спрВлад.ТекущийЭлемент().Подразделение Тогда
            Если СокрЛП(ТекущийЭлемент().Должность) = СокрЛП(спрВлад.ТекущийЭлемент().ШтатнаяЕдиница) Тогда
                спрДоч.ИспользоватьВладельца(спрВлад.ТекущийЭлемент());
                Если ПустоеЗначение(спрВлад.ТекущийЭлемент().НаборСпецодежды)=0 Тогда
                    спрДоч.ВыбратьЭлементы();
                    Пока спрДоч.ПолучитьЭлемент() = 1 Цикл
                        Сообщить(спрДоч.Сотрудник.Размер);
                    КонецЦикла;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
Добавлено через 14 минут
разобрался, все довольно просто было....просто это периодический реквизит))
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
15.05.2014, 16:05
Ответы с готовыми решениями:

Подчиненные справочники в 7.7
Имеется форма документа, где в шапке выбирается клиент (из справочника), а в табличной части...

Подчиненные Справочники В 1с 7.7
Добрый день. Работаю на базе, где нет ни склада, ни бухгалтерии, зато есть отчетность менеджеров о...

Подчиненные справочники в запросе
Помогите, люди добрые! 1С 7.7 Ситуация: -есть справочник Контрагенты; -есть справочник Услуги,...

подчиненные справочники и его отбор в форме
Здравствуйте! у меня возникла проблема с интерфейсом заполнения данными справочника в 1с 7.7...

Подчиненные справочники
Есть справочник 'КонтактнаяИнфо' (подчинен справочнику 'Обзвон') и справочник 'ХранилищеКонтакт'...

1
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
15.05.2014, 18:44 2
Цитата Сообщение от shiro93 Посмотреть сообщение
спрДоч.ВыбратьЭлементы()
там, вроде бы, владелец параметром д.б. Синт.пом что говорит?
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.05.2014, 18:44

Подчиненные справочники 1с 8,3
Доброго времени суток, такая проблема. Начинаем работать с 1с 8,3. Нужно создать справочники...

3 Подчиненные таблицы
Помогите пожалуйста! Не могу связать 3ю подчиненную флрму со второй! Ситуация: таблицы...

Подчиненные формы
Добрый вечер, в общем задание такое, нужно было сделать бд, для создания связей использовать мастер...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru