Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.81/16: Рейтинг темы: голосов - 16, средняя оценка - 4.81
Sproviero_Nasty
0 / 0 / 0
Регистрация: 22.05.2014
Сообщений: 10
1

Автоматическое заполнение документа из регистра сведений

22.05.2014, 03:30. Просмотров 3073. Ответов 8
Метки нет (Все метки)

Здравствуйте. Проблема с заполнением документа. В нем много полей в ТЧ, но по заданию в ручную забивается толькоо поле Оборудование, а остальные должны автоматически. Это документ Сопроводитель на заказ для типографии. Все данные в разных регистрах сведений, но получается вернуть только то значение, которое зависит от поля Оборудование.
Поле услуга, формат, КоличествоЛистов заполняются сами на основании другого документа.

1C
1
2
3
4
5
6
7
8
9
Процедура ВЗОборудованиеПриИзменении(Элемент)
    СтрокаТабличнойЧасти = ЭлементыФормы.ВЗ.ТекущиеДанные;
    СтрокатабличнойЧасти.Материал = РаботаСЗатратКомплектующих.Материал(Дата, ЭлементыФормы.ВЗ.ТекущиеДанные.Услуга);
    СтрокаТабличнойЧасти.НаЛист =  РаботаСЗатратКомплектующих.НаЛист(Дата, Элемент.Формат);
    СтрокаТабличнойЧасти.Чернила =   РаботаСЗатратКомплектующих.Чернила(Дата, ЭлементыФормы.ВЗ.ТекущиеДанные.Оборудование);
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.ОбщееЧислоЛистов*(РаботаСЗатратКомплектующих.Цена(Дата, Элемент.Значение) + РаботаСЗатратКомплектующих.Цена(Дата, СтрокаТабличнойЧасти.Чернила));
    СтрокаТабличнойЧасти.СуммаДляКлиента = СтрокаТабличнойЧасти.Сумма*3;
 
КонецПроцедуры
Данная процедуда возвращает лишь поле Чернила. В чем ошибка?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.05.2014, 03:30
Ответы с готовыми решениями:

Заполнение табличной части документа из регистра сведений
Доброго времени суток , столкнулся с такой проблемой Как заполнить табличную часть документа из...

Заполнение регистра сведений
Добрый день. Есть документ "Поступление материалов", информация с которого должна автоматически...

Подставить значение из регистра сведений в ТЧ документа
есть регистр сведений который хранит информацию о номерах в гостинице.(Номер - тип...

Заполнение данными из регистра сведений. Отбор по двум измерениям
Подскажите пожалуйста. В переодическом регистре сведений есть два измерения (контрагент,...

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и подчиненный ему...

8
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
22.05.2014, 09:38 2
А в чем ошибка-то?
0
Sproviero_Nasty
0 / 0 / 0
Регистрация: 22.05.2014
Сообщений: 10
22.05.2014, 09:46  [ТС] 3
В том, что ничего не выводит, хотя данные в регистрах сведений есть.
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.05.2014, 09:49 4
Sproviero_Nasty,
1C
1
РаботаСЗатратКомплектующих.Материал()
Что за функция? Вы её можете выложить?
0
22.05.2014, 09:49
Sproviero_Nasty
0 / 0 / 0
Регистрация: 22.05.2014
Сообщений: 10
22.05.2014, 09:57  [ТС] 5
1C
1
2
3
4
5
Функция Материал(АктуальнаяДата, ЭлементУслуги) Экспорт 
    Отбор = Новый Структура("Услуга", ЭлементУслуги); 
    ЗначенияРесурсов = РегистрыСведений.ЗатратКомплектующих.Получить(АктуальнаяДата, Отбор);
        Возврат ЗначенияРесурсов.Материал;
    КонецФункции
Добавлено через 52 секунды
SPR1TE89,
1C
1
2
3
4
5
Функция Материал1(АктуальнаяДата, ЭлементУслуги) Экспорт 
    Отбор = Новый Структура("Услуга", ЭлементУслуги); 
    ЗначенияРесурсов = РегистрыСведений.ЗатратКомплектующих.Получить(АктуальнаяДата, Отбор);
        Возврат ЗначенияРесурсов.Материал;
    КонецФункции
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.05.2014, 10:00 6
Sproviero_Nasty, Возможно у вас данных нет за период, который вы передаете в эту функцию, посмотрите в регистрах сведений на заданные даты, есть записи? так же и по другим функциям
0
Sproviero_Nasty
0 / 0 / 0
Регистрация: 22.05.2014
Сообщений: 10
22.05.2014, 10:05  [ТС] 7
SPR1TE89, Данные есть за тот период. Данные вчерашнего числа, а документ уже сегодняшнего.
0
SPR1TE89
21 / 21 / 3
Регистрация: 22.04.2014
Сообщений: 112
22.05.2014, 10:18 8
Sproviero_Nasty,
1C
1
2
3
4
5
6
Функция Материал1(АктуальнаяДата, ЭлементУслуги) Экспорт 
   Отбор = Новый Структура("Услуга", ЭлементУслуги); 
// ЗначенияРесурсов = РегистрыСведений.ЗатратКомплектующих.Получить(АктуальнаяДата, Отбор);
   ЗначенияРесурсов = РегистрыСведений.ЗатратКомплектующих.ПолучитьПоследнее(АктуальнаяДата, Отбор);
   Возврат ЗначенияРесурсов.Материал;
КонецФункции
Попробуйте так заменить эту функцию, и посмотрите что получится.
0
Sproviero_Nasty
0 / 0 / 0
Регистрация: 22.05.2014
Сообщений: 10
22.05.2014, 10:32  [ТС] 9
SPR1TE89, Спасибо боьшое. Вроде получилось )
0
22.05.2014, 10:32
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.05.2014, 10:32

Заполнение документа данными из регистра накопления. Создание отчета по данным регистра накопления.
Изучаю 1с по методичкам не могу решить два задания Объясните что да как делается +100 в карму

Заполнение документа данными из шаблона в регистре сведений
Доброго времени суток. Не могу справиться с задачей, поэтому прошу специалистов о помощи! Имеется...

Автоматическое заполнение данных документа
Здравствуйте, подскажите почему не работает процедура автоматической подстановки единиц измерения...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
9
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.