Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.57/7: Рейтинг темы: голосов - 7, средняя оценка - 4.57
МилаЛюда
0 / 0 / 0
Регистрация: 05.04.2011
Сообщений: 19
1

Создание макета

17.06.2014, 14:38. Просмотров 1449. Ответов 3
Метки нет (Все метки)

Помогите изменить код макета чтоб он был в таком виде как на картинке.
Вот код который у меня получилось сделать.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
&НаКлиенте
Процедура Сформировать(Команда)
    СформироватьНаСервере();
КонецПроцедуры
 
 
&НаСервере
Процедура СформироватьНаСервере()
        Макет = ВнешниеОбработки.Выгрузка.ПолучитьМакет("Макет1");
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ОстатокАвтомобилейОстаткиИОбороты.КоличествоРасход,
        |   ОстатокАвтомобилейОстаткиИОбороты.КоличествоПриход,
        |   ОстатокАвтомобилейОстаткиИОбороты.КоличествоОборот,
        |   ОстатокАвтомобилейОстаткиИОбороты.КоличествоКонечныйОстаток,
        |   ОстатокАвтомобилейОстаткиИОбороты.КоличествоНачальныйОстаток,
        |   ОстатокАвтомобилейОстаткиИОбороты.МодВарКомп.Модель,
        |   ОстатокАвтомобилейОстаткиИОбороты.МодВарКомп.ДатаВыпускаАвто,
        |   ОстатокАвтомобилейОстаткиИОбороты.МодВарКомп.Модель.Ссылка,
        |   ОстатокАвтомобилейОстаткиИОбороты.МодВарКомп.Модель.Представление
        |ИЗ
        |   РегистрНакопления.ОстатокАвтомобилей.ОстаткиИОбороты КАК ОстатокАвтомобилейОстаткиИОбороты";
 
    РезультатЗапроса = Запрос.Выполнить();
 
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
 
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
 
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
 
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
        ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
    КонецЦикла;
 
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ТабДок.Вывести(ОбластьПодвал);
 
КонецПроцедуры
0
Миниатюры
Создание макета  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.06.2014, 14:38
Ответы с готовыми решениями:

Создание макета
Здравствуйте! Разбираю курс Практическое пособие разработчика, на 8-м занятии не пойму как нужно...

Создание макета ver.8
Здравствуйте, необходимо организовать, чтобы пользователь мог из Предприятия добавлять новые...

Создание макета печатной формы
Добрый вечер. Почти доделал макет. Осталось сделать подвал. Не соображу, как сделать так ячейки,...

Редактирование макета в 8.2
добрый день интерусет как отредактировать макет декларации по ЕНВД, а именно что бы нужное поле...

Строка макета
Доброго времени суток!Подскажите пожалуйста, как можно сделать так, что если значение,которое...

3
SonicQ
284 / 184 / 18
Регистрация: 20.02.2012
Сообщений: 925
17.06.2014, 14:50 2
задай области на самом макете, у тебя их нет
1
Dethmontt
Модератор
Эксперт 1С
2756 / 2510 / 446
Регистрация: 10.03.2011
Сообщений: 9,160
Записей в блоге: 1
Завершенные тесты: 1
17.06.2014, 14:52 3
МилаЛюда, где ошибка то?
0
МилаЛюда
0 / 0 / 0
Регистрация: 05.04.2011
Сообщений: 19
17.06.2014, 18:52  [ТС] 4
Уже ни в чем, спасибо разобралась)
0
17.06.2014, 18:52
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.06.2014, 18:52

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

печать макета
Сейчас изучаю макеты и хочу его напечатать. Имеется справочник. (Все необходимые картинки...

Вывод макета
Вывожу макет..вроде все выводит, но при нажатии на печать..он в одном макете выводит на печать ВСЕ...

Вывод макета
приветик всем. помогите пж вывести число записей в форме. вот приблизительный код:...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.