Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 11, средняя оценка - 4.73
StrelokCj
49 / 49 / 12
Регистрация: 15.01.2013
Сообщений: 290
#1

Поиск ссылок на объект - 1С/1C 8.x (тонкий)

01.07.2014, 08:01. Просмотров 2094. Ответов 7
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
Если (Объект.СсылкаНаОбъект.Пустая() = Истина) Тогда
        Сообщить("Выберите номенклатуру");  
    Иначе
        Ссылки = Новый Массив;
        Ссылки.Добавить(Объект.СсылкаНаОбъект);
        ТабСсылок = НайтиПоСсылкам(Ссылки);
        Для Каждого Элем Из ТабСсылок Цикл
            Сообщить(Элем);
        КонецЦикла;     
КонецЕсли
Создал внешнюю обработку, указываю номенклатуру. В коде на кнопке выскакивает ошибка:
Код
{Форма.Форма.Форма(9,15)}: Процедура или функция с указанным именем не определена (НайтиПоСсылкам)
		ТабСсылок = <<?>>НайтиПоСсылкам(Ссылки); (Проверка: Тонкий клиент)
Почему ошибка, не знаю.
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.07.2014, 08:01
Здравствуйте! Я подобрал для вас темы с ответами на вопрос 1C 8.x (тонкий) Поиск ссылок на объект (1С):

1C 8.x Объект типа Объект.Использование - не всегда реален. - 1С
При формировании отчета выдает ошибку &quot;Значение не является значением объектного типа (Использование)&quot; В чем может быть проблема? ...

Количество ссылок на объект - Java SE
Я понимаю, что это полный детский сад, но запутался. Нужно посчитать количество ссылок на объект на момент выполнения строки. Как я понял...

Удаление ссылок на объект - XNA
У меня есть множество объектов в массиве. Как &quot;уничтожить&quot; их, чтобы они не занимали память и цп? Добавлено через 25 минут Черт, я...

Узнать количество ссылок на объект - C#
Всем привет, как узнать сколько ссылок ссылается на данный объект? Нужно для того, чтобы знать, можно ли удалить объект из памяти или нет. ...

Как зделать коллекцию экземпляров объекта, а не ссылок на объект? - Visual Basic
как зделать коллекцию экземпляров объекта, а не ссылок на объект?

Поиск ссылок - C++ Builder
Имеется файл с исходным кодом страницы. Рассматривать фрагмент страницы между строками содержащими &quot;&lt;TR class=hdr&gt;&quot; (их всего 2) ...

7
wladimir_ui
Шизофреник
357 / 360 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:10 #2
НайтиПоСсылкам
Доступность:
Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
0
StrelokCj
49 / 49 / 12
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:41  [ТС] #3
А какую функцию можно использовать во внешней обработке для поиска ссылок на объект?
0
wladimir_ui
Шизофреник
357 / 360 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:42 #4
эту же, но вызывать ее надо на сервере
1
StrelokCj
49 / 49 / 12
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:43  [ТС] #5
У меня в модуле перед процедурой написано &НаКлиенте, исправить на &НаСервере? Так?
0
wladimir_ui
Шизофреник
357 / 360 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:49 #6
Лучший ответ Сообщение было отмечено автором темы, экспертом или модератором как ответ
Примерно так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте
Процедура ТвояПроцедураКлиентская(Команда)
    Если (Объект.СсылкаНаОбъект.Пустая() = Истина) Тогда
        Сообщить("Выберите номенклатуру");  
    Иначе
        Ссылки = Новый Массив;
        Ссылки.Добавить(Объект.СсылкаНаОбъект);
        НайтиПоСсылкамНаСервереТвояПроцедура(Ссылки);
    КонецЕсли;
КонецПроцедуры
 
&НаСервере
Процедура НайтиПоСсылкамНаСервереТвояПроцедура(Ссылки)
        ТабСсылок = НайтиПоСсылкам(Ссылки);
        Для Каждого Элем Из ТабСсылок Цикл
            Сообщить(Элем);
        КонецЦикла;     
КонецПроцедуры
1
StrelokCj
49 / 49 / 12
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:50  [ТС] #7
Спасибо большое
0
startq1
0 / 0 / 0
Регистрация: 17.02.2016
Сообщений: 2
20.02.2017, 15:46 #8
Функция НайтиПоСсылкам Доступна на серуере и толстом клиенте.
0
20.02.2017, 15:46
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.02.2017, 15:46
Привет! Вот еще темы с ответами:

Поиск ссылок в тексте - Java SE
Как искать ссылки в HTML файле (содержимое которого хранится в одной переменной string)? Идея такая разбить весь файл на массив чар и потом...

Поиск ссылок в HTML - Perl
Здравствуйте! У меня в переменной есть строковое представление HTML. Подскажите, какой регуляркой получить все ссылки из этой переменной.

1C 8.2 Поиск неудаляемых ссылок - 1С
Как найти ссылки котрые не дают удалить документ. (Удаление помеченных объектов) Список я вижу по (!) но где его найти - этот документ не...

.NET 3.x Поиск ссылок по сайту C# - C#
День добрый! Нужно осуществить поиск битых ссылок по сайту. Программа подгружает с главной страницы ссылки в ArrayList типа...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.