Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг: Рейтинг темы: голосов - 11, средняя оценка - 4.73
StrelokCj
217 / 49 / 52
Регистрация: 15.01.2013
Сообщений: 290
#1

Поиск ссылок на объект - 1С/1C 8.x (тонкий)

01.07.2014, 08:01. Просмотров 2336. Ответов 7
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
Если (Объект.СсылкаНаОбъект.Пустая() = Истина) Тогда
        Сообщить("Выберите номенклатуру");  
    Иначе
        Ссылки = Новый Массив;
        Ссылки.Добавить(Объект.СсылкаНаОбъект);
        ТабСсылок = НайтиПоСсылкам(Ссылки);
        Для Каждого Элем Из ТабСсылок Цикл
            Сообщить(Элем);
        КонецЦикла;     
КонецЕсли
Создал внешнюю обработку, указываю номенклатуру. В коде на кнопке выскакивает ошибка:
Код
{Форма.Форма.Форма(9,15)}: Процедура или функция с указанным именем не определена (НайтиПоСсылкам)
		ТабСсылок = <<?>>НайтиПоСсылкам(Ссылки); (Проверка: Тонкий клиент)
Почему ошибка, не знаю.
http://www.cyberforum.ru/1c-custom/thread1500634.html
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.07.2014, 08:01
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x (тонкий) Поиск ссылок на объект (1С):

Количество ссылок на объект
Я понимаю, что это полный детский сад, но запутался. Нужно посчитать количество...

Удаление ссылок на объект
У меня есть множество объектов в массиве. Как &quot;уничтожить&quot; их, чтобы они не...

Узнать количество ссылок на объект
Всем привет, как узнать сколько ссылок ссылается на данный объект? Нужно для...

Как зделать коллекцию экземпляров объекта, а не ссылок на объект?
как зделать коллекцию экземпляров объекта, а не ссылок на объект?

Поиск ссылок
Имеется файл с исходным кодом страницы. Рассматривать фрагмент страницы между...

7
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:10 #2
НайтиПоСсылкам
Доступность:
Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
0
StrelokCj
217 / 49 / 52
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:41  [ТС] #3
А какую функцию можно использовать во внешней обработке для поиска ссылок на объект?
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:42 #4
эту же, но вызывать ее надо на сервере
1
StrelokCj
217 / 49 / 52
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:43  [ТС] #5
У меня в модуле перед процедурой написано &НаКлиенте, исправить на &НаСервере? Так?
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
01.07.2014, 08:49 #6
Лучший ответ Сообщение было отмечено StrelokCj как решение

Решение

Примерно так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
&НаКлиенте
Процедура ТвояПроцедураКлиентская(Команда)
    Если (Объект.СсылкаНаОбъект.Пустая() = Истина) Тогда
        Сообщить("Выберите номенклатуру");  
    Иначе
        Ссылки = Новый Массив;
        Ссылки.Добавить(Объект.СсылкаНаОбъект);
        НайтиПоСсылкамНаСервереТвояПроцедура(Ссылки);
    КонецЕсли;
КонецПроцедуры
 
&НаСервере
Процедура НайтиПоСсылкамНаСервереТвояПроцедура(Ссылки)
        ТабСсылок = НайтиПоСсылкам(Ссылки);
        Для Каждого Элем Из ТабСсылок Цикл
            Сообщить(Элем);
        КонецЦикла;     
КонецПроцедуры
1
StrelokCj
217 / 49 / 52
Регистрация: 15.01.2013
Сообщений: 290
01.07.2014, 08:50  [ТС] #7
Спасибо большое
0
startq1
0 / 0 / 0
Регистрация: 17.02.2016
Сообщений: 2
20.02.2017, 15:46 #8
Функция НайтиПоСсылкам Доступна на серуере и толстом клиенте.
0
20.02.2017, 15:46
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.02.2017, 15:46
Привет! Вот еще темы с решениями:

Поиск ссылок по сайту
День добрый! Нужно осуществить поиск битых ссылок по сайту. Программа...

Поиск ссылок в HTML
Здравствуйте! У меня в переменной есть строковое представление HTML....

В тексте поиск ссылок
Уважаемые форумчане! Подскажите как можно реализовать поставленную задачу. Мы...

Поиск ссылок в txt
Ребят помогите пожалуйста.Нужно зачаровать кнопку button так,что при нажатии...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru