Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/14: Рейтинг темы: голосов - 14, средняя оценка - 4.71
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
1

Не работает внешняя печатная форма

06.08.2014, 13:02. Просмотров 2601. Ответов 11
Метки нет (Все метки)

Здравствуйте!
Делаю внешнюю печатную форму для документа "Разовые начисления организаций".
Требуется сделать так, чтобы из документа открывалась форма обработки печатной формы при нажатии на кнопку печать.
Если открыть печатную форму как внешнюю форму, то всё работает нормально, но если печатную форму прикрепить к документу, то при нажатии кнопки печать форма внешней печатной формы не открывается, а так же происходит ошибка:
Не удалось сформировать внешнюю печатную форму!
Недостаточно фактических параметров

Может, кто сможет объяснить мне, в чем ошибка?
Вот ссылка на обработку: [del]
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.08.2014, 13:02
Ответы с готовыми решениями:

Внешняя печатная форма
Добрый день! Подскажите, пожалуйста, как сделать внешнюю печатную форму для макета...

Внешняя печатная форма для реестра
Здравствуйте, такой вопрос, как думаете, если сделать внешнюю печатную форму для формирования...

Внешняя печатная форма дополнительного соглашения
Здравствуйте! Делаю внешнюю печатную форму Дополнительного соглашения к договору (зуп3.1). Не могу...

Внешняя печатная форма ценников. ЗАПРОСЫ
День добрый. Я начинающий программист. Есть задача, но знаний не хватает. Прошу помощи. Есть...

8.2, Внешняя печатная форма для Комплексной автоматизации 1.1
Доброго времени суток. Прошу помощи по 1с. Версия платформы: 8.2. Конфигурация: комплексная...

11
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
06.08.2014, 13:20 2
Saengmyung, не работает ссылка, прикрепите обработку напрямую в сообщении (расширенный режим).
0
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
06.08.2014, 13:28  [ТС] 3
пишет, что неверный файл...

Добавлено через 2 минуты
я попробовала скачать, все работает у меня..
0
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
06.08.2014, 13:28 4
Saengmyung, за-архивируйте обработку
0
06.08.2014, 13:28
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
06.08.2014, 13:31  [ТС] 5
вот
0
Вложения
Тип файла: rar Приказ о стимулирующих выплатах.rar (13.7 Кб, 11 просмотров)
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
06.08.2014, 13:52 6
Saengmyung, а к чему это ПолеВыбора1? Вам недостаточно реквизита СсылкаНаОбъект? Измените тип(не Строка, а нужный док).
В модуле обработки:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Функция Печать() Экспорт
    //ПечатьПриказаТ11а(ПолеВыбора1);
    Форма = ПолучитьФорму("Форма");
        Если Форма.Открыта() тогда
            Форма.Закрыть("Да");
        Иначе
            Тест = Форма.ОткрытьМодально();
            Если (Тест <> "Да") Тогда
                Возврат Неопределено;
            КонецЕсли;
        КонецЕсли;
        Возврат ПечатьПриказаТ11а(СсылкаНаОбъект);
КонецФункции
Соответственно в модуле формы:
1C
1
2
3
Процедура КнопкаВыполнитьНажатие(Кнопка)
    Печать();
КонецПроцедуры
0
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
06.08.2014, 13:58  [ТС] 7
Но ведь нужно чтобы, в печатную форму попадали данные из этого ПолеВыбора...
А ПолеВыбора содержит значения, которые и перечислены в модуле объекта.
И как из ссылки на объект сослаться на поле выбора из формы?
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
06.08.2014, 14:15 8
Saengmyung, дело в том, что прикрепленная внешняя обработка сразу же вызывает функцию Печать() модуля, где у вас неизвестный параметр ПолеВыбора1. Если в нем есть такая необходимость - тогда можно так:
в модуле обработки:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
Функция Печать() Экспорт
    //ПечатьПриказаТ11а(ПолеВыбора1);
    Форма = ПолучитьФорму("Форма");
        Если Форма.Открыта() тогда
            Форма.Закрыть("Да");
        Иначе
            Тест = Форма.ОткрытьМодально();
            Если (Тест <> "Да") Тогда
                Возврат Неопределено;
            КонецЕсли;
        КонецЕсли;
        //Возврат ПечатьПриказаТ11а(СсылкаНаОбъект);
КонецФункции
Функцию ПечатьПриказаТ11а(ПолеВыбора1) делаем экспортной. А в модуле формы:
1C
1
2
3
4
Процедура КнопкаВыполнитьНажатие(Кнопка)
    //Печать();
    ПечатьПриказаТ11а(ПолеВыбора1);
КонецПроцедуры
Добавлено через 5 минут

Не по теме:

что-то больно мудреная функция Печать(), вы бы ее переписали.

0
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
06.08.2014, 14:20  [ТС] 9
Начинает ругаться, что не определена ПечатьПриказаТ11а(ПолеВыбора1);
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
06.08.2014, 14:22 10
Saengmyung, ну так
Цитата Сообщение от GreenkO Посмотреть сообщение
Функцию ПечатьПриказаТ11а(ПолеВыбора1) делаем экспортной
Это значит в модуле обработки надо прописать: Функция ПечатьПриказаТ11а(ПолеВыбора1) Экспорт
0
Saengmyung
0 / 0 / 0
Регистрация: 15.10.2013
Сообщений: 14
06.08.2014, 15:02  [ТС] 11
все равно ругается на фактические параметры...
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
06.08.2014, 15:09 12
Saengmyung, покажите код функции Печать
0
06.08.2014, 15:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
06.08.2014, 15:09

Внешняя печатная форма не распечатывает непроведенные документы
Здравствуйте. Создал внешнюю печатную форму для документа НакладнаяНаОтпускМ15(конфигурация...

Внешняя печатная форма Акта передачи прав
Здравствуйте. Есть внешняя печатная форма Акта передачи прав для документа &quot;Реализация товаров и...

Внешняя печатная форма
Делал внешнюю печатная форма к ЗУП к документу &quot;Зарплата к выплате&quot;. Там впринципе всё просто....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru