Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
1

Формирование отчета

22.08.2014, 16:16. Просмотров 1025. Ответов 14
Метки нет (Все метки)

Есть номенклатура:
-Склад
-Продукты
-Мясо
-свинина
-говядина
-Хлеб
-круглый
-кирпичный
-Молоко
-20% жира
-30% жира
-Техника
-Телефоны
-Телевизоры
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
22.08.2014, 16:16
Ответы с готовыми решениями:

Формирование отчета в СКД
Добрый день. При создании отчета на СКД появились две проблемы. 1) Нужно, чтобы одна из колонок...

Формирование отчета с отбором.
Добрый вечер! Разрабатываю базу "Расписание занятий". Расписание группы на неделю формирую с...

Не убирается табличка формирование отчета
Добрый день, вот такая проблема, отчет сформировался, но показывается, как-будто он формируется,...

Формирование отчета из нескольких источников
Всем привет. Как через скд или другой вариант формирование отчета вывести в нем 2 таблицы друг под...

Формирование документа на основании отчета
Здраствуйте! Подскажите пожалуйста можно ли сформировать документ на основании отчета, и если да...

14
duk337
22.08.2014, 16:17
  #2

Не по теме:

смелое утверждение

0
Xomych
22.08.2014, 16:32
  #3

Не по теме:

Почём?

0
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
22.08.2014, 16:42  [ТС] 4
Есть номенклатура:
-Склад
--Продукты
---Мясо
----свинина
----говядина
---Хлеб
----круглый
----кирпичный
---Молоко
----20% жира
----30% жира
--Техника
---Телефоны
----Смартфон
----Планшет
---Телевизоры
----ЛСД
----СмартТВ
Есть Реализация товара, нужно сделать отчет в котором отображаются третьи уровни и данной номенклатуры. Получается только сделать с отображением четвертого уровня, с третим не получается.
- первый ур.
-- второй ур.
--- третий ур.
---- четвертый ур.
0
22.08.2014, 16:42
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
22.08.2014, 17:12 5
Есть такая функция у справочника Уровень(). Добавь по ней условие в запрос
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
22.08.2014, 18:47 6
что-то запамятовал: 7 группирует по иерархии?
0
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
22.08.2014, 20:44 7
Группирует есесьно
0
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
26.08.2014, 08:16  [ТС] 8
Можешь рассказать по подробнее?
Я в 1С новичок.
0
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
26.08.2014, 09:58 9
Код клади
0
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
26.08.2014, 10:18  [ТС] 10
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Без итогов;
    |Родитель = Документ.Реализация.Номенклатура.Родитель;
    |Сумма = Документ.Реализация.Сумма;
    |Функция СуммаСумма = Сумма(Сумма);
    |Группировка Родитель упорядочить по Родитель.Наименование;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка() = 1 Цикл
        // Заполнение полей Сформировать
        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
Добавлено через 9 минут
Этот код выводит все подряд наименования, а мне нужно выводить наименования находящиеся в Папке РЕМОНТНЫЕ РАБОТЫ.
Родитель Наименование
Материалы на участках
АСВ
ИСС
НСС
ПЖ и КИП
Радио
Сварочный участок
Проверки снабжения
АСВ
Замена, ремонт снабжения
ИСС
Замена, ремонт снабжения
Калибровка СИ
Замена, ремонт снабжения
Огнетушители
Замена, ремонт снабжения
Такелаж
Замена, ремонт снабжения
Реализация штормтрапы и шкентеля
Электроучасток
Замена, ремонт снабжения
АСВ
Гидравлические испытания баллаонов
ИСС
Калибровка СИ
Лаборатория
механический участок
НСС
НШО
Огнетушители
Пожарные рукава
Такелаж
Толщинометрия
Шлюпки
Электроучасток
РЕМОНТНЫЕ РАБОТЫ
Радиоучасток
Сварочные работы
Проверки снабжения
Услуги транспорта
0
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
26.08.2014, 10:49 11
Лучший ответ Сообщение было отмечено Hvake26 как решение

Решение

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Без итогов;
    |Тов= Документ.Реализация.Номенклатура;
    |Сумма = Документ.Реализация.Сумма;
    |Функция СуммаСумма = Сумма(Сумма);
    |Группировка Тов упорядочить по Тов.Наименование;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка() = 1 Цикл
        // Заполнение полей Сформировать
        Если Запрос.Тов.Уровень()<3 тогда продолжить КонецЕсли;
        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
Добавлено через 4 минуты
Если тебе нужно по конкретной группе выводить добавь условие в запрос
Условие (Тов в НужнаяГруппа);
1
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
26.08.2014, 11:30  [ТС] 12
Цитата Сообщение от Xomych Посмотреть сообщение
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |ОбрабатыватьДокументы все;
    |Без итогов;
    |Тов= Документ.Реализация.Номенклатура;
    |Сумма = Документ.Реализация.Сумма;
    |Функция СуммаСумма = Сумма(Сумма);
    |Группировка Тов упорядочить по Тов.Наименование;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка() = 1 Цикл
        // Заполнение полей Сформировать
        Если Запрос.Тов.Уровень()<3 тогда продолжить КонецЕсли;
        Таб.ВывестиСекцию("Сформировать");
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры
Добавлено через 4 минуты
Если тебе нужно по конкретной группе выводить добавь условие в запрос
Условие (Тов в НужнаяГруппа);
Условие (Тов в НужнаяГруппа);

НужнаяГруппа я так понимаю в моем случае это РЕМОНТНЫЕ РАБОТЫ?
0
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
26.08.2014, 13:34 13
Ну видимо
Добавь поле в форму отчета, где выбирать будут нужную группу
0
Hvake26
0 / 0 / 0
Регистрация: 13.05.2014
Сообщений: 23
26.08.2014, 13:48  [ТС] 14
Как сделать выбор группы?
Мне бы хоть какой нибудь пример.
0
Xomych
785 / 604 / 95
Регистрация: 01.11.2012
Сообщений: 2,179
26.08.2014, 14:32 15
Лучший ответ Сообщение было отмечено Hvake26 как решение

Решение

Добавь на форму поле с типом справочник.Номенклатура назови его допустим ВыбГруппа и проверяй в запросе условие вхождение товара в ВыбГруппу, как я написал выше
1
26.08.2014, 14:32
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.08.2014, 14:32

Формирование отчета 1с 8.3. Отключение отбора по Читателю.
Значит создал отчет, с параметром читатель (ФИО) который берется из справочника. В пользовательских...

Формирование отчета на скд остатки материалов в организации на складе 1с 8.3
Помогите, пожалуйста разобраться с запросом. В 1с новичок. Нужно сформировать отчет остатки...

Формирование отчета
Здравствуйте! Помогите переправить отчет пожалйста. Есть отчет Движение Товаров, он выводит...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
15
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru