Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/8: Рейтинг темы: голосов - 8, средняя оценка - 4.75
V0vKA
0 / 0 / 0
Регистрация: 22.04.2013
Сообщений: 26
1

Добавление колонок в цикле

11.09.2014, 15:47. Просмотров 1449. Ответов 4
Метки нет (Все метки)

добавление колонок в цикле


1C
1
2
3
4
5
6
7
Для х=0 По сч-1 Цикл
                Колонка = "к"+х;
                
                НоваяСтрока.Колонка=СтрокаДочь.Колонка;
                КонецЦикла; 
                НоваяКолонка="к"+сч;
                НоваяСтрока.НоваяКолонка=Родитель.к0;
Ругается на Колонка. т.к. ее нет в Таблице значений


Проблема в том что заранее нельзя узнать в какую колонку будет добавляться значение. Как сделать чтобы название можно было вводить через переменную.
0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.09.2014, 15:47
Ответы с готовыми решениями:

Динамическое добавление колонок в отчет
Добрый день. Никак не могу сообразить, как собрать программно отчет, в котором...

Динамическое добавление колонок в 1С8
Появилась проблема: необходимо создать документ, в табличных частях которого...

Группировка колонок ТЗ
Добрый день нужна помошь. Есть таблица из 3 значений Цена,Количество,вес. И...

Печать в несколько колонок
Хочу разобраться как напечатать выбранные элементы справочника через подбор в...

Группировка колонок в отчете
Доброго дня! Пишу отчет по жалобам, задача сделать группировку по...

4
Volexovich
199 / 175 / 29
Регистрация: 24.10.2011
Сообщений: 696
11.09.2014, 16:29 2
Вот вам пример с динамическим добавлением колонок:
1C
1
2
3
4
5
6
7
8
9
10
Родня = Новый Массив;
Родня.Добавить("Мама");
Родня.Добавить("Папа");
Родня.Добавить("Я");
 
ТЗ = Новый ТаблицаЗначений;
 
Для каждого СтрокаР из Родня Цикл
     ТЗ .Колонки.Добавить(СтрокаР);
КонецЦикла;
0
V0vKA
0 / 0 / 0
Регистрация: 22.04.2013
Сообщений: 26
11.09.2014, 16:37  [ТС] 3
колонки добавляются, но как нам добавить строку если мы заранее не знаем имя колонки, это в цикле должно происходить, к колонкам по индексу можно обращаться?
0
SonicQ
282 / 182 / 18
Регистрация: 20.02.2012
Сообщений: 916
11.09.2014, 17:03 4
Лучший ответ Сообщение было отмечено V0vKA как решение

Решение

1C
1
2
3
4
Если СтрокаР = "Папа" Тогда
НовСтрока = ТЗ.Добавить();
НовСтрока[СтрокаР ]= СтрокаР ;
КонецЕсли;
идея такова... синтаксис надо проверить
1
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
11.09.2014, 20:46 5
Цитата Сообщение от V0vKA Посмотреть сообщение
к колонкам по индексу можно обращаться?
ДА!!!
0
11.09.2014, 20:46
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
11.09.2014, 20:46

Авто. заполнение колонок
Подскажите пожалуйста. Есть справочник Номенклатура, как сделать при заполнении...

Отчет с количеством колонок >255
Добрый день. Второй день бьюсь: интерактивно не получится, ограничение 1с,...

Нужно В 7-ке Управлять Положением Колонок
Возникла небольшая задачка. Один клиент попросил расположить колонки в большом...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru