Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
daxo
0 / 0 / 0
Регистрация: 11.09.2013
Сообщений: 29
1

Отбор оклада в 7.7

17.09.2014, 18:47. Просмотров 777. Ответов 11
Метки нет (Все метки)

вот и снова задачка от 7.7. есть такое условие как исполнить не представляю точнее визуально представляю но вот как сделать..
Разработайте Отчет по окладам, которые позволяет формировать список сотрудников, у которых сумма оклада находится в диапазоне, заданном пользователем.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.09.2014, 18:47
Ответы с готовыми решениями:

Отбор на быстрый отбор СКД
Всем привет. Подскажите кто-нить, чойта туплю. Есть простой отчет на СКД, в макете компоновки...

Перерасчет оклада по практич. пособию Радченко
Пытаюсь сформировать отчет о перерасчете оклада по книге Радченко и ничего не получается, изменял...

Получение в документе данных ФИО и оклада из справочника Сотрудники
Здравствуйте помогите пожалуйста а то что то не получается. Есть справочник сотрудники, в нем фио...

Увеличение оклада
Сформировать файл, содержащий n записей о работниках предприятия. Записи должны содержать...

Расчет оклада сотрудников
Доброго времени суток! Есть БД "интернет-магазин". Есть таблица "Сотрудники", в которой имеется...

11
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
17.09.2014, 21:10 2
Попробуйте дать больше исходных, а то есть риск, что не ответят. Ну, хотя бы, где хранится оклад?
0
daxo
0 / 0 / 0
Регистрация: 11.09.2013
Сообщений: 29
17.09.2014, 22:23  [ТС] 3
можно ли тут в модуле прописать условие как в паскале, например, через если два значения,мол между тем и тем????
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
17.09.2014, 22:44 4
можно
0
daxo
0 / 0 / 0
Регистрация: 11.09.2013
Сообщений: 29
17.09.2014, 22:51  [ТС] 5
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Процедура Сформировать() 
 Таб=СоздатьОбъект ("Таблица");
 Таб.ИсходнаяТаблица ("оклад");   
 Таб.ВывестиСекцию("Шапка")  ;
 Кадры=СоздатьОбъект ("Справочник.Кадры");
 Кадры. ВыбратьЭлементы();
 НомерСтроки=0; 
 
 пока Кадры. ПолучитьЭлемент ()=1 цикл 
    
    если Кадры.оклад > мин
     если Кадры.оклад < макс
    тогда
        НомерСтроки=НомерСтроки +1;  
        Таб.ВывестиСекцию("Строка");
    КонецЕсли; 
    КонецЦикла;
 
    
    Таб.ТолькоПросмотр(1);
    Таб.Показать("оклад");
 
КонецПроцедуры
я конечно пойму если вы будите над таким модулем смеяться но я не не совсем хорошо знаю как тут прописывать
0
Миниатюры
Отбор оклада в 7.7  
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
17.09.2014, 22:57 6
В моей транскрипции было бы так:
1C
1
2
3
4
5
6
7
Пока Кадры. ПолучитьЭлемент ()=1 Цикл 
окл=Кадры.оклад;
Если НЕ (окл>мин И окл<макс) Тогда Продолжить;КонецЕсли;
//.... далее по тексту
НомерСтроки=НомерСтроки +1;  
Таб.ВывестиСекцию("Строка");
КонецЦикла;//...
0
daxo
0 / 0 / 0
Регистрация: 11.09.2013
Сообщений: 29
17.09.2014, 23:55  [ТС] 7
много ругани у него, в основном по поводу скобок, но это меньшая проблема которая может быть
0
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.09.2014, 01:23 8
Вас чо, пытать, что ли, как зою Космодемьянскую?
У меня база не загружается - архив битый. Сделайте Выгрузить

Добавлено через 2 минуты
тьфу, блин, СОХРАНИТЬ данные!
0
daxo
0 / 0 / 0
Регистрация: 11.09.2013
Сообщений: 29
18.09.2014, 01:28  [ТС] 9
и снова она
сохраненная и выгруженная ..
0
Вложения
Тип файла: zip 1с.zip (18.3 Кб, 8 просмотров)
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
18.09.2014, 01:59 10
Администрирование.СОХРАНИТЬ!
Больно я помню 77... Ошибка архива и всё тут. В зип давай

Добавлено через 15 минут
ага. кое как из мдэхи сделал базу.
Кароче так, Шарапов. Удали-ка ты из формулы подр "Сформировать()"

Добавлено через 11 минут
А тут надо так () если уж скобки молотить:
1C
1
Если (оклад<мин) ИЛИ (оклад>макс) Тогда Продолжить;КонецЕсли;
0
притолстый
0 / 0 / 0
Регистрация: 16.06.2015
Сообщений: 4
22.03.2016, 10:42 11
Делаю по вашим указаниям, но он просит какую то скобочку у "мин"
0
slypower
34 / 33 / 8
Регистрация: 12.11.2015
Сообщений: 352
22.03.2016, 13:01 12
мин() и макс() это в системных процедурах и функциях. Попробуйте реквизит назвать по другому
0
22.03.2016, 13:01
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.03.2016, 13:01

Нужно рассчитать премию от оклада
Здравствуйте мне нужна ваша помощь, помогите пожалуйста ,я уже не знаю что с этим делать Я...

Определите тарифные ставки оклада работников
Известно, что тарифная ставка оклада работника 5 разряда равна минимальной заработной плате....

Расчёт общего и индивидуального оклада в базе данных
Создала базу данных о перподавателях. Из данной таблицы получить другую таблицу(запросом ли или...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
12
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru