Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
te_morituri
22 / 22 / 4
Регистрация: 17.10.2009
Сообщений: 281
1

Свойства КомОбъекта()

29.10.2014, 18:02. Просмотров 298. Ответов 0
Метки нет (Все метки)

Доброго времени суток, форумчане!

Написал такой код:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
ДобавитьЗаписьВИсторию("            ЗП за год (Начало) ");
    
    Спр77 = База77.CreateObject("ЖурналРасчетов.Зарплата");
    
    ТекМесяц=ДобавитьМесяц(НачалоМесяца(ТекущаяДата()),-1);
    
            
        ТекМесяц=ДобавитьМесяц(ТекМесяц,-1);
    н=0;    
    
    Пока н<=12 Цикл
        н=н+1;
        
        Мин=НачалоМесяца(ТекМесяц);
        Макс=КонецМесяца(ТекМесяц);
        
        Спр77.ВыбратьЗаписи(Мин, Макс);
        
        НовыйДокументЗП=Документы.НачислениеЗарплатыРаботникамОрганизаций.СоздатьДокумент();
        
        Пока Спр77.ПолучитьЗапись() Цикл
 
                Сообщить ("ПР: "+Спр77.ПериодРегистрации+"ПД: "+Спр77.ПериодДействия+" рез:"+Спр77.Результат+" СменВсего:"+Спр77.СменВсего+" Назначение:"+Спр77.объект.Наименование+" код"+Спр77.объект.код);
            
            
        КонецЦикла;
        
        ТекМесяц=ДобавитьМесяц(ТекМесяц,-1);
        
 
    КонецЦикла;
Так вот, Спр77.ПериодРегистрации это КомОб. в 7.7 это ПР: Май 2014 г.ПД: Май 2014 г.

так вот, как мне обратиться к этому тексту.
Тестил с под отладки: имя, получить(), представление, наименование,

Добавлено через 1 час 30 минут
справка не помогла:
Кликните здесь для просмотра всего текста
ПериодДействия

Период действия записи журнала расчетов.

Синтаксис:

ПериодДействия

Англоязычный синоним:

EffectivePeriod

Описание:

Атрибут типа «период журнала расчетов» — период действия текущей запи*си журнала расчетов. Под периодом действия подразумевается тот расчетный период журнала, в который попадают ДатаНачала и ДатаОкончания дейст*вия записи журнала расчетов (акта расчета).

Атрибут ПериодДействия предназначен только для чтения.

Пример:

Процедура ПоПодр()

Перем Запрос, ТекстЗапроса, Таб;

//Создание объекта типа Запрос

Запрос = СоздатьОбъект("Запрос");

ТекстЗапроса = "//{{ЗАПРОС(ПоПодр)

|Период с ДатаНач по ДатаКон;

|Док = ЖурналРасчетов.Зарплата.ТекущийДокумент;

|ПД = ЖурналРасчетов.Зарплата.ПериодДействия;

|Подр = ЖурналРасчетов.Зарплата.Объект.МестоРаботы.Владелец;

|Рез = ЖурналРасчетов.Зарплата.Результат;

|Группировка ПД;

|Группировка Подр без групп;

|Функция Итог = Сумма(Рез);

|"//}}ЗАПРОС

// Если ошибка в запросе, то выход из процедуры

Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда

Возврат;

КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса

Таб = СоздатьОбъект("Таблица");

Таб.ИсходнаяТаблица("ПоПодр");

// Заполнение полей "Заголовок"

Таб.ВывестиСекцию("Заголовок");

Пока Запрос.Группировка("ПД") = 1 Цикл

// Заполнение полей ПД

Таб.ВывестиСекцию("ПД");

Сообщение(Запрос.ПД.Описатель);

Пока Запрос.Группировка("Подр") = 1 Цикл

// Заполнение полей Подр

Таб.ВывестиСекцию("Подр");

КонецЦикла;

КонецЦикла;

// Заполнение полей "Итого"

Таб.ВывестиСекцию("Итого");

// Вывод заполненной формы

Таб.Опции(1, 0, 1, 0);

Таб.Показать("ПоПодр", "");

КонецПроцедуры

См. также: ДатаНачала, ПериодДействия, ПериодРегистрации

ПериодРегистрации

Период регистрации записи журнала расчетов.

Синтаксис:

ПериодРегистрации

Англоязычный синоним:

RegistrationPeriod

Описание:

Атрибут типа «период журнала расчетов» — расчетный период, в котором текущая запись была введена в журнал расчетов. Это тот расчетный период, который на момент ввода данной записи был установлен для журнала расчетов как текущий.

Атрибут ПериодРегистрации предназначен только для чтения.

Пример:

См. предыдущий пример.

См. также: ДатаНачала, ДатаОкончания, ПериодДействия


Добавлено через 1 час 28 минут
ДатаНачала, ДатаОкончания, Описатель (или ОписательПериода) - не пашет

Добавлено через 16 минут
Решение - смотреть Спр77.ДатаНачала
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.10.2014, 18:02
Ответы с готовыми решениями:

Выполнить команду в set свойства для свойства SelectedItem (ComboBox ) MVVM
Хай Коротко: при каждом выборе элемента из ComboBox нужно выполнять команду, для которой в...

PropertyGrid. Как отловить видимость свойства в зависимости от другого свойства?
Работаю с propertyGrid. Одно поле высвечивается, когда в другом появляется определенное значение....

Что лучше, свойства с приватной переменной или автоматические свойства?
Известно, что в классах свойства можно определить так: class MyClass { private...

Можно ли объекту присвоить значение свойства от другого свойства?
Здравствуйте! Подскажите пожалуйста. var book = { title:&quot;Java Programming&quot;, author:&quot;John...

Биндинг свойства контрола к одной из переменных свойства класса
Добрый день. У меня есть вопрос по биндингу. Ситуация следующая: У меня есть структура, ...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
29.10.2014, 18:02

Реализовать зависимость свойства volume у mediaElement от свойства Value у slider
Добрый день! Как можно реализовать зависимость свойства volume у mediaElement от свойства Value у...

Создать Generic Mapper, который будет мапить схожие свойства одного объекта в свойства другого
Нужно создать generic mapper, который будет мапить схожие(similar) свойства одного объекта в...

Отличие свойства доступ от свойства блокировка в формах
Подскажите,пож-ста,отличие.Никак не могу найти в книжке


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru