Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.55/11: Рейтинг темы: голосов - 11, средняя оценка - 4.55
Fenlou
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 480
1

Как исправить ошибку?

29.10.2014, 19:40. Просмотров 2147. Ответов 4
Метки нет (Все метки)

Здравствуйте, при проведении документов, выдается сообщения:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Здравствуй, Дорогой пользователь!
Поступление товаров К1 от 28.03.2014 15:30:07. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К2 от 29.03.2014 23:51:32. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 1 от 29.03.2014 23:52:47. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 2 от 29.03.2014 23:53:52. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 3 от 06.05.2014 18:36:49. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К3 от 09.05.2014 16:23:42. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К6 от 09.05.2014 16:24:33. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К5 от 09.05.2014 16:24:41. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К8 от 09.05.2014 16:25:30. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К7 от 09.05.2014 20:56:55. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Поступление товаров К4 от 09.05.2014 20:57:29. Ошибка при выполнении обработчика - '{Документ.ПоступлениеТоваров(31)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 4 от 23.09.2014 17:56:58. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 5 от 01.10.2014 10:57:12. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 6 от 02.10.2014 19:08:41. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 7 от 08.10.2014 13:19:40. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Вид субконто "Контрагенты" не доступен для данной записи! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 2)'
Продажа товаров 8 от 08.10.2014 13:28:33. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Поле "Валюта" должно быть пустым! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 1)'
Продажа товаров 9 от 08.10.2014 13:35:12. Ошибка при выполнении обработчика - '{Документ.ПродажаТоваров(48)}: Ошибка при вызове метода контекста (Записать): Запись не верна! Вид субконто "Контрагенты" не доступен для данной записи! (Регистр бухгалтерии: Основной регистр бухгалтерии; Номер строки: 2)'
Подскажите как исправить!
Вот модули для документов:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        // регистр ОстаткиТоваров Приход
        Движение = Движения.ОстаткиТоваров.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Товар;
        Движение.Склад = Склад;
        Движение.Количество = ТекСтрокаТовары.Количество;
        // регистр ОсновнойРегистрБухгалтерии 
        Движение = Движения.ОсновнойРегистрБухгалтерии.Добавить();
        Движение.СчетДт = ПланыСчетов.ОсновнойПланСчетов.Товары;
        Движение.СчетКт = ПланыСчетов.ОсновнойПланСчетов.Поставщики;
        Движение.Период = Дата;
        Движение.Организация = Организация;
        Движение.Валюта = ТекСтрокаТовары.Валюта;
        Движение.Сумма = ТекСтрокаТовары.Сумма;
        Движение.КоличествоДт = ТекСтрокаТовары.Количество;
        Движение.СуммаХолдинга = Итого;
        Движение.Содержание = "Поступление товаров";
        Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Товары] = ТекСтрокаТовары.Товар;
        Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Склады] = Склад;
        Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
    
    // записываем движения регистров
    Движения.ОстаткиТоваров.Записать();
    Движения.ОсновнойРегистрБухгалтерии.Записать();
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецЦикла;
 
КонецПроцедуры

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
Процедура ОбработкаПроведения(Отказ, Режим)
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    Для Каждого ТекСтрокаТовары Из Товары Цикл
        // регистр ОстаткиТоваров Расход
        Движение = Движения.ОстаткиТоваров.Добавить();
        Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
        Движение.Период = Дата;
        Движение.Номенклатура = ТекСтрокаТовары.Товар;
        Движение.Склад = Склад;
        Движение.Количество = ТекСтрокаТовары.Количество;
        // регистр ОбъёмЗакупок 
        Движение = Движения.ОбъёмЗакупок.Добавить();
        Движение.Период = Дата;
        Движение.Контрагент = Контрагент;
        Движение.Сумма = Итого;
        // регистр ОсновнойРегистрБухгалтерии 
        Движение = Движения.ОсновнойРегистрБухгалтерии.Добавить();
        Движение.СчетДт = ПланыСчетов.ОсновнойПланСчетов.Капитал;
        Движение.СчетКт = ПланыСчетов.ОсновнойПланСчетов.Товары;
        Движение.Период = Дата;
        Движение.Организация = Организация;
        Движение.Валюта = ТекСтрокаТовары.Валюта;
        Движение.Сумма = ТекСтрокаТовары.Сумма;
        Движение.КоличествоКт = ТекСтрокаТовары.Количество;
        Движение.СуммаХолдинга = ТекСтрокаТовары.Цена;
        Движение.Содержание = "Продажа товаров";
        Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Товары] = ТекСтрокаТовары.Товар;
        Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконто.Склады] = ТекСтрокаТовары.Склад;
        // регистр ОсновнойРегистрБухгалтерии 
        Движение = Движения.ОсновнойРегистрБухгалтерии.Добавить();
        Движение.СчетДт = ПланыСчетов.ОсновнойПланСчетов.Контрагенты;
        Движение.СчетКт = ПланыСчетов.ОсновнойПланСчетов.Капитал;
        Движение.Период = Дата;
        Движение.Организация = Организация;
        Движение.Валюта = ТекСтрокаТовары.Валюта;
        Движение.Сумма = Итого;
        //Движение.СуммаХолдинга = ТекСтрокаТовары.Цена;
        Движение.Содержание = "Продажа товаров";
        Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Склады] = ТекСтрокаТовары.Склад;
        Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконто.Контрагенты] = Контрагент;
 
    // записываем движения регистров
    Движения.ОстаткиТоваров.Записать();
    Движения.ОбъёмЗакупок.Записать();
    Движения.ОсновнойРегистрБухгалтерии.Записать();
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
        КонецЦикла;
КонецПроцедуры
Добавлено через 5 минут
Задания были по регистрам бухгалтерии!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
29.10.2014, 19:40
Ответы с готовыми решениями:

Как исправить ошибку при создании табличной формы справочника
Помогите пожалуйста советом. Сделал табличную форму справочника (рис1), вроде форма получилась....

Если не выбрать цвет и выбрать или коробку передач или класса автомобиля выдает ошибку - как исправить?
помогите пожалуйста с запросом!! код запроса: Процедура Кнопка1Нажатие(Элемент) Запрос = Новый...

Помогите исправить ошибку при обмене
Ошибка при обмене. На глобальной базе запускаю обмен, при загрузки из перефирии выскакивает ошибка....

Как исправить ошибку: формат теста исправить нельзя, только текст программы
class AmericanDate: def __init__(self, y, m, d): self.get_year = str(y) ...

Подскажите как исправить ошибку. прога ломается на 79 строке. а ошибку не выдает
#include <iostream> #include <cstdlib> #include <ctime> using namespace std; int chisla(int...

4
1c-k
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,238
Записей в блоге: 1
29.10.2014, 20:38 2
Привет. Для начала строку 19 закоментируй, там где с валютами и попробуй провести.
0
Fenlou
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 480
29.10.2014, 21:47  [ТС] 3
Цитата Сообщение от 1c-k Посмотреть сообщение
Привет. Для начала строку 19 закоментируй, там где с валютами и попробуй провести.
Ошибка с валютами убралась. Но у меня проблемы с субконто.
0
1c-k
340 / 315 / 43
Регистрация: 20.08.2014
Сообщений: 1,238
Записей в блоге: 1
29.10.2014, 21:49 4
Fenlou, смотри что в кадом субконто и верно вписывай согласно типов
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
30.10.2014, 22:32 5
http://www.cyberforum.ru/post5930400.html разберись, возьми нужное
0
30.10.2014, 22:32
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
30.10.2014, 22:32

Структура: Не могу понять, почему выдает ошибку и как собственно эту ошибку можно исправить?
Привет,не могу понять почему ошибку выдает и как сбстно эту ошибку можно исправить? #include...

Как исправить исправить ошибку в коде
Здравствуйте,помогите пожалуйста исправить ошибку в коде.using System; using System.Threading; ...

Как исправить ошибку
<html> <head> <title>Размер стипендии</title> <script language = "JavaScript"> function st...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru