Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/11: Рейтинг темы: голосов - 11, средняя оценка - 5.00
Werwolf_666999
0 / 0 / 2
Регистрация: 19.06.2010
Сообщений: 175
1

Итог Суммы в отчете

31.10.2014, 09:39. Просмотров 2245. Ответов 1
Метки нет (Все метки)

Здравствуйте. Подскажите, как рассчитать итог суммы в отчете с применением макета? Кусочек кода,в качестве примера. Как можно вычислить сумму цены, средней цены и наценки.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
&НаСервереБезКонтекста
Процедура ЗаполнитьТабДок(ТабДок)   
    ТабДок.Очистить();
    Макет = Отчеты.АнализТорговойНаценки.ПолучитьМакет("Макет"); 
    
    ОблШапка = Макет.ПолучитьОбласть("Шапка");
    ОблЭлемент = Макет.ПолучитьОбласть("Элемент");
    ОблПодвал = Макет.ПолучитьОбласть("Подвал");
    
    ОблШапка.Параметры.ДатаОтчета = Формат(ТекущаяДата(), "ДЛФ=DD");
    ТабДок.Вывести(ОблШапка);
    
 
     
     Запрос = Новый Запрос();
     Запрос.Текст =
     "ВЫБРАТЬ
     |  ЦеныНоменклатуры.Номенклатура.Наименование КАК НоменклатураПолное,
     |  ЦеныНоменклатуры.Цена
     |ИЗ
     |  РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры";
     
    Результат = Запрос.Выполнить();
    Выборка=Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
    //Сообщить(""+Выборка.Период+Символы.Таб+Выборка.Курс); 
    ОблЭлемент.Параметры.НаименованиеПолное = Выборка.НоменклатураПолное;
    ОблЭлемент.Параметры.СредняЦена = Выборка.Цена;
    ОблЭлемент.Параметры.Цена = Выборка.Цена*1.05;
    ОблЭлемент.Параметры.СредняяНаценка = ОблЭлемент.Параметры.Цена - ОблЭлемент.Параметры.СредняЦена;
    ОблЭлемент.Параметры.ПроцентСредней = "5%";
    ТабДок.Вывести(ОблЭлемент); 
КонецЦикла;
 
 
КонецПроцедуры
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.10.2014, 09:39
Ответы с готовыми решениями:

Вывести Итог Суммы в макете
Здравствуйте, помогите пожалуйста.1с 8.2Мне нужно чтобы при печати Итог суммы который находится в...

Расчет суммы и процента в отчете
Здравствуйте столкнулся с такой проблемой что не могу реализовать расчет вычисление суммы и...

Неверные суммы в отчете СКД по Реализации товаров
Всем привет. Ребят, занимаюсь по учебнику Радченко и Хрусталевой СКД. Пытаюсь вывести отчет...

Итог по колонке
1cv77, бухгалтерия 4.5. В документе "РасходнаяНакладная" реквизит табличной части "Сумма" не имеет...

Не могу сделать Итог по колонке
архив с отчетом приложил. помогите пожалуйста.

1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
04.11.2014, 16:13 2
1C
1
2
3
4
5
6
7
СумСум=0;
    Пока Выборка.Следующий() Цикл
СумСум=СумСум+Выборка.Цена*Выборка.Количество;    
...
КонецЦикла;
ОблПодвал.Параметры.Сумма=СумСум; 
ТабДок.Вывести(ОблПодвал);
PS. Просьба: не копировать в свой модуль "в лоб", и жаловаться, что не работает.
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
04.11.2014, 16:13

8.2 Предприятие СКД итог по колонке
день добрый ! курю гугл уже третий день, никак не могу понять, как в СКД вывести итоги по колонке...

Итог по родителям дерева значений
Подскажите . Как подсчитать сумму по родителям в дереве значений и результат вывести в реквизит в...

Итог по столбцу табличного поля
Доброго времени, нужна помощь, 1С начал познавать совсем недавно, и не по своей воле) конфа 8.3 УТ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru