Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Fenlou
1 / 1 / 2
Регистрация: 11.03.2014
Сообщений: 480
1

Маска

31.10.2014, 13:56. Просмотров 245. Ответов 0
Метки нет (Все метки)

Здравствуйте, помогите с маской, данная маска работает, но требует быстрого ввода или использовать стрелку вправо.
Как сделать нормальный, умеренный ввод и добавить обязательность ввода 17 элементов?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
&НаКлиенте
Процедура VINИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
    Массив = Новый Массив(); 
 F = "abcdefghijklmnopqrstuvwxyz0123456789";
 Для сч=1 По СтрДлина(Текст) Цикл
  символ = Сред(Текст, сч,1);
  Если Найти(F, НРег(символ)) = 0 Тогда
   Массив.Добавить(сч);
  КонецЕсли; 
 КонецЦикла; 
 
 Для сч=0 По Массив.ВГраница() Цикл 
  Элемент.УстановитьГраницыВыделения(Массив[Массив.ВГраница()-сч], Массив[Массив.ВГраница()-сч]+1);
  Элемент.ВыделенныйТекст = "";
 КонецЦикла;
 
 Если Не ПустаяСтрока(Элемент.ТекстРедактирования) Тогда
  Элемент.УстановитьГраницыВыделения(1,СтрДлина(Элемент.ТекстРедактирования)+1);
  Элемент.ВыделенныйТекст = ВРег(Элемент.ВыделенныйТекст);
 КонецЕсли; 
КонецПроцедуры
Добавлено через 1 час 28 минут
Обошелся другим способом. Помощь больше не нужна!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
31.10.2014, 13:56
Ответы с готовыми решениями:

Маска ввода
Как в поле на форме документа сделать маску ввода?

Пользовательская маска и маска по умолчанию
Всем привет! Подскажите, пожалуйста, в чём разница между пользовательской маской и маской по...

Маска
Собственно нужно, чтобы if проверял переменную против маски. Типа if($a=**.**.****), но как это...

Маска
Доброго времени суток... подскажите пожалуйста как создать функцию проверки на маску такого вот...

Маска
Суть следующая - у меня есть прямоугольник черного цвета, который ложится поверх всего экрана и...

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
31.10.2014, 13:56

Маска сети
Здравствуйте. Кто-то может простым языком объяснить, как высчитывать маску сети и для чего это...

Маска и рисунок
Привет всем! У меня вопрос. Есть два рисунка PNG с так сказать Альфа каналами которые не видно. ...

Маска подсети
Ответьте на вопросы, пожалуйста: 1. Как определить на сколько подсетей делится маска подсети? 2....


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
1
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru