Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 4.50/10: Рейтинг темы: голосов - 10, средняя оценка - 4.50
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
1

Внешняя обработка печати

06.11.2014, 10:16. Просмотров 1932. Ответов 28
Метки нет (Все метки)

Добрый день, не разу не работал со внешней обработкой печати, подскажите что не так. Работаю с УТ 10.3.
Поставили мне задачу заменить печатную форму, я стал копать, наткнулся на этот код

1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ГБОСертификатыНажатие(Элемент)
    ДокЗаказа = ПоследнийЗаказ.Ссылка;
    СсылкаНаВнешнююОбработку = Справочники.ВнешниеОбработки.НайтиПоНаименованию("ГБО Сертификаты");
    Если ЗначениеЗаполнено(ДокЗаказа) И ЗначениеЗаполнено(СсылкаНаВнешнююОбработку) Тогда
        СтруктураДляПечати = Новый Структура;
        СтруктураДляПечати.Вставить("ИсточникМакета", Перечисления.ВидыДополнительныхВнешнихОбработок.ПечатнаяФорма);
        СтруктураДляПечати.Вставить("НомерСтроки", 1);
        СтруктураДляПечати.Вставить("СсылкаНаВнешнююОбработку", СсылкаНаВнешнююОбработку);
        ТабДок = УниверсальныеМеханизмы.НапечататьВнешнююФорму(ДокЗаказа, СтруктураДляПечати);
    КонецЕсли;
КонецПроцедуры
Вижу, что те сертификаты которые мне нужно заменить, нашел внешнюю печатную форму ГБО Сертификаты, там нашел макет ГБО Сертификаты и исправил в нем. Запускаю я 1С а у меня все по старому, зашел опять все проверил, думал может что слетело, но все в порядке, так и не могу понять почему не работает.
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.11.2014, 10:16
Ответы с готовыми решениями:

Внешняя обработка
Здравствуйте! как из формы внешней обработки сформировать типовой отчет и передать необходимые...

Внешняя обработка
Нужно создать внешнюю обработку. Ввести в поле ввода дату. По кнопке "Сформировать" получить дату,...

Внешняя обработка
Всем привет! Помогите пожалуйста составить такой вот код - (перебирает целые числа от 0 до...

Внешняя обработка из Далион
Ситуация такая имеется обработка из 1С:8 далион, надо переделать в 1С:8 розницу, соответственно в...

Внешняя обработка, создание формы
Всем доброго времени суток. Народ, подскажите, пишу с нуля внешнюю обработку для загрузки данных в...

28
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.11.2014, 21:45 2
есть метка "впф" в разделе. Есть гугл.
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
06.11.2014, 22:40  [ТС] 3
duk337, не понял что за метка
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.11.2014, 22:48 4
Поиск "по метке"
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
06.11.2014, 22:50  [ТС] 5
duk337, как обычно вы загадками говорите
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
06.11.2014, 22:54 6
ну да... всё как обычно, как всегда... Впрочем, я сам страдаю пользовательским кретинизмом
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
06.11.2014, 22:58  [ТС] 7
duk337, хорошо завтра буду разгадывать Ваш ребус
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
07.11.2014, 01:14 8
В справочнике Внешние обработки лежит обработка "ГБО Сертификаты"
Сохрани ее в файл и открой в конфигураторе
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
09.11.2014, 21:03  [ТС] 9
Dethmontt, я так и сделал

Добавлено через 3 минуты
duk337, Не могу найти поиск по метке

Добавлено через 7 минут
Я не понимаю, посмотрел как работает обработка, почему то открывается другой макет которого нет в обрабокте
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
09.11.2014, 23:41 10
1C
1
ПолучитьМакет("ИмяМакета")
Имя макета и нужно искать
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
10.11.2014, 00:33  [ТС] 11
Dethmontt, имя макета ГРО Сертификат
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
10.11.2014, 01:20 12
Цитата Сообщение от Ermak27 Посмотреть сообщение
имя макета ГРО Сертификат
Значит он его и печатает
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
10.11.2014, 08:05  [ТС] 13
Dethmontt, я это понимаю, но макет выводит другой
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
10.11.2014, 09:53 14
Цитата Сообщение от Ermak27 Посмотреть сообщение
но макет выводит другой
Так не бывает!!! либо ты плохо смотришь, либо не туда смотришь!!!
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
10.11.2014, 10:21  [ТС] 15
Dethmontt, выше я показал код при нажатии на кнопку код срабатывает. Не понимаю почему нет такого макета который он выводит.

Добавлено через 41 секунду
Не понимаю где искать
0
wladimir_ui
Шизофреник
358 / 361 / 83
Регистрация: 25.06.2013
Сообщений: 1,141
10.11.2014, 15:22 16
Ermak27, обработку выложи
0
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
10.11.2014, 15:26 17
Ermak27, код что ты выложил тут вообще не причем! он ничего не печатает!

Печатает обработка (ФАЙЛ) и ее экспортная функция
1C
1
функция ПЕЧАТЬ() ЭКСПОРТ
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
10.11.2014, 15:50  [ТС] 18
Dethmontt, При нажатии на кнопку открывается макет сертификатов, по кнопки вышел на код
0
Ermak27
4 / 4 / 0
Регистрация: 16.01.2013
Сообщений: 1,199
10.11.2014, 16:12  [ТС] 19
Выложил обработку
0
Вложения
Тип файла: zip ГБО Сертификаты.zip (5.13 Мб, 8 просмотров)
Dethmontt
Модератор
Эксперт 1С
2659 / 2446 / 421
Регистрация: 10.03.2011
Сообщений: 8,756
Записей в блоге: 1
Завершенные тесты: 1
10.11.2014, 16:19 20
Чо не так то? Все есть в обработке!!!

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
//Функция запуска
Функция Печать() Экспорт
    ТипЗаявления = Неопределено;
    ПечатнаяФорма = Неопределено;
    
    Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
        Если ДополнительныеПараметры.Свойство("ПечатнаяФорма") Тогда
            ПечатнаяФорма = ДополнительныеПараметры.ПечатнаяФорма;
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПечатьСчета" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("Заказ");
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПечатьЗаявления" Тогда
            Если ДополнительныеПараметры.Свойство("ТипЗаявления") Тогда
                ТипЗаявления = ДополнительныеПараметры.ТипЗаявления;
            КонецЕсли;
            ТабДокумент = ПечатьЗаявление(ТипЗаявления); //тип может быть "Плита" или "Водонагреватель"
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ЗаявлениеНаДоставку" Тогда
            ТабДокумент = ПечатьЗаявлениеДоставка();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ОтчетОРозничныхПродажах" Тогда
            ТабДокумент =  ПечатьОРП()
        КонецЕсли;
                
        Если ПечатнаяФорма = "ПКОИзОРП" Тогда
            СоздатьПКОНаОсновании()
        КонецЕсли;
        
        Если ПечатнаяФорма = "ПеремещениеСевергаз" Тогда
            ТабДокумент = ПечатьПеремещения();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОДоговораОказанияУслуг" Тогда
            ТабДокумент = ГБОДоговораОказанияУслуг();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОАктПриемаПередачи" Тогда
            ТабДокумент = ГБОАктПриемаПередачи();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
 
        Если ПечатнаяФорма = "ГБОСоответствиеТС" Тогда
            ТабДокумент = ГБОСоответствиеТС();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОПроведениеИспытаний" Тогда
            ТабДокумент = ГБОПроведениеИспытаний();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОУдостоверение" Тогда
            ТабДокумент = ГБОУдостоверение();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОВозмездноеОказаниеУслуг" Тогда
            ТабДокумент = ГБОВозмездноеОказаниеУслуг();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "ГБОСертификаты" Тогда
            ТабДокумент = ГБОСертификаты();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
 
        Если ПечатнаяФорма = "ГБОСчетЗаказ" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("ЗаказГБО");;
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);  
        КонецЕсли;
        
        Если ПечатнаяФорма = "СчетЗаявлениеДоставка" Тогда
            ТабДокумент = ПечатьСчетаЗаказа("Заказ");
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
            
            Если ДополнительныеПараметры.Свойство("ТипЗаявления") Тогда
                ТипЗаявления = ДополнительныеПараметры.ТипЗаявления;
            КонецЕсли;
            ТабДокумент = ПечатьЗаявление(ТипЗаявления); //тип может быть "Плита" или "Водонагреватель"
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
            
            ТабДокумент = ПечатьЗаявлениеДоставка();
            УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 2, Истина, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект.Ссылка, СсылкаНаОбъект.Ссылка.Метаданные().Представление()),СсылкаНаОбъект.Ссылка);    
        КонецЕсли;
    КонецЕсли; 
КонецФункции // Печать()
0
10.11.2014, 16:19
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.11.2014, 16:19

Внешняя обработка для создания документа
Нужно создать внешнюю обработку для созданию общего заказа поставщику из остальных заказов с...

Планирование статей бюджетов и внешняя обработка
Добрый день! Подскажите алгоритм(хотя бы на пункта три, уже будет прекрасно) действий в...

Внешняя обработка для копирования документов
Здраствуйте, создаю внешнюю обработку для копирования документов. Не могу понять как застить ее...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru