Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.71/41: Рейтинг темы: голосов - 41, средняя оценка - 4.71
Dethmontt
Модератор
Эксперт 1С
2701 / 2465 / 432
Регистрация: 10.03.2011
Сообщений: 8,937
Записей в блоге: 1
Завершенные тесты: 1
1

СтрЗаменить() в запросе или в СКД

16.11.2014, 01:56. Просмотров 7861. Ответов 2
Метки нет (Все метки)

Как реализовать замену символа в строке на языке запросов 1С или на языке выражений СКД ?
Есть какие нибудь идеи как это изящней сделать?

З.Ы. Выбор когда Подстрока(Строка,1,1) = "нужный символ"
НЕ ПРЕДЛАГАТЬ!!!
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.11.2014, 01:56
Ответы с готовыми решениями:

Рабочие дни в запросе СКД
Здравствуйте всем. Сделал самописный отчёт в СКД, нужные значения считает правильно. Но поставили...

Ошибка в запросе. Но в СКД запрос корректно работает!
Вопрос. В СКД сделал запрос с вложенными завпросами. Все нормально отображается. При использовании...

Ошибка в запросе СКД при откате версии
Здравствуйте. Прошу помощи в следующем вопросе. При откате в 8.2.13 на 8.2.10.77 (УПП 1.3.14.1) в...

Убрать поля в запросе (скрыть поля в отчете скд)
В запросе я создаю временную таблицу. В ней сгруппировав поля получаю нужную таблицу. Но некоторые...

СТРЗаменить
Добрый вечер собственно вот есть лицевые счета 0200100899; 0200100900 и т.д. хочу избавиться от...

2
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
16.11.2014, 13:06 2
Вставлял в СКД юзерполе с юзерфанкшн, в которой тупо стрзаменить. В запросе никак, по-моему. Сам SQL тоже не поддерживает, хотя боюсь соврать. Вот тут в примере нету, по крайней мере: http://msdn.microsoft.com/en-us/library/aa978496%28v=vs.71%29.aspx
0
Dethmontt
Модератор
Эксперт 1С
2701 / 2465 / 432
Регистрация: 10.03.2011
Сообщений: 8,937
Записей в блоге: 1
Завершенные тесты: 1
16.11.2014, 15:38  [ТС] 3
Пока сделал так. Но это решение мне не нравиться!(хотя и рабочее для моего случая)
З.Ы. т.к. обработкой буду пользоваться не я, не хотелось бы отдавать это решение

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
    МассивОбластей = Новый Массив;
    Для каждого Пар Из МакетКомпоновки.Макеты.Макет5.Параметры Цикл
                //Ищем колонки где в выражении сидит мой параметр &Префикс
        Если ТипЗнч(Пар) = Тип("ПараметрОбластиВыражениеКомпоновкиДанных") и Найти(Пар.Выражение,"&Префикс") > 0 Тогда
            МассивОбластей.Добавить(Пар.Имя);
        КонецЕсли; 
    КонецЦикла; 
    
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
    ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
    
    ПроцессорВывода.НачатьВывод();
    
    ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    Пока ЭлементРезультата <> Неопределено Цикл
        Если ЭлементРезультата.ЗначенияПараметров.Количество()>0 Тогда
            Для каждого Обл Из МассивОбластей Цикл //Тут через параметры лень было делать... Хотя можно попробовать СЗ затолкать
                ЭлементРезультата.ЗначенияПараметров[Обл].Значение = СтрЗаменить(ЭлементРезультата.ЗначенияПараметров[Обл].Значение,"*","х");
                ЭлементРезультата.ЗначенияПараметров[Обл].Значение = СтрЗаменить(ЭлементРезультата.ЗначенияПараметров[Обл].Значение,"_","");
            КонецЦикла; 
        КонецЕсли;
        ПроцессорВывода.ВывестиЭлемент(ЭлементРезультата);
        ЭлементРезультата = ПроцессорКомпоновки.Следующий();
    КонецЦикла;
    ПроцессорВывода.ЗакончитьВывод();
0
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
16.11.2014, 15:38

СтрЗаменить - выдает не те символы
Доброго времени суток! Подскажите в чем проблема. п=Док.Номер; //Док-документ ЗаказПокупателя,...

Замена СтрЗаменить на любой цикл
Добрый вечер, можно ли как-то заменить этот программный код, чтобы был использован обязательно...

8.3 СКД ВычислитьВыражение или что-то другое ?
Задача: показать в итоге отчета-таблицы количество выведенных строк с данными. Думается, что...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.