Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
Ekaterina
0 / 0 / 0
Регистрация: 28.04.2014
Сообщений: 32
1

Написать функцию, которая вернет реквизит "содержание" в табличной части услуги

08.12.2014, 17:51. Просмотров 857. Ответов 5
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Процедура Реквизит1ПриИзменении(Элемент)
    а=1;
    Строка="";
    ИсходнаяСтрока=Объект.Реквизит1;
    ДлинаСтроки = СтрДлина(ИсходнаяСтрока);
    Для а=1 по ДлинаСтроки Цикл
        Строка=Сред(ИсходнаяСтрока,а,1);        
        Если Строка="/" Тогда
            Строка7=Сред(ИсходнаяСтрока,а+7,1);
            Если Строка7="/" Тогда
                НомерГТД=Сред(ИсходнаяСтрока,а-8,23);
                Сообщить(НомерГТД);
            КонецЕсли;
            
        КонецЕсли;      
     КонецЦикла;
    
КонецПроцедуры
Помогите написать функцию чтобы возвращала этот список......пожалуйста.......
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.12.2014, 17:51
Ответы с готовыми решениями:

Как обратиться к табличной части документа из процедуры "ПриЗаписи"
Здравствуйте! Создается новый документ. В его модуле, в процедуре "ПриЗаписи", необходимо...

Заполнение табличной части документа "Инвентарных номеров"
Здравствуйте многоуважаемые форумчане. Обращаюсь к Вам за очередной помощью. После долгих исканий...

Где перехватить стандартный обработчик "кнопки создать" в табличной части?
Где перехватить стандартный обработчик "кнопки создать" в табличной части типа динамический список...

Сохранить значение реквизитов и табличной части внешней обработки "куда-то" что бы потом открыть
Здравствуйте, Форумчане) Есть одна внешняя обработка. Которая имеет несколько реквизитов (тип...

Создание ссылки на реквизит в табличной части
Такая беда есть справочник Дисциплины в котором есть табличная часть Темы и Реквизит...

5
Dethmontt
Модератор
Эксперт 1С
2686 / 2466 / 429
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
08.12.2014, 23:26 2
Цитата Сообщение от Ekaterina Посмотреть сообщение
этот список....
Какой список?

Добавлено через 3 минуты
Лучше бы написала что ЕСТЬ и что из этого нужно получить, было бы понятнее...
0
Ekaterina
0 / 0 / 0
Регистрация: 28.04.2014
Сообщений: 32
09.12.2014, 09:14  [ТС] 3
в реализации товаров и услуг есть табличная часть услуги в ей есть реквизит содержание вот эта строка "содержание" должна возвращаться, написано должно быть в виде функции..... помогите если можите...

Добавлено через 8 минут
написать функцию которая вернет реквизит "содержание" в табличной части услуги....
0
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
09.12.2014, 23:37 4
1C
1
2
ф=СтрЗаменить("*"+ИсходнаяСтрока,"/",Символы.ПС);
ФрагментГТД=СтрПолучитьСтроку(ф,2)+СтрПолучитьСтроку(ф,3);
это приблизительно.
0
Dethmontt
Модератор
Эксперт 1С
2686 / 2466 / 429
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
10.12.2014, 01:50 5
Лучший ответ Сообщение было отмечено duk337 как решение

Решение

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
//Параметры:
//Источник - экземпляр объекта или ссылки на документ/справочник (тип любая ссылка или любой объект) - например ДокументСсылка.РеализацияТоваровУслуг
//ИмяТЧ - Имя табличной части в которой будет происходить поиск реквизита
//НомерСтроки - номер строки из которой необходимо получить значение
//ИмяРеквизита - Имя/Идентификатор реквизита табличной части, значение которого необходимо получить
 
//ПЗРТЧ - ПолучитьЗначениеРеквизитаТабличнойЧасти
//Development for Ekaterina.  :D
Функция ПЗРТЧ(Источник, ИмяТЧ, НомерСтроки, ИмяРеквизита)
    
    ТипОбъекта = ТипЗнч(Источник);
    
    МД = Метаданные.НайтиПоТипу(ТипОбъекта);
        
    Если МД = Неопределено Тогда
        ВызватьИсключение "Тип объекта <"+ТипОбъекта+"> не найден в конфигурации";
    КонецЕсли;
    
    Если Метаданные.Перечисления.Содержит(МД) Тогда 
        ВызватьИсключение "Нельзя передавать значения перечислений!"; 
    КонецЕсли;  
    
    ТЧ = МД.ТабличныеЧасти.Найти(ИмяТЧ);
    Если ТЧ = Неопределено Тогда
        ВызватьИсключение "У типа объекта <"+ТипОбъекта+"> не найдена табличная часть с именем - "+ИмяТЧ;
    КонецЕсли;
    
    ВсегоСтрок = Источник[ИмяТЧ].Количество();
    Если НомерСтроки < 1 или НомерСтроки > ВсегоСтрок Тогда
        ВызватьИсключение "Для объекта <"+ТипОбъекта+"> в таблице "+ИмяТЧ+" не найдена строка №"+НомерСтроки;
    КонецЕсли;
    
    Если ТЧ.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда
        ВызватьИсключение "Для объекта <"+ТипОбъекта+"> в таблице <"+ИмяТЧ+"> не найден реквизит с именем - "+ИмяРеквизита;
    КонецЕсли;
    
    Возврат Источник[ИмяТЧ][НомерСтроки-1][ИмяРеквизита];
    
КонецФункции
Пример вызова функции:
1C
1
2
3
Процедура КнопкаНажатие(Элемент)
   ЗначениеРеквизита = ПЗРТЧ(ДокументОбъектИЛИСсылка, "Услуги", 1, "Содержание");
   Сообщить(ЗначениеРеквизита);
1
duk337
2951 / 1763 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
10.12.2014, 13:38 6
Dethmontt,

Не по теме:

Ещё предлагать сразу кроссплатформенные функции, чтоб и для 77 и для 8 подходили

0
10.12.2014, 13:38
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2014, 13:38

Ссылка на реквизит табличной части справочника?
Здравствуйте, дорогие коллеги! Вопрос у меня такой - возможно ли в колонку ТаблицыЗначений записать...

Вывод суммы из табличной части в реквизит
Как это сделать ?

Ссылка На Реквизит Табличной Части Справочника?
Здравствуйте, дорогие коллеги! Вопрос у меня такой - возможно ли в колонку ТаблицыЗначений записать...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru