Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/6: Рейтинг темы: голосов - 6, средняя оценка - 4.50
Randal
3 / 3 / 1
Регистрация: 12.04.2014
Сообщений: 35
1

Ошибка при выборе элемента перечисления

09.12.2014, 09:34. Просмотров 1124. Ответов 4
Метки нет (Все метки)

Здравствуйте,столкнулся с такой проблемой. нужно на форме с помощью 2-х реквизитов выполнить операции(сложение,вычитание,умножение) и сохранить результат в Константу "Результат". для этого создал Перечисление "Операции" соответственно с реквизитами Сложение,Вычитание,Умножение
делаю:

Ошибка при выборе элемента перечисления


1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
&НаКлиенте
Процедура Вычислит1(Команда)
    ВычислитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ВычислитьНаСервере()
    Если Перечисления.Операции.Получить(0)
        Тогда Число3 = Число1 + Число2
    ИначеЕсли Перечисления.Операции.Получить(1)
        Тогда Число3 = Число1 - Число2
    ИначеЕсли Перечисления.Операции.Получить(2)
        Тогда Число3 = Число1 * Число2
    КонецЕсли;
    Константы.Результат.Установить(Число3); 
    Сообщить("Итог вычисления:" + Константы.Результат.Получить());
КонецПроцедуры
не понимаю, толи я не правильно задал выбор элемента перечисления. ругается "Преобразование к типу Булево не может быть выполнено". помогите пожалуйста
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.12.2014, 09:34
Ответы с готовыми решениями:

Установка отбора при выборе элемента в ТЧ обработки
Здравствуйте. Есть обработка в собственной конфигурации, в которой есть реквизиты: подразделение -...

1с выдимые и невидимые табличные части при выборе элемента
Уважаемые знатоки! Есть две табличные части : сотрудник и ОЛмедсестры. Появилась необходимость при...

Как при выборе элемента справочника сделать отображение кода, а не наименование?
имеется таб. часть, в ней поле с типом справочникссылка. как при выборе элемента в этом поле...

При выборе цвета из перечисления enum должны задаваться коэффициенты при помощи атрибутов
Помогите пожалуйста! Есть задание:добавление ингредиента в кулинарный стакан, при выборе цвета из...

Ошибка при выборе элемента DataGridViewComboBoxColum
C#; VS2010 Доброго времени суток! Считываю данные из файлов. Для удобства редактирования,...

4
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 11:19 2
Лучший ответ Сообщение было отмечено Randal как решение

Решение

1C
1
 Если Перечисления.Операции.Получить(0) ТОГДА
Не явное приведение к типу БУЛЕВО

Нужно приводит ЯВНО
1C
1
Если ИмяРеквизитаСодержащегоЗначениеПеречисления = Перечисления.Операции.Сложение ТОГДА
0
Randal
3 / 3 / 1
Регистрация: 12.04.2014
Сообщений: 35
09.12.2014, 13:27  [ТС] 3
то есть нужно просто элемент значение перечисления присвоить какой-либо переменной? как я понимаю
Ошибка при выборе элемента перечисления
0
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,850
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 13:41 4
Лучший ответ Сообщение было отмечено Randal как решение

Решение

Цитата Сообщение от Randal Посмотреть сообщение
то есть нужно просто элемент значение перечисления присвоить какой-либо переменной?
Ничего никуда не нужно присваивать!

На форме должна быть переменная которая хранит значение перечисления выбранного на ФОРМЕ его и нужно сравнивать со значением в БАЗЕ

Добавлено через 47 секунд
Переменную
1C
1
ИмяРеквизитаСодержащегоЗначениеПеречисления
Заменить на имя реквизита на форме!
0
Randal
3 / 3 / 1
Регистрация: 12.04.2014
Сообщений: 35
09.12.2014, 13:44  [ТС] 5
да да спасибо большое! я просто протупил малость)
0
09.12.2014, 13:44
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.12.2014, 13:44

Ошибка при выборе элемента DataGridViewComboBoxColum
при попытке изменить значение в DataGridViewComboBoxColum вылетает ошибка Тестовый проект...

В динамической сборке при выборе элемента treeWidget вылетает ошибка
Ребята, возникла такая вот очень странная проблема. Собираю значит программу на Qt 5.3.1...

Ошибка при передаче перечисления как параметра
Здравствуйте! Я пока в С++ начинающий студия 2012, проблема такая учусь по книжки Хортона, создал...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru