Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
Robesper3411
17 / 17 / 2
Регистрация: 20.02.2012
Сообщений: 452
Записей в блоге: 1
Завершенные тесты: 1
1

Данные, которые могут использовать разные формы. Передача значения в форму-родитель.

09.12.2014, 10:49. Просмотров 698. Ответов 7
Метки нет (Все метки)

Всем доброго времени суток!
Есть две формы в обработке. Мне нужен способ, чтобы они могли друг с другом общаться. Есть массив, который формируется в одной форме, и я его хочу использовать во второй. Если есть какая-нибудь возможность, чтобы ввести какие-нибудь глобальные переменные, то было бы замечательно. Если есть другие способы, то буду рад их выслушать. Только желательно объяснить как можно проще - в 1С я новичок.
0
Лучшие ответы (1)
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
09.12.2014, 10:49
Ответы с готовыми решениями:

Как сделать чтоб данные, которые заносят в форму, сохранялись в 2 разные таблицы
Как сделать чтоб данные, которые заносят в форму, сохранялись в 2 разные таблицы, при чем конкретно...

Передача значения из формы в форму
Из форм 2,6,7,8,9 нужно перенести значения счетчиков в форму 4.сровнять значения и вывести большее...

Передача значения TextBox из формы в форму
Создал одну форму, из нее вызываю другую форму, но никак не могу передать значение textBox из...

Как найти нужные значения из ячеек, которые содержат разные данные, по нескольким условиям
Добрый день! Помогите, пожалуйста, два дня голову ломаю. Есть 5 столбцов с данными. Это либо...

При вызове menuStrip у дочерней формы фокус переводится на форму- родитель
Добрый день уважаемые форумчане. Проблема в следующем: При вызове menuStrip у дочерней формы...

7
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,846
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 11:11 2
ОбработкаОповещения() и метод Оповестить()
0
Robesper3411
17 / 17 / 2
Регистрация: 20.02.2012
Сообщений: 452
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 11:59  [ТС] 3
Dethmontt, хм, что-то не могу найти этого метода.
0
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,846
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 12:08 4
Плохо ищешь
0
09.12.2014, 12:08
Robesper3411
17 / 17 / 2
Регистрация: 20.02.2012
Сообщений: 452
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 13:05  [ТС] 5
Dethmontt, может есть другие варианты?! А то пока чего-то не то.
0
Dethmontt
Модератор
Эксперт 1С
2685 / 2465 / 428
Регистрация: 10.03.2011
Сообщений: 8,846
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 13:35 6
Лучший ответ Сообщение было отмечено Robesper3411 как решение

Решение

Код формы 1

1C
1
2
3
4
5
6
7
8
Форма = ПолучитьФорму("ПутьДоФормы", ЭтФорма); //Если не глобальный контекст (получаем форму 2 с установкой владельца этой формы)
Форма.Открыть();
 
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник) 
   Если ИмяСобытия = "МоеСобытие" Тогда
       Сообщить(Параметр);
   КонецЕсли;
КонецПроцедуры
Код формы 2
1C
1
2
3
4
5
Процедура НекоеДействиеФормы2()
 
   Оповестить("МоеСобытие", "Это данные которые я передаю из формы 2", ЭтаФорма);
 
КонецПроцедуры
1
Robesper3411
17 / 17 / 2
Регистрация: 20.02.2012
Сообщений: 452
Записей в блоге: 1
Завершенные тесты: 1
09.12.2014, 16:01  [ТС] 7
Dethmontt, практически то, что нужно.
0
Dethmontt
10.12.2014, 00:16     1C 8.x Данные, которые могут использовать разные формы. Передача значения в форму-родитель.
  #8

Не по теме:

Цитата Сообщение от Robesper3411 Посмотреть сообщение
Dethmontt, может есть другие варианты?! А то пока чего-то не то.
Ты просто не умеешь их готовить...

0
10.12.2014, 00:16
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.12.2014, 00:16
Привет! Вот еще темы с ответами:

Произведение ячеек, которые могут содержать нечисловые значения
Кто может помогите!!! При выполнении произведения нескольких ячеек появляется #ЗНАЧ! ? Если хоть в...

Можно ли использовать вложенные инструкции On error, которые ведут на разные метки
Подскажите, можно ли использовать вложенные инструкции On error, которые ведут на разные метки? ...

Создание библиотеки функций, которые могут принимать аргументы и возращать значения
Создал простую библиотеку для теста: Public Class Class1 Function teest(ByVal i As Integer)...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru