Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.83/6: Рейтинг темы: голосов - 6, средняя оценка - 4.83
unknown_sb
7 / 7 / 2
Регистрация: 25.11.2013
Сообщений: 46
1

Простой запрос регистра накопления

04.02.2015, 18:23. Просмотров 1113. Ответов 6
Метки нет (Все метки)

Всем доброе время суток.
Сижу уже второй день над проблемой. Есть простой запрос из регистра накопления:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    Элементы.БазоваяЕденицаИзмерения.Доступность = БазоваяЕденицВРегистрах(Объект.Ссылка);
 
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция БазоваяЕденицВРегистрах(Номенклатура)
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   ОстаткиТоваровОбороты.Номенклатура,
        |   ОстаткиТоваровОбороты.КоличествоОборот
        |ИЗ
        |   РегистрНакопления.ОстаткиТоваров.Обороты КАК ОстаткиТоваровОбороты
        |ГДЕ
        |   ОстаткиТоваровОбороты.Номенклатура = &Номенклатура";
    
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Возврат РезультатЗапроса.Пустой();
    
КонецФункции
Хочу просто посмотреть были ли движения в регистре по конкретной номенклатуре, но он ничего не выдает.
Пустой запрос. Если убрать условие, то он выдает все что там есть (как бы логично), а вот с условием не работает.
И такое не только с этим конкретно запросом. Я писал кое что другое и в другом месте, там тоже с параметром не хочет работать. Подскажите, что не так?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
04.02.2015, 18:23
Ответы с готовыми решениями:

Заполнение документа данными из регистра накопления. Создание отчета по данным регистра накопления.
Изучаю 1с по методичкам не могу решить два задания Объясните что да как делается +100 в карму

Запрос к остаткам регистра накопления
Функция ПолучитьДаныеПоСырью(ТекДокумент, МассивСырья) Запрос = Новый Запрос; Запрос.Текст =...

Измерения регистра накопления
Здравствуйте. Подскажите пожалуйста по работе регистра накопления. Регистр Накопления...

Выборка из регистра накопления остатков
Здравствуйте. Я только учусь поэтому сильно не пинайте если вопросы глупые. Есть задание - в...

Данные из регистра накопления в переменную
помогите пожалуйста. В 1С предприятие имеются документы поступления и списания материалов со...

6
Dethmontt
Модератор
Эксперт 1С
2655 / 2444 / 419
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
04.02.2015, 18:34 2
unknown_sb,
1. Правильнее писать такие условия в параметры виртуальной таблицы
1C
1
2
ИЗ
        |   РегистрНакопления.ОстаткиТоваров.Обороты(,,,Номенклатура = &Номенклатура) КАК ОстаткиТоваровОбороты
2. Тип переменной "Номенклатура" и тип переменной Измерения Регистра совпадают?
1C
1
2
Сообщить("тип моего отбора - "+типЗнч(Номенклатура));
Запрос.УстановитьПараметр("Номенклатура", Номенклатура); //Какой тип у переменной Номенклатура?
0
unknown_sb
7 / 7 / 2
Регистрация: 25.11.2013
Сообщений: 46
04.02.2015, 18:46  [ТС] 3
Цитата Сообщение от Dethmontt Посмотреть сообщение
Сообщить("тип моего отбора - "+типЗнч(Номенклатура));
1C
1
Тип моего отбора - Номенклатура
Попробовал и в виртуальной таблице сделать условие, все равно ничего нет(
0
Dethmontt
Модератор
Эксперт 1С
2655 / 2444 / 419
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
04.02.2015, 18:59 4
Какой тип измерения в Регистре?

Обороты за какой период? Зачем тебе вообще обороты?

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
&НаСервереБезКонтекста
Функция БазоваяЕденицВРегистрах(Номенклатура)
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |   ОстаткиТоваровОбороты.Номенклатура
        |ИЗ
        |   РегистрНакопления.ОстаткиТоваров КАК ОстаткиТоваровОбороты
        |ГДЕ
        |   ОстаткиТоваровОбороты.Номенклатура = &Номенклатура";
    
    Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Возврат РезультатЗапроса.Пустой();
    
КонецФункции
1
unknown_sb
7 / 7 / 2
Регистрация: 25.11.2013
Сообщений: 46
04.02.2015, 19:27  [ТС] 5
Dethmontt, действительно накосячил в регистре, не указал ссылку на справочник. Спасибо за помощь)))
Обороты нужны были для того, что бы посмотреть были ли движения по конкретной номенклатуре, что бы запретить изменять единицу измерения.
0
Dethmontt
Модератор
Эксперт 1С
2655 / 2444 / 419
Регистрация: 10.03.2011
Сообщений: 8,748
Записей в блоге: 1
Завершенные тесты: 1
04.02.2015, 22:11 6
Цитата Сообщение от unknown_sb Посмотреть сообщение
Обороты нужны были для того, что бы посмотреть были ли движения по конкретной номенклатуре
А что ОДНА запись в физической таблице тебя не устраивает? Нужны именно обороты?
0
unknown_sb
7 / 7 / 2
Регистрация: 25.11.2013
Сообщений: 46
05.02.2015, 13:05  [ТС] 7
Цитата Сообщение от Dethmontt Посмотреть сообщение
А что ОДНА запись в физической таблице тебя не устраивает? Нужны именно обороты?
И опять вы правы, не знаю почему именно туда полез)
0
05.02.2015, 13:05
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
05.02.2015, 13:05

Подставление цены номенклатуры из регистра накопления
Только начинаю познавать азы прогр-я 1с. Необходимо продать товар по его средней себестоимости. ...

Последнее значение ресурса регистра накопления
Здравствуйте. в собственной конфигурации есть документ "Ежедневный отчет", который создает движение...

Отчет по выбранным датам из регистра накопления
Есть регистр накопления "Бронь" в котором хранится информация от забронированных датах на номера в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru