Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.92/13: Рейтинг темы: голосов - 13, средняя оценка - 4.92
bukashchik
0 / 0 / 0
Регистрация: 21.04.2015
Сообщений: 2
1

Как вызвать функцию формы "Обработки" из "Общего модуля"?

21.04.2015, 17:30. Просмотров 2610. Ответов 4
Метки нет (Все метки)

В Обработке реализована некая функция. Как мне вызвать ее из Общего модуля?

Эта функция собирает следующие данные о разных формах объектов конфигурации:
Функция GetFormInfos() Экспорт
mForm=Справочники["имяСправочника"].ПолучитьФорму("ФормаЭлемента");
ИЛИ
mForm=Документы["имяДокумента"].ПолучитьФорму("ФормаЭлемента");

//получаем описание формы
fName=mForm.Наименование;
fTitle=mForm.Заголовок;
...

//получаем описание элементов формы
controls=mForm.ЭлементыФормы;
...
КонецФункции

Получить описание форм для разных объектов конфигурации не удалось ни из объектов Справочник, Документ и т.д., ни из Общего Модуля, т.к. при попытке вызова "ПолучитьФорму" для "других" объектов, возвращается просто "Неопределено".
А вот из Обработки удается это сделать.


В итоге мне нужно, чтобы веб-функция дергала ф-цию общего модуля, а та возвращала описание форм.

Пытаюсь делать так:
1 Вариант:
В общем модуле:
Функция Method() Экспорт
obr=Обработки.ОбработкаТест.Создать();
mForm=obr.ПолучитьФорму();
mForm.Открыть();
КонецФункции

А в "ПриОткрытии" вызываю GetFormInfos, которая запишет описания в файл.

Ругается на "ПолучитьФорму": "Интерактивные операции недоступны".

В свойствах модуля у меня стоят галочки на: Клиент(управляемое прилож.), Клиент(обычное прилож.),сервер,внешнее соединение. Короче, везде...

2 Вариант:
Заменяю в Method:
mForm=ПолучитьФорму("Обработка.ОбработкаТест.Форма.Форма",mParams);
mForm.Открыть();

mParams-структура с моими параметрами

Ругается: "Процедура или функция с указанным именем не определена (ПолучитьФорму)"


Какие еще варианты возможны?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
21.04.2015, 17:30
Ответы с готовыми решениями:

1С 8.3 Розница 2.1.4.9 "Текущая цена розницы" и "Остаток" в форме элемента "Номенклатура"
Есть ли готовое решение, можно через внешнюю форму нужно контроль "Текущая цена розницы" и...

Как создать колонку "Цена" и "Количество" в справочнике номенклатура
Подскажите как создать колонку "Цена" и "Количество" в справочнике номенклатура?

Как вызвать процедуру "Предупреждение()" в модуле объекта?
Если текущая дата больше даты выдачи книги то должно быть окно вывод, что дата выдачи книги...

Кнопка "Выбрать" на форме выбора или как выполнить нажатие кнопки "Выбрать"
Добрый день! Обычное приложение. Какие мысли есть, чтобы выполнить нажатие на кнопку...

На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений"
1С.8.0 На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений". При...

4
bukashchik
0 / 0 / 0
Регистрация: 21.04.2015
Сообщений: 2
21.04.2015, 17:37  [ТС] 2
Есть ф-ция, которая собирает следующие данные о разных формах объектов конфигурации:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
Функция [B]GetFormInfos[/B]() Экспорт
mForm=Справочники["имяСправочника"].ПолучитьФорму("ФормаЭлемента");
ИЛИ 
mForm=Документы["имяДокумента"].ПолучитьФорму("ФормаЭлемента");
 
//получаем описание формы
fName=mForm.Наименование;
fTitle=mForm.Заголовок;
...
 
//получаем описание элементов формы    
controls=mForm.ЭлементыФормы;
...
КонецФункции
Получить описание форм для разных объектов конфигурации не удалось ни из объектов Справочник, Документ и т.д., ни из Общего Модуля, т.к. при попытке вызова "ПолучитьФорму" для "других" объектов, возвращается просто "Неопределено".
А вот из Обработки удается это сделать.

В итоге мне нужно, чтобы веб-функция дергала ф-цию общего модуля, а та возвращала описание форм.

Вызвать в общем модуле функцию GetFormInfos из Обработки мне пока не удается, т.к. она должна быть "&НаКлиенте", из-за чего общий модули говорит, что не видит ее...

Подскажите пожалуйста, какие еще возможны варианты?
Как, откуда можно бы получить описание форм?
0
Dethmontt
Модератор
Эксперт 1С
2679 / 2460 / 427
Регистрация: 10.03.2011
Сообщений: 8,820
Записей в блоге: 1
Завершенные тесты: 1
22.04.2015, 00:35 3
bukashchik, web-сервер исполняется только на Сервере (Галками ты указываешь где код должен компилироваться)
Храни описание форм в кокой либо таблице БД
0
qjkxbmw777
0 / 0 / 0
Регистрация: 23.04.2015
Сообщений: 2
23.04.2015, 11:36 4
Видеокурс по языку компоновки данных 1С
https://www.dropbox.com/sh/9kg0avjgw...MTyMO8Xda?dl=0
0
Dethmontt
24.04.2015, 10:19     1C 8.x Как вызвать функцию формы "Обработки" из "Общего модуля"?
  #5

Не по теме:

qjkxbmw777, СКД конечно тут в тему!!!

0
24.04.2015, 10:19
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
24.04.2015, 10:19
Привет! Вот еще темы с ответами:

Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода"
Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода" с типом...

Автоматическое заполнение поля "Комментарий" документа "заказ покупателя"
Всем здравствуйте! Помогите, пожалуйста, решить такую задачку: С сайта (на Битриксе) выгружаются...

1c 8.2 как "прочитать" с формы элемент?
Подскажите пожалуйста как заполнить всю(или выделенные строки) табличную часть документа выбранным...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru