Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
 
Рейтинг 5.00/6: Рейтинг темы: голосов - 6, средняя оценка - 5.00
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
1

Заполнение ТЧ одного документа ТЧ другого, заполнение тч из запроса

06.06.2015, 15:27. Просмотров 1098. Ответов 22
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
&НаСервере
Процедура ЗаполнитьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ТоварнаяНакладная.Ссылка
    |ИЗ
    |   Документ.ТоварнаяНакладная КАК ТоварнаяНакладная
    |ГДЕ
    |   ТоварнаяНакладная.Ссылка = &МассаБрутто";
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
         НоваяСтрока = ОбъектМассаБрутто.Добавить();
         НоваяСтрока.МассаБрутто = Выборка.МассаБрутто;
    КонецЦикла;
    
КонецПроцедуры
 
&НаКлиенте
Процедура Заполнить(Команда)
        ЭтаФорма.Записать();
        ЗаполнитьНаСервере();
    КонецПроцедуры
Есть док ТоварнаяНакладная в нем тчНакладная в ней МассаБрутто и МассаНетто
есть докНакладнаяНаОтпуск в нем тчТовар в ней МассаБрутто МассаНетто
нужно организовать запрос на выбор массы и из запроса заполнить поля накладной
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
06.06.2015, 15:27
Ответы с готовыми решениями:

Заполнение ТЧ одного документа ТЧ другого
&НаСервере Процедура ЗаполнитьНаСервере() Запрос = Новый Запрос; ...

Заполнение табличной части одного документа данными из ТЧ другого
Здравствуйте. Есть 2 документа: 1) "Выдача книги" с табличной частью...

Заполнение табличной части одного документа на основании другого.
Мне необходимо чтобы в Документе :ЗаказНаПроизводство в Табличной части: Товар...

Заполнение на форме данными из другого документа
Здравствуйте! Перейду собственно к проблеме - имеется два документа (Допустим...

Заполнение табличной части одного документа при проведение другого
Подскажите пожалуйста, какой можно использовать синтаксис при такой ситуации. ...

22
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
06.06.2015, 17:24 2
А где Запрос.УстановитьПараметр( , );
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
06.06.2015, 17:36  [ТС] 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
&НаСервере
Процедура ЗаполнитьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   ТоварнаяНакладная.Накладная.(
    |       Товар.Наименование,
    |       МассаБрутто,
    |       МассаНетто
    |   )
    |ИЗ
    |   Документ.ТоварнаяНакладная КАК ТоварнаяНакладная
    |ГДЕ
    |   ТоварнаяНакладная.Накладная.МассаБрутто = &МассаБрутто";
    Запрос.УстановитьПараметр("МассаБрутто", МассаБрутто);
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
         ЗаполнитьЗначенияСвойств(Товар.Добавить(), Выборка);
         
    КонецЦикла;
    
КонецПроцедуры
 
&НаКлиенте
Процедура Заполнить(Команда)
        ЭтаФорма.Записать();
        ЗаполнитьНаСервере();
    КонецПроцедуры
{Документ.НакладнаяНаОтпуск.Форма.ФормаДокумента.Форма(32,43)}: Переменная не определена (МассаБрутто)
Запрос.УстановитьПараметр("МассаБрутто", <<?>>МассаБрутто); (Проверка: Сервер)
{Документ.НакладнаяНаОтпуск.Форма.ФормаДокумента.Форма(36,35)}: Переменная не определена (Товар)
ЗаполнитьЗначенияСвойств(<<?>>Товар.Добавить(), Выборка); (Проверка: Сервер)

Что не так делаюто?

Добавлено через 5 минут
получается нужно взять реквизиты массы и заполнить накладную
1) Правильно ли организован запрос на выбор Массы
2) Как передать пробовал через заполнить не получается ошибка
можно примерчик)
0
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
06.06.2015, 17:37 4
Как понимаю, обращаться надо к тчНакладная и заполнять тчТовар
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
06.06.2015, 17:38  [ТС] 5
Цитата Сообщение от Fairuza Посмотреть сообщение
Как понимаю, обращаться надо к тчНакладная и заполнять тчТовар
да)
0
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
06.06.2015, 17:41 6
Мне кажется здесь надо указать Документ.ТоварнаяНакладная.Накладная КАК ТоварнаяНакладная
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
06.06.2015, 17:43  [ТС] 7
Цитата Сообщение от ravinka Посмотреть сообщение
ВЫБРАТЬ
* * | * ТоварнаяНакладная.Накладная.(
* * | * * * Товар.Наименование,
* * | * * * МассаБрутто,
* * | * * * МассаНетто
* * | * )
* *|ИЗ
* * | * Документ.ТоварнаяНакладная КАК ТоварнаяНакладная
* *|ГДЕ
* * | * ТоварнаяНакладная.Накладная.МассаБрутто = &МассаБрутто";
вот есть или я не в том направлении
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
07.06.2015, 01:00 8
Цитата Сообщение от ravinka Посмотреть сообщение
* * | * Документ.ТоварнаяНакладная КАК ТоварнаяНакладная
* * | * Документ.ТоварнаяНакладная.Накладная КАК ТоварнаяНакладная
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
07.06.2015, 11:11  [ТС] 9
{Документ.НакладнаяНаОтпуск.Форма.ФормаДокумента.Форма(32,43)}: Переменная не определена (МассаБрутто)
Запрос.УстановитьПараметр("МассаБрутто", <<?>>МассаБрутто); (Проверка: Сервер)
{Документ.НакладнаяНаОтпуск.Форма.ФормаДокумента.Форма(36,35)}: Переменная не определена (Товар)
ЗаполнитьЗначенияСвойств(<<?>>Товар.Добавить(), Выборка); (Проверка: Сервер)

что получается не видит их или что?
или сначала их определить надо
0
Fairuza
Модератор
5206 / 2634 / 471
Регистрация: 23.11.2010
Сообщений: 8,690
07.06.2015, 11:48 10
Я, конечно, могу ошибаться, но Вы хотите заполнить документ НакладнаяНаОтпуск на основании документа ТоварнаяНакладная?
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
07.06.2015, 15:05  [ТС] 11
Цитата Сообщение от Fairuza Посмотреть сообщение
Я, конечно, могу ошибаться, но Вы хотите заполнить документ НакладнаяНаОтпуск на основании документа ТоварнаяНакладная?
ну чтобы из документа перенести реквизиты в другой документ
0
Dethmontt
Модератор
Эксперт 1С
2617 / 2417 / 407
Регистрация: 10.03.2011
Сообщений: 8,595
Записей в блоге: 1
Завершенные тесты: 1
08.06.2015, 00:00 12
Цитата Сообщение от ravinka Посмотреть сообщение
что получается не видит их или что?
Что именно где и кто не видит?

Цитата Сообщение от ravinka Посмотреть сообщение
Переменная не определена (МассаБрутто)
Нету у вас такой переменной!!!!
Цитата Сообщение от ravinka Посмотреть сообщение
Запрос.УстановитьПараметр("МассаБрутто", <<?>>МассаБрутто);
Вообще бред какой-то......
Цитата Сообщение от ravinka Посмотреть сообщение
Переменная не определена (Товар)
Что такое товар???????????????
ЗаполнитьЗначенияСвойств(<<?>>Товар.Добавить(), Выборка); (Проверка: Сервер)
1
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.06.2015, 11:56 13
Цитата Сообщение от Dethmontt Посмотреть сообщение
Вообще бред какой-то......
эт'точно. Невозможно ответить сразу по нескольким косякам, типа "ФСЁ не так".
ravinka, разберитесь со всеми реквизитами и объектами: что где находится прежде всего.
1
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
08.06.2015, 14:51  [ТС] 14
Цитата Сообщение от duk337 Посмотреть сообщение
эт'точно. Невозможно ответить сразу по нескольким косякам, типа "ФСЁ не так".
ravinka, разберитесь со всеми реквизитами и объектами: что где находится прежде всего.
а можно литературку какую нть или чутьпомощи я вообще нооооооооовичок

Добавлено через 3 минуты
вообще не понимаю
1C
1
2
3
4
5
6
ТоварнаяНакладнаяНакладная.Товар,
    |   ТоварнаяНакладнаяНакладная.МассаБрутто,
    |   ТоварнаяНакладнаяНакладная.МассаНетто,
    |   ТоварнаяНакладнаяНакладная.Ссылка
    |ИЗ
    |   Документ.ТоварнаяНакладная.Накладная КАК ТоварнаяНакладнаяНакладная
этим я выбираю тч товар и реквизиты массаа и ссылка из товарнойнакладной правильно?
1C
1
2
|ГДЕ
    |   ТоварнаяНакладнаяНакладная.Ссылка = &Ссылка";
зачем это нужно чтобы в последствии получить доступ к ссылочным объектам?

почему тогда не устанавливается параметр
1C
1
Запрос.УстановитьПараметр("Ссылка", Ссылка);
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.06.2015, 20:39 15
Это условие: фильтр на указанный документ через ссылку на него.
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
08.06.2015, 22:32  [ТС] 16
1C
1
Объект.СсылкаДокументТоварнаяНакладная
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
08.06.2015, 22:49 17
Цитата Сообщение от ravinka Посмотреть сообщение
Объект.СсылкаДокументТоварнаяНакладная
пальцем в небо тыкать надо так:
1C
1
ОбъектИзМоейКонфигурации.СсылкаДокументТоварнаяНакладнаяИзПодсистемыЗапасыНаСкладе.
Три дублирующиеся темы - раз.
Якобы нежелание думать и смотреть в синтакс помощник - два.
Это, однако, троллинг.
Я бы объединил все три Ваши темы в одну песню. Будет хоть повеселее.
Цитата Сообщение от ravinka Посмотреть сообщение
а можно литературку какую нть или чутьпомощи я вообще нооооооооовичок
Вы раздел этот смотрели так же, как синтакс-помощник
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
08.06.2015, 22:59  [ТС] 18
Цитата Сообщение от duk337 Посмотреть сообщение
Вы раздел этот смотрели так же, как синтакс-помощник
цитирую:ДокументСсылка.<Имя документа> (DocumentRef.<Имя документа>)
1C
1
ДокументСсылка.ТоварнаяНакладная;
или
1C
1
ДокументТабличнаяЧасть.ТоварнаяНакладная.Накладная
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
09.06.2015, 10:15 19
В разделе даже есть отдельная тема про литературу.
Далее.
Надо смотреть методы тч. Осознать, где док.приёмник, где док.источник. Какие реквы у них в тч.
Вы же тыкаете пальцем в небо, хотя осознаёте, что ВАШИ объекты и их структура для нас тайна.
Если с запросом не выходит - делайте просто циклом по тч источника. Прочухайте, где объект, а где ссылка.

Не по теме:

Вообще этот троллинг слегка запарил.

0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
09.06.2015, 21:42  [ТС] 20
Цитата Сообщение от duk337 Посмотреть сообщение
В разделе даже есть отдельная тема про литературу.
Далее.
Надо смотреть методы тч. Осознать, где док.приёмник, где док.источник. Какие реквы у них в тч.
Вы же тыкаете пальцем в небо, хотя осознаёте, что ВАШИ объекты и их структура для нас тайна.
Если с запросом не выходит - делайте просто циклом по тч источника. Прочухайте, где объект, а где ссылка.
я много читал и закипел уже помоги...чуть что не правильно?
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
&НаСервере
Процедура ЗаполнитьТД(Масса)
Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ
                  | ТоварнаяНакладнаяНакладная.МассаБрутто КАК МассаБрутто,
                  | ТоварнаяНакладнаяНакладная.МассаНетто КАК МассаНетто,
                  | ТоварнаяНакладнаяНакладная.Товар.Наименование
                  |ИЗ
                  | Документ.ТоварнаяНакладная.Накладная КАК ТоварнаяНакладнаяНакладная"; 
                  
                РезультатЗапроса = Запрос.Выполнить();
                Масса = РезультатЗапроса.Выгрузить();
    Запрос2 = Новый Запрос;
    Запрос2.Текст ="ВЫБРАТЬ
                   |    НакладнаяНаОтпускТовар.Наименование.Наименование КАК Наименование,
                   |    НакладнаяНаОтпускТовар.МассаБрутто,
                   |    НакладнаяНаОтпускТовар.МассаНетто
                   |ИЗ
                   |    Документ.НакладнаяНаОтпуск.Товар КАК НакладнаяНаОтпускТовар";
                  РезультатЗапроса = Запрос2.Выполнить();
 
                   
            Для Каждого Товар Из Масса Цикл
            //  НоваяСтрока = Товар.Добавить();
            //  НоваяСтрока.МассаБрутто = ТабЗнач.МассаБрутто;
            //  НоваяСтрока.МассаНетто = ТабЗнач.МассаНетто;
            ЗаполнитьЗначенияСвойств(Товар, Масса);
            КонецЦикла;
 
КонецПроцедуры
 
    
    
&НаКлиенте
Процедура ТоварНаименованиеПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Товар.ТекущиеДанные;
    СтрокаТабличнойЧасти.Цена=РаботаСоСправочниками.РозничнаяЦена
    (Объект.Дата,СтрокаТабличнойЧасти.Наименование);
    
    ЗаполнитьТД(СтрокаТабличнойЧасти.МассаБрутто);
        
    СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество
*СтрокаТабличнойЧасти.Цена;    
КонецПроцедуры
0
09.06.2015, 21:42
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
09.06.2015, 21:42

Заполнение табличной части одного документа из табличной части другого документа
Здравсвуйте. 1С 8.2. Есть документ Приход и документ Расход. Оба документа...

Заполнение табличной части документа из запроса
Здравствуйте! Просмотрела много подобных тем, но все равно не получается...

Заполнение реквизита документа программно из результата запроса к регистру накопления
Здравствуйте. Делаю конфигурацию в 1С 8.3.Есть Документ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru