Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
start_kmv
3 / 3 / 3
Регистрация: 27.04.2014
Сообщений: 220
1

Запрос ничего не выводит

08.06.2015, 18:52. Просмотров 824. Ответов 5
Метки нет (Все метки)

доброго дня. с помощью консоли запросов пытаюсь из следующего кода:
1C
1
2
3
4
5
6
7
8
9
10
11
ВЫБРАТЬ
    ПаспортныеДанныеФизЛиц.ДокументВид КАК Поле1,
    ПаспортныеДанныеФизЛиц.ДокументСерия КАК Поле2,
    ПаспортныеДанныеФизЛиц.ДокументНомер КАК Поле3,
    ПаспортныеДанныеФизЛиц.ДокументДатаВыдачи КАК Поле4,
    ПаспортныеДанныеФизЛиц.ДокументКемВыдан КАК Поле5,
    ПаспортныеДанныеФизЛиц.ДокументКодПодразделения КАК Поле6
ИЗ
    РегистрСведений.ПаспортныеДанныеФизЛиц КАК ПаспортныеДанныеФизЛиц
ГДЕ
    ПаспортныеДанныеФизЛиц.ФизЛицо.Ссылка = &Контрагент
вытащить паспортные данные физ.лица. но ничего не выходит. подскажите, где ошибка?
0
Лучшие ответы (1)
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
08.06.2015, 18:52
Ответы с готовыми решениями:

Почему запрос ничего не выводит?
Мне нужно сравнить сколько товара, по которому есть скидки, продано в период...

Запрос об остатках номенклатуры на конкретном складе не возвращает ничего
В общем, есть РегистрНакопления ОстаткиНоменклатуры по которому проводятся...

Запрос выводит некорректный результат
Есть запрос "ВЫБРАТЬ |" + ?(неСворачиватьПоСериям,...

Запрос, который выводит список 5 покупателей, которые купили товар на наибольшую сумму денег
Добрый вечер! Помогите, пожалуйста! Нужно написать запрос, который выводит...

Запрос к win32_printjob ничего не выводит
доброго времени суток времени суток , прошу помощи для решения следующей...

5
Tklwegsd
Эксперт 1С
712 / 518 / 176
Регистрация: 24.07.2013
Сообщений: 1,834
08.06.2015, 19:42 2
По указанному в параметре &Контрагент физлицу нет данных, либо некорректное значение самого параметра.
0
start_kmv
3 / 3 / 3
Регистрация: 27.04.2014
Сообщений: 220
09.06.2015, 11:31  [ТС] 3
Tklwegsd, спасибо за ответ. да, действительно, не &Контрагент, а &ФизЛицо, поскольку в регистре сведений ПаспортныеДанныеФизЛиц ФизЛицо ссылается на справочник ФизическиеЛица и КонтактныеЛица.
но, это половина задачи: сейчас код исправил на:
1C
1
2
3
4
5
6
7
8
9
10
11
ВЫБРАТЬ
    ПаспортныеДанныеФизЛиц.ДокументВид КАК Поле1,
    ПаспортныеДанныеФизЛиц.ДокументСерия КАК Поле2,
    ПаспортныеДанныеФизЛиц.ДокументНомер КАК Поле3,
    ПаспортныеДанныеФизЛиц.ДокументДатаВыдачи КАК Поле4,
    ПаспортныеДанныеФизЛиц.ДокументКемВыдан КАК Поле5,
    ПаспортныеДанныеФизЛиц.ДокументКодПодразделения КАК Поле6
ИЗ
    РегистрСведений.ПаспортныеДанныеФизЛиц КАК ПаспортныеДанныеФизЛиц
ГДЕ
    ПаспортныеДанныеФизЛиц.ФизЛицо.Ссылка = &[B][U]ФизЛицо[/U][/B]
сейчас почему то вычисляемые значения паспортные данные Родственник вычисляется без проблем, а нужные значения (Залогодатель и Контрагент) не вычисляются, в отладчике смотрю:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
Функция ПаспортныеДанныеРодственник(Родственник)
    //паспортные данные физического лица
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ПаспортныеДанныеФизЛиц.ДокументВид КАК Поле1,
    |   ПаспортныеДанныеФизЛиц.ДокументСерия КАК Поле2,
    |   ПаспортныеДанныеФизЛиц.ДокументНомер КАК Поле3,
    |   ПаспортныеДанныеФизЛиц.ДокументДатаВыдачи КАК Поле4,
    |   ПаспортныеДанныеФизЛиц.ДокументКемВыдан КАК Поле5,
    |   ПаспортныеДанныеФизЛиц.ДокументКодПодразделения КАК Поле6
    |ИЗ
    |   РегистрСведений.ПаспортныеДанныеФизЛиц КАК ПаспортныеДанныеФизЛиц
    |ГДЕ
    |   ПаспортныеДанныеФизЛиц.ФизЛицо.Ссылка = &ФизЛицо";  
    
    Запрос.УстановитьПараметр("ФизЛицо", Родственник);//СсылкаНаОбъект.Родственник.мфоФизЛицо);
    
    СтрокаПаспортныеДанные =  Запрос.Выполнить().Выгрузить();
    Если СтрокаПаспортныеДанные.Количество() > 0 Тогда                
        Паспорт = ""+СтрокаПаспортныеДанные[0].Поле1 + ", серия "+СтрокаПаспортныеДанные[0].Поле2+ ", № "+СтрокаПаспортныеДанные[0].Поле3 + ", выдан "+Формат(СтрокаПаспортныеДанные[0].Поле4,"ДЛФ=Д") + "г. "+СтрокаПаспортныеДанные[0].Поле5 + " код подразделения " + СтрокаПаспортныеДанные[0].Поле6 ; 
    Иначе             
        Паспорт = "";
    КонецЕсли;
    Возврат Паспорт
 
КонецФункции
перескакивает сразу на
1C
1
2
3
Иначе             
        Паспорт = "";
    КонецЕсли;
хотя, что Контрагента, что Родственника, что Залогодателя вычисляю одинаково
0
Вложения
Тип файла: zip ВнешнийМодульПечати.zip (200.1 Кб, 0 просмотров)
SHIFT_969
Злой самаритянин
177 / 178 / 93
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
09.06.2015, 11:48 4
А точно по этому родственнику есть записи? Условие не проходит, потому что запрос ничего не выбирает. Возможно, если регистр периодический, необходимо указать период в запросе...
0
Tklwegsd
Эксперт 1С
712 / 518 / 176
Регистрация: 24.07.2013
Сообщений: 1,834
09.06.2015, 11:55 5
Лучший ответ Сообщение было отмечено start_kmv как решение

Решение

По указанному в параметре &Физлицо значению нет данных, либо некорректное значение самого параметра.
0
start_kmv
3 / 3 / 3
Регистрация: 27.04.2014
Сообщений: 220
10.06.2015, 11:33  [ТС] 6
Tklwegsd, спасибо огромное, разобрался. действительно, типы были разные. я брал данные из Контрагента, а нужно было из ФизЛица.
0
10.06.2015, 11:33
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.06.2015, 11:33

на веб странице ничего не отображает просто белый квадрат вместо аплета, без ошибок просто ничего не выводит
Всем привет ! ! ! :drink: Создаю applet с jfreechart: import...

Запускает, но не выводит ничего
Привет, я прохожу уроки по Java остановилась на исключениях, все делала как в...

Программа не выводит ничего
Собственно начал изучать NASM но у меня не выводится в этой программе ничего ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru