Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
1

Заполнение документа из тч справочника, заполнение при изменении()

11.06.2015, 15:05. Просмотров 848. Ответов 12
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
&НаСервере
Процедура ПолучитьПродукты(Выборка)
    Выборка=Справочники.Блюда.Выбрать();
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = Объект.Список.Добавить();
        НоваяСтрока.Наименование = Выборка.Наименование;
        НоваяСтрока.Норма_кг = Выборка.Норма_кг;
    КонецЦикла;
КонецПроцедуры
 
 
&НаКлиенте
Процедура НаименованиеБлюдаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Список.ТекущиеДанные;
    ПолучитьПродукты(Элементы.Список.текущиеДанные);
 
КонецПроцедуры
Такая ситуация есть справочник Блюда с тчСписок в ней Продукт и Норма_кг
есть докКалькуляционнаяКарточка с тчСписок в ней Наименование, Норма_кг, Цена, Сумма и реквизит НаимБлюда
писал читал ничего не получается подскажите в чем ошибка?
0
Миниатюры
Заполнение документа из тч справочника, заполнение при изменении()   Заполнение документа из тч справочника, заполнение при изменении()  
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
11.06.2015, 15:05
Ответы с готовыми решениями:

Автоматическое заполнение табличной части документа при изменении реквизита этого документа
Здравствуйте. Делаю свою конфу на 1с 8.3.5. Добавил справочник "Сотрудники" и...

Заполнение данных справочника при проведении документа.
Здравствуйте. Кто может подсказать, как сделать так, чтобы при проведении...

Заполнение реквизита тч документа из справочника
Всем доброго времени суток. Прошу помощи Часто создаваемая тема, но все же....

Заполнение документа данными из справочника
Здравствуйте! Столкнулась с проблемой. Есть Справочник...

Заполнение таблицы документа данными справочника автоматически
Здравствуйте. Делаю простую программу на 1С и столкнулся с проблемой. У меня...

12
duk337
2950 / 1762 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
11.06.2015, 15:48 2
1.Чем карточка отличается от ТЧ Блюда?
2.Вы пытаетесь заполнить таблицу ингредиентов элементами всего справочника Блюда

Поля "Наименование", "Продукт" - какие типы? Почему разные имена? Сделайте одинаковые и
1C
1
Карточка.ТЧ.Загрузить(Блюдо.ТЧ.Выгрузить());
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
11.06.2015, 16:03  [ТС] 3
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
&НаСервере 
Процедура ЗаполнитьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    БлюдаСписок.Продукт КАК Наименование,
    |    БлюдаСписок.Норма_кг КАК Норма_кг
    |ИЗ
    |    Справочник.Блюда.Список КАК БлюдаСписок";
    Результат = Запрос.Выполнить();
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = Объект.Список.Добавить();
        НоваяСтрока.Наименование = Выборка.Наименование;
    КонецЦикла;
    
КонецПроцедуры
 
 
&НаКлиенте
Процедура НаименованиеБлюдаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Список.ТекущиеДанные;
    ЗаполнитьНаСервере();
 
КонецПроцедуры
сделал запросом только все выводит
те все продукты вообще)))
как отбор поставить подскажите плиз

Добавлено через 4 минуты
Цитата Сообщение от duk337 Посмотреть сообщение
1.Чем карточка отличается от ТЧ Блюда?
Наименование, Норма_кг, Цена, Сумма а в спр Продукт, Норма_кг
0
Dethmontt
Модератор
Эксперт 1С
2644 / 2436 / 416
Регистрация: 10.03.2011
Сообщений: 8,701
Записей в блоге: 1
Завершенные тесты: 1
11.06.2015, 16:26 4
1C
1
2
3
|"ГДЕ БлюдаСписок.Ссылка = &МоёЛюбимоеБлюдо";
 
...тьПараметр("МоёЛюбимоеБлюдо", МоеБлюдо);
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
11.06.2015, 16:51  [ТС] 5
Цитата Сообщение от Dethmontt Посмотреть сообщение
|"ГДЕ БлюдаСписок.Ссылка = &МоёЛюбимоеБлюдо";
...тьПараметр("МоёЛюбимоеБлюдо", МоеБлюдо);
а потом если и цикл?

Добавлено через 2 минуты
да и еще вопрос почему всегда у меня ошибка вылетает когда параметр устанавливаю*7
0
Dethmontt
Модератор
Эксперт 1С
2644 / 2436 / 416
Регистрация: 10.03.2011
Сообщений: 8,701
Записей в блоге: 1
Завершенные тесты: 1
11.06.2015, 16:58 6
Цитата Сообщение от ravinka Посмотреть сообщение
а потом если и цикл?
А потом све что у тебя после запроса написано

Добавлено через 30 секунд
Цитата Сообщение от ravinka Посмотреть сообщение
да и еще вопрос почему всегда у меня ошибка вылетает когда параметр устанавливаю
ээээээ.... Хз
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
11.06.2015, 16:59  [ТС] 7
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
&НаСервере
Процедура ЗаполнитьНаСервере()
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |   БлюдаСписок.Продукт КАК Наименование,
    |   БлюдаСписок.Норма_кг КАК Норма_кг
    |ИЗ
    |   Справочник.Блюда.Список КАК БлюдаСписок
    |ГДЕ
    |   БлюдаСписок.Ссылка = &МоеБлюдо";    
        Запрос.УстановитьПараметр("МоеБлюдо", МоеБлюдо);
        Результат = Запрос.Выполнить();         
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = Объект.Список.Добавить();
        НоваяСтрока.Наименование = Выборка.Наименование;
        НоваяСтрока.Норма_кг = Выборка.Норма_кг;
    КонецЦикла;
    
КонецПроцедуры
 
 
&НаКлиенте
Процедура НаименованиеБлюдаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Список.ТекущиеДанные;
    ЗаполнитьНаСервере();
 
КонецПроцедуры
{Документ.КалькуляционнаяКарточка.Форма.ФормаДокумента.Форма(40,45)}: Переменная не определена (МоеБлюдо)
Запрос.УстановитьПараметр("МоеБлюдо", ,<<?>>МоеБлюдо); (Проверка: Сервер)
0
Dethmontt
Модератор
Эксперт 1С
2644 / 2436 / 416
Регистрация: 10.03.2011
Сообщений: 8,701
Записей в блоге: 1
Завершенные тесты: 1
11.06.2015, 17:06 8
Цитата Сообщение от ravinka Посмотреть сообщение
Переменная не определена (МоеБлюдо)
И что же тут непонятного?
Получи блюдо (ссылку на блюдо) для отбора и положи в переменную МоеБлюдо

Добавлено через 12 секунд
и ошибки не будет

Добавлено через 1 минуту
1C
1
2
3
4
5
6
7
8
&НаКлиенте
Процедура НаименованиеБлюдаПриИзменении(Элемент)
    СтрокаТабличнойЧасти=Элементы.Список.ТекущиеДанные;
    ЗаполнитьНаСервере(СтрокаТабличнойЧасти.Наименование); //Получение ссылки на блюдо (наименование)
 
&НаСервере
Процедура ЗаполнитьНаСервере(МоеБлюдо)
//...........
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
11.06.2015, 17:18  [ТС] 9
что за ерунда то
{Документ.КалькуляционнаяКарточка.Форма.ФормаДокумента.Форма(56)}: Значение не является значением объектного типа (Наименование)
ЗаполнитьНаСервере(СтрокаТабличнойЧасти.Наименование);
0
Dethmontt
Модератор
Эксперт 1С
2644 / 2436 / 416
Регистрация: 10.03.2011
Сообщений: 8,701
Записей в блоге: 1
Завершенные тесты: 1
12.06.2015, 01:00 10
Ты издеваешься что ли? Троль?

Сколько можно тебе подсказывать (писать за тебя, выяснять структуру твоей программы...) ???

Цитата Сообщение от ravinka Посмотреть сообщение
что за ерунда то
Цитата Сообщение от ravinka Посмотреть сообщение
Значение не является значением объектного типа (Наименование)
Ты не знаешь как у тебя колонки в табличной части называются?
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
12.06.2015, 09:28  [ТС] 11
Dethmontt,
да знаю а толку то как не указывай все равно ошибка
Объект.Список.Наименование
СтрокаТабличнойЧасти.Наименование
СтрокаТабличнойЧасти.Список.Наименование
СтрокаТабличнойЧасти.ОбъектСписок.Наименование
бестолку
0
ravinka
0 / 0 / 0
Регистрация: 24.03.2015
Сообщений: 70
12.06.2015, 22:02  [ТС] 12
ну плиз помогите
0
Tklwegsd
Эксперт 1С
747 / 545 / 185
Регистрация: 24.07.2013
Сообщений: 1,899
12.06.2015, 22:15 13
ravinka, Зачем тебе все это надо?
0
12.06.2015, 22:15
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
12.06.2015, 22:15

Заполнение табличной части документа данными из справочника
Добрый день! Очень нужна ваша помощь ! Есть справочник Должности (на каждую...

При изменении реквизита Группа ТЧ документа заполнить из ТЧ Справочника
Здравствуйте... Никак не могу разобраться с запросами 1С. У меня имеется...

Заполнение ТЧ одного документа ТЧ другого, заполнение тч из запроса
&amp;НаСервере Процедура ЗаполнитьНаСервере() Запрос = Новый Запрос; ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
13
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru