Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
komzakowa
0 / 0 / 0
Регистрация: 17.06.2015
Сообщений: 16
1

Объясните логику работы модуля

17.06.2015, 13:55. Просмотров 437. Ответов 3
Метки нет (Все метки)

Есть вот такой модуль формы. Не понимаю почему, при изменении поля Дисциплина вызывается функция ПолучитьСтудентов()
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
&НаСервере
Функция ПолучитьСтудентов()
    Если Не ЗначениеЗаполнено(Объект.Группа) Тогда
        Сообщить( "Поле Группа не заполнено") 
            Иначе
                Группа = Объект.Группа;
                Запрос = Новый Запрос;
                Запрос.Текст =
                        "ВЫБРАТЬ
                        |   Студент1СрезПоследних.Студент.Наименование,
                        |   Студент1СрезПоследних.Студент.НомерЗачетки
                        |ИЗ
                        |   РегистрСведений.Студент1.СрезПоследних КАК Студент1СрезПоследних
                        |ГДЕ
                        |   Студент1СрезПоследних.Группа = &Группа";                     
                    Запрос.УстановитьПараметр("Группа", Группа);
                    Результат = Запрос.Выполнить().Выгрузить();
                    Объект.Студенты.Загрузить(Результат);
                    //Объект.Студенты.Загрузить(объект.РегистрСведений.Студент1.СрезПоследних(,Новый Структура("Группа", Группа),"Фамилия","НомерЗачетки"));
    КонецЕсли;
КонецФункции
   
 
&НаКлиенте
Процедура Заполнить(Команда)    
    ЭтаФорма.Записать();
        ПолучитьСтудентов(); 
    // Вставить содержимое обработчика.
КонецПроцедуры
 
&НаСервере
 
Процедура ЗапонитьЧасы()
ОТборПоСпециальности = Объект.Специальность;
ОтборПоСеместру = Объект.Семестр;
ОтборПоДисциплине = объект.Дисциплина;
Запрос = Новый Запрос;
                Запрос.Текст =
 
        "ВЫБРАТЬ
        |   СУММА(УчебныйПлан.Лекции) КАК Лекции,
        |   СУММА(УчебныйПлан.Практики) КАК Практики,
        |   СУММА(УчебныйПлан.Лабораторные) КАК Лабораторные,
        |   СУММА(УчебныйПлан.СРС) КАК СРС
        |ИЗ
        |   РегистрСведений.УчебныйПлан КАК УчебныйПлан
        |ГДЕ
        |   УчебныйПлан.Семестр = &Семестр
        |   И УчебныйПлан.Дисциплина = &Дисциплина
        |   И УчебныйПлан.Специальность = &Специальность"  ;
        запрос.УстановитьПараметр ("Семестр", ОтборПоСеместру); 
        запрос.УстановитьПараметр ("Специальность", ОТборПоСпециальности);  
        запрос.УстановитьПараметр ("Дисциплина", ОтборПоДисциплине);
        Результат = Запрос.Выполнить().Выгрузить();
        объект.ЧасовВсего.загрузить(Результат);
    
    КонецПроцедуры
    
    
&НаКлиенте
Процедура ДисциплинаПриИзменении ()
    
ЭтаФорма.Записать();
ЗапонитьЧасы();
    
    
КонецПроцедуры;
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
17.06.2015, 13:55
Ответы с готовыми решениями:

Объясните логику работы программы
public static boolean getAnswer ( int array){ if (array.length < 2)...

Объясните логику работы скриптовых button
Есть у меня программа WinCc Siemens У меня есть кнопка, в event на mouse...

Объясните, пожалуйста, логику работы кода
Пожалуйста, объясните логику этого примера, не могу совсем разобраться....

Объясните, пожалуйста, в каком порядке Java-машина читает код и логику работы
Объясните, пожалуйста, в каком порядке Java-машина читает код и логику работы....

Объясните логику
Задание следующее "вывести все числа от а до в которые делятся на 3, a=3, b =10...

3
Volexovich
198 / 174 / 29
Регистрация: 24.10.2011
Сообщений: 683
17.06.2015, 14:10 2
Потому что у поля Дисциплина стоит обработчик события ПриИзменении, который вызывает функцию ПолучитьСтудентов().
0
Phil
Эксперт 1С
247 / 248 / 75
Регистрация: 28.05.2014
Сообщений: 946
17.06.2015, 14:10 3
komzakowa, при ДисциплинаПриИзменении вызывается
1C
1
2
ЭтаФорма.Записать();
ЗапонитьЧасы();
вот там и искать, возможно ЗапонитьЧасы() лезет в ПолучитьСтудентов, отладкой пройдись
0
duk337
2948 / 1760 / 82
Регистрация: 03.11.2011
Сообщений: 8,280
17.06.2015, 22:16 4
ПриЗаписи() или ПередЗаписью и в форме, и в объекте что написано? И в менеджере на всякий.

Добавлено через 2 минуты

Не по теме:

Цитата Сообщение от komzakowa Посмотреть сообщение
ЗапонитьЧасы
... ЗаишачитьМинуты() и УбаранитьСекунды() - не хватает, наверное

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.06.2015, 22:16

Объясните логику кода
Здравствуйте! Прошу помощи у вас - объясните, пожалуйста, логику небольшого...

Объясните логику выполнения выражения
var a=2 alert(--a * ++a) // выводит 2НО var a=2 alert(a++ + --a * ++a) ...

Инкремент и оператор if (объясните логику программы)
Почему выдаёт (1) при выполнении нижеследующей программы? #include<iostream>...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru