Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/4: Рейтинг темы: голосов - 4, средняя оценка - 4.50
start_kmv
3 / 3 / 3
Регистрация: 27.04.2014
Сообщений: 220
1

Выборка контактной информации из запроса

19.06.2015, 18:41. Просмотров 782. Ответов 2
Метки нет (Все метки)

Доброго времени суток. в УТ 10.3 написал следующие строки выборки контактной информации из запроса:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ДатаСреза",          Документ.Дата);
    Запрос.УстановитьПараметр("СтруктурнаяЕдиница", Документ.Склад);
    Запрос.УстановитьПараметр("ТекущийДокумент",  Документ);
    Запрос.УстановитьПараметр("ПустойКонтрагент", Справочники.Контрагенты.ПустаяСсылка());
    
    Запрос.Текст =
    "ВЫБРАТЬ
    |   РеализацияТоваровУслуг.Номер,
    |   РеализацияТоваровУслуг.Дата КАК ДатаДокумента,
    |   РеализацияТоваровУслуг.Организация,
    |   РеализацияТоваровУслуг.Организация КАК ЮрФизЛицо,
    |   РеализацияТоваровУслуг.Организация КАК Поставщик,
    |   РеализацияТоваровУслуг.Организация КАК Контрагент,
    |   РеализацияТоваровУслуг.Организация КАК Руководители,
    |   ВЫБОР
    |       КОГДА РеализацияТоваровУслуг.Грузополучатель = &ПустойКонтрагент
    |           ТОГДА РеализацияТоваровУслуг.Контрагент
    |       ИНАЧЕ РеализацияТоваровУслуг.Грузополучатель
    |   КОНЕЦ КАК Грузополучатель,
    |   ВЫБОР
    |       КОГДА РеализацияТоваровУслуг.Грузоотправитель = &ПустойКонтрагент
    |           ТОГДА РеализацияТоваровУслуг.Организация
    |       ИНАЧЕ РеализацияТоваровУслуг.Грузоотправитель
    |   КОНЕЦ КАК Грузоотправитель,
    |   РеализацияТоваровУслуг.БанковскийСчетОрганизации КАК БанковскийСчет,
    |   РеализацияТоваровУслуг.Контрагент КАК Покупатель,
    |   РеализацияТоваровУслуг.Контрагент КАК Плательщик,
    |   ОтветственныеЛица.ФизическоеЛицо КАК ОтветственноеЛицо,
    |   РеализацияТоваровУслуг.Подразделение,
    |   РеализацияТоваровУслуг.ВалютаДокумента,
    |   РеализацияТоваровУслуг.КурсВзаиморасчетов КАК Курс,
    |   РеализацияТоваровУслуг.КратностьВзаиморасчетов КАК Кратность,
    |   РеализацияТоваровУслуг.УчитыватьНДС,
    |   РеализацияТоваровУслуг.СуммаВключаетНДС,
    |   РеализацияТоваровУслуг.ОтпускРазрешил,
    |   РеализацияТоваровУслуг.ОтпускПроизвел,
    |   РеализацияТоваровУслуг.ДоверенностьНомер,
    |   РеализацияТоваровУслуг.ДоверенностьДата,
    |   РеализацияТоваровУслуг.ДоверенностьВыдана,
    |   КонтактнаяИнформация.Вид.Ссылка КАК ВидКИ,
    |   КонтактнаяИнформация.Представление КАК ПредставлениеКИ
    |ИЗ
    |   Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |       ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница = &СтруктурнаяЕдиница) КАК ОтветственныеЛица
    |       ПО (ОтветственныеЛица.СтруктурнаяЕдиница = РеализацияТоваровУслуг.Склад),
    |   РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
    |ГДЕ
    |   РеализацияТоваровУслуг.Ссылка = &ТекущийДокумент";
 
    Шапка = Запрос.Выполнить().Выбрать();
    
    
    Для Каждого ВыборкаСтрок из Шапка Цикл
        Если Шапка.ВидКИ.Наименование = "Водит.удостоверение" Тогда
            ВодитУдост = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "Гос.номер автомобиля" Тогда
            ГосНомерАМ = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "ФИО водителя" Тогда
            ФИОВод = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "Марка автомобиля" Тогда
            МаркаАМ = Шапка.ПредставлениеКИ;
        КонецЕсли;
    КонецЦикла;
    
    
    Шапка.Следующий();
добавил в контактную информацию контрагента 4 вида новой контактной информации с типов Другое: Водит.удостоверение, Гос.номер автомобиля, ФИО водителя, Марка автомобиля.
теперь хочу эти данные вытащить в макет.

при отладке ругается на то, что Итератор для значения не определен:
{Форма.Форма.Форма(63)}: Итератор для значения не определен
Для Каждого ВыборкаСтрок из Шапка Цикл

скажите, что делаю не так? и как правильно получить контактную информацию из контрагента?
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
19.06.2015, 18:41
Ответы с готовыми решениями:

Добавление Окна Ввода Контактной Информации В Документ.
Здравствуйте, имеется Управление торговлей, редакция 11.0 (11.0.8.11) . Скажите...

Выборка из запроса
Доброго вечера! Столкнулся с достаточно сложной для меня, как начинающего,...

выборка из запроса
нужно по выборке создать документ ПНК для каждого поставщика для этого мы...

Выборка нужной информации из разных справочников
Добрый день господа. С 1С работаю недавно, по этому возможно для большинства...

Виды контактной информации непонятные элементы
Добрый день всем. Ситуация такова. Пришел обновлять типовую конфу БП 2.0, бух...

2
Tklwegsd
Эксперт 1С
710 / 516 / 176
Регистрация: 24.07.2013
Сообщений: 1,831
19.06.2015, 18:54 2
1C
1
2
3
4
5
6
7
8
9
10
11
Пока Шапка.Следующий() Цикл
        Если Шапка.ВидКИ.Наименование = "Водит.удостоверение" Тогда
            ВодитУдост = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "Гос.номер автомобиля" Тогда
            ГосНомерАМ = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "ФИО водителя" Тогда
            ФИОВод = Шапка.ПредставлениеКИ;
        ИначеЕсли Шапка.ВидКИ.Наименование = "Марка автомобиля" Тогда
            МаркаАМ = Шапка.ПредставлениеКИ;
        КонецЕсли;
    КонецЦикла;
0
start_kmv
3 / 3 / 3
Регистрация: 27.04.2014
Сообщений: 220
20.06.2015, 00:07  [ТС] 3
Tklwegsd, спасибо за ответ. все получилось.
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
20.06.2015, 00:07

Порядок типов контактной информации в карточке контрагента
Всем доброго времени суток. В 1С 8.2, УТ10.3, в карточке контрагента есть...

Выбрать и адрес, и телефон, и ящик из контактной информации
Привет. У меня тут снова вопрос родился. Мне надо получить контактную...

Построить описание класса, содержащего информацию о контактной информации организации
Построить описание класса, содержащего информацию о контактной информации...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru