Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.60/5: Рейтинг темы: голосов - 5, средняя оценка - 4.60
Briolin
58 / 63 / 11
Регистрация: 13.11.2014
Сообщений: 900
1

Сохранение отчета из 1С 8.2 в docx

16.08.2015, 21:02. Просмотров 925. Ответов 3
Метки нет (Все метки)

Здарова. В общем суть-написал конфу с нуля. Есть отчет, результат которого нужно сохранить в ворд. Сам вордовский файл я создал, в нём таблицу и шапку. Сам отчет построен с помощью СКД, вручную ничего не писал, всё работает как надо. Вопрос-как результат отчета сохранить в вордовский файл, и не просто сохранить, а именно в те таблицы которые "помеченны" в самом вордовском файле. Приходит на ум, что нужно в файле ворд написать типа "{переменная}" и в неё будет записывать значение из отчета. Но как это осуществить? С подобной задачей столкнулся впервые
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.08.2015, 21:02
Ответы с готовыми решениями:

Сохранение отформатированных печатных форм в .xlsx или .docx
Добрый день. Конфигурация ЗУП 2.5. Как можно передать параметры форматирования (отображения) в...

Создание отчета .doc / .docx на основе шаблона
Есть шаблон .dot / .dotx, в нем поля с именами. Необходимо из C# создавать файл на основе шаблона,...

Сохранение отчета
из базы выгружаются доки в ексель Скажи как сделать что бы в новый ексель сохраняла неашу таблицу...

Сохранение отчета в файл
Привет всем! Подскажите как сохранить результат отчета в файл Excel или Word, где имя файла будет...

Сохранение отчета в Word
Приветствую. Очень нужна помощь. Имеется: Несколько полей TEdit, один TMemo и один TChart....

3
1c-k
339 / 315 / 42
Регистрация: 20.08.2014
Сообщений: 1,238
Записей в блоге: 1
16.08.2015, 22:23 2
Briolin, в документообороте есть некоторые реквизиты, которые прописываются специальным образом как их заполнить. Далее берется шаблон и заполняется по этим раннее настроенным реквизитам.
Просто так в Word без описания шаблона ничего не поместить. Т.е. надо писать подсистему, которая будет хватать нужные данные и распихивать в нужные места в документе Word.
0
RitterBruder
1 / 1 / 0
Регистрация: 22.04.2012
Сообщений: 41
16.08.2015, 22:58 3
Да, код справедлив и для 1С http://delphiworld.narod.ru/base/create_word_doc.html
0
SHIFT_969
Злой самаритянин
178 / 179 / 94
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
17.08.2015, 12:39 4
нужно в файле ворд написать типа "{переменная}" и в неё будет записывать значение из отчета
Да, типа того (у меня только в опен офисе, поищи под ворд):
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Функция Печать() Экспорт
    
            Макет = ПолучитьМакет("Макет");
            ИмяВременногоФайла = ПолучитьИмяВременногоФайла("ODT");
            Макет.Записать(ИмяВременногоФайла);
            
            ПФ_oDoc = ОткрытьOpenOffice(ИмяВременногоФайла);
            ПФ_ReplaceDescriptor = ПФ_oDoc.createReplaceDescriptor();
            
            ПФ_ReplaceDescriptor.SearchString = "<Дата>";
            ПФ_ReplaceDescriptor.ReplaceString = Строка(Формат(ЗаданиеОбъект.Дата,"ДЛФ=Д"));
            ПФ_oDoc.replaceAll(ПФ_ReplaceDescriptor);
    
КонецФункции
    
Функция ОткрытьOpenOffice(пИмяФайла)
    //Если мDocument = Неопределено Тогда
        Попытка
            // создадим COM объект менеджер интерфейса OpenOffice.org
            мService = Новый  COMObject("com.sun.star.ServiceManager");
            мDesktop = мService.CreateInstance("com.sun.star.frame.Desktop");
        Исключение
            ОбщегоНазначения.ВывестиПредупреждение("Ошибка инициализации интерфейса OpenOffice.org OLE Automation object!",,"Ошибка!","Объект - Open Office API");   
            Отказ = истина;
            Возврат Неопределено;
        КонецПопытки;
    //КонецЕсли;
    
    лURLФайла = "file:///" + СтрЗаменить(пИмяФайла,"\","/");
    лPropertyValueArray = Новый COMSafeArray("VT_DISPATCH",2);
    
    Попытка
        мDocument = мDesktop.LoadComponentFromURL(лURLФайла, "_blank", 0, лPropertyValueArray);
        Предупреждение("Документ сформирован!", 3);
        Возврат мDocument;
    Исключение
        ОбщегоНазначения.ВывестиПредупреждение("Ошибка при открытии интерфейса OpenOffice.org OLE Automation object!",,"Ошибка!","Файл не открывыется!");   
        Возврат Неопределено;
    КонецПопытки;
КонецФункции
Ну или как-то импортировать XML в ворд, я даже инструкцию нашел...
Кликните здесь для просмотра всего текста
Instructions
Open Word 2007. The default option brings up a blank page. If you’re importing an XML document into an existing Word document, click the “File” tab, click “Open,” click “Browse” and navigate to that Word file. Double-click the file name, which opens the document in a new Word window.

Scroll to the place to add the XML file and press the “Ctrl” and “Enter” keys on the keyboard for a page break to a new page or press just the “Enter” key to move onto a new line.

Click the “Insert” tab at the top of the screen. Click the small “Object” button near the right side of the toolbar at the top of the screen, under the “Text” group. Click the “Object” link in the drop-down menu.

Click the “Create from File” tab, then click the “Browse” button to navigate to the location on your computer with the XML file. Look for the .xml extension.

Click once on the file to highlight it and click the “Insert” button to return to the “Create from File” window. Click “OK” and the XML file is inserted into the Word document.

Click the “File” tab, click “Save As” and save the Word document to your computer, or rename the file and save it as a new version.
0
17.08.2015, 12:39
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.08.2015, 12:39

Сохранение отчета в PDF
Здравствуйте. Подскажите что делать.Есть бд на 2 компах. На них разное разрешение экрана. В отчете...

Сохранение настроек отчета
Необходимо добавить в отчет(нетиповой), созданный с помощью построителя, сохранение набора...

Сохранение отчета в Excel
Добрый день! У меня такой вопрос. Можно ли сохранить отчет выводимый в Access, в Excel в таком же...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
4
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru