Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Trit5
24 / 24 / 2
Регистрация: 11.09.2013
Сообщений: 93
1

Программное изменение пользователя документа

01.10.2015, 11:42. Просмотров 341. Ответов 1
Метки нет (Все метки)

Добрый день!

Подскажите пожалуйста в следующем вопросе.

В Событии ПередЗаписью провожу проверку необходимости замены пользователя.
Если пользователь Админ(Обладает ролью ПолныеПрава), то вместо прямой замены предупреждение-вопрос
Заменить пользователя или нет.

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    
    Если ПроверкаРоли() Тогда       
        Объект.Ответственный = ПолучитьПользователя();
    Иначе
        Если НЕ Объект.Ответственный = ПолучитьПользователя() Тогда
            Оповещение = Новый ОписаниеОповещения("ВопросПользователю",ЭтотОбъект);
            ТекстВопроса = "Ответственный пользователь отличается от текущего, перезаписать?";
            ПоказатьВопрос(Оповещение,ТекстВопроса,РежимДиалогаВопрос.ДаНет);           
        КонецЕсли;
    КонецЕсли; 
    
КонецПроцедуры
 
&НаСервере
Функция ПолучитьПользователя();     
    текПользователь = ПараметрыСеанса.ТекущийПользователь;
    Возврат текПользователь;      
КонецФункции
 
&НаСервере
Функция ПроверкаРоли()
    
    Если НЕ РольДоступна("ПолныеПрава") Тогда       
        Возврат Истина;     
    Иначе
        Возврат Ложь;
    КонецЕсли;  
    
КонецФункции
 
&НаКлиенте
Процедура ВопросПользователю(Результат, ДополнительныеПараметры) Экспорт
    
    Если Результат = КодВозвратаДиалога.Да Тогда
        Объект.Ответственный = ПолучитьПользователя();
    КонецЕсли;
    
КонецПроцедуры
Итого
если в документе нажимаем "Записать", алгоритм работает как надо (Спрашивает и записывает в зависимости от ответа).
если в документе нажимаем "Провести и закрыть", то вопрос всплывает уже на форме списка документов и замена пользователя не происходит.

Вопрос - как реализовать эту схему записи при нажатии на "Провести и закрыть"?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
01.10.2015, 11:42
Ответы с готовыми решениями:

Программное заполнение документа
Необходимо заполнить документ (Выдача_денег_из_кассы) на основе документа...

Программное проведение документа
Привет. Пишу такой код для программного проведения документа(обработку пишу): &НаСервере...

Программное проведение документа из обработки
Всем привет! В обработке создаю документ, но не пойму как его провести. Пробовал вот так, но не...

Программное обращение к проводкам документа 1с 7.7
Подскажите, пожалуйста, как программно обратиться к проводкам документа в 1с 7.7 и возможно ли это?

Программное создание нового документа и заполнение его реквизитов
Здравствуйте. В собственной конфигурации 1с 8.3 сделал обработку, на форму которой выводится список...

1
Phil
Эксперт 1С
251 / 251 / 76
Регистрация: 28.05.2014
Сообщений: 996
01.10.2015, 12:01 2
Trit5, закинуть её в обработку проведения, ну его) алгоритм
0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
01.10.2015, 12:01

Программное создание нового документа и открытие его формы с заполненными реквизитами
Здравствуйте. В собственной конфигурации 1с 8.3 есть справочник...

Программное изменение длины и точности реквизита формы
Добрый день. Конфигурация Зарплата и управление персоналом 3.1.1.74. Платформа 8.3.8.2167. На...

Программное создание документа
Доброго времени суток! Господа, подскажите, как при программном создании документа выставить ему...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
2
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru