Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.75/4: Рейтинг темы: голосов - 4, средняя оценка - 4.75
nasta22
0 / 0 / 0
Регистрация: 09.06.2015
Сообщений: 10
1

Ошибка в процедуре: не считается сумма

10.10.2015, 11:35. Просмотров 671. Ответов 6
Метки нет (Все метки)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
выдает ошибку программы
 
Процедура РассчитатьСумму(СтрокаТабличнойЧасти) Экспорт
    СтрокаТабличнойЧасти.Сумма = СтрокаТабличнойЧасти.Количество * СтрокаТабличнойЧасти.Цена; 
КонецПроцедуры
 
 
 
Процедура ДокументСписокКоличествоПриИзменении(Элемент)
     СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
 
Процедура ДокументСписокЦенаПриИзменении(Элемент)
       СтрокаТабличнойЧасти = <?>Элементы.Документ.ТекущиеДанные;
    РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
КонецПроцедуры
Добавлено через 6 минут
{Документ.Прибыль.Форма.ФормаВыбора(9,28)}: Переменная не определена (Элементы)
СтрокаТабличнойЧасти = <<?>>Элементы.Документ.ТекущиеДанные;
{Документ.Прибыль.Форма.ФормаВыбора(4,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
{Документ.Прибыль.Форма.ФормаВыбора(10,5)}: Переменная не определена (РаботаСДокументами)
<<?>>РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
10.10.2015, 11:35
Ответы с готовыми решениями:

Сумма в документах не считается
Помогите решить проблему! ТиС 7.7. После объединения одной конфигурации с другой не считает поле...

С клавиатуры вводится строка, в ней и+1 меняется с и-1 элементом, считается количество таких перестановок, после этого считается сумма всех четных си
Дорогие форумчане, вы не раз мне помогали в решении проблем, но сегодня проблема, с которой я...

Не считается сумма товара
есть программа которая принимает тип товара и проданное количество этого товара.... подчитует...

Не считается сумма в форме access
Приветствую всех. Есть такая проблема: Существует ленточная форма с набором записей, в...

странно. сумма считается по разному
имеется такая конструкция Первый вариант - пичатает весь список Второй вариант - с...

6
Xomych
814 / 627 / 102
Регистрация: 01.11.2012
Сообщений: 2,264
10.10.2015, 11:38 2
Обычное приложение или Управляемые формы?
0
nasta22
0 / 0 / 0
Регистрация: 09.06.2015
Сообщений: 10
10.10.2015, 12:34  [ТС] 3
В форме документа
0
Xomych
814 / 627 / 102
Регистрация: 01.11.2012
Сообщений: 2,264
10.10.2015, 13:40 4
Понятно, что форме документа, на вопрос мой вы не ответили.
Базу скиньте, посмотрю
0
nasta22
0 / 0 / 0
Регистрация: 09.06.2015
Сообщений: 10
10.10.2015, 15:26  [ТС] 5
Новая папка.rar
0
nasta22
0 / 0 / 0
Регистрация: 09.06.2015
Сообщений: 10
10.10.2015, 15:29  [ТС] 6
там ошибка в документах 2х нужно высчитать сумму, и сделать кнопки печать
0
Xomych
814 / 627 / 102
Регистрация: 01.11.2012
Сообщений: 2,264
10.10.2015, 15:44 7
У вас полный бардак.
У вас нет в документах табличной части.
У вас нет формы документа, есть только форма выбора.
Вы расположили процедуры в форме Выбора, а не в форме документа.
Когда у общего модуля стоит галочка Глобальный перед его процедурами не нужно указывать имя общего модуля. (РассчитатьСумму, а не РаботаСДокументами.РассчитатьСумму).

1. Создайте табличную часть у документов
2. Создайте форму документа.
3. Перенесите туда процедуры из формы выбора.
0
10.10.2015, 15:44
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
10.10.2015, 15:44

Не считается сумма бесконечного ряда
Сделал програму но она не хочет считать суму ряду...никак не могу найти где я ошибся, помогите плз....

Сумма кодов символов считается не правильно
Где я допустил ошибку? var a:array of byte; s:string; c:char; ...

Неверно Считается Total Сумма В Представлении
Доброго дня, Ситуация следующая: Есть представление с многоуровневой категоризацией по...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru