Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
#1

Работа с табличным полем - 1С/1C 8.x

13.10.2015, 18:06. Просмотров 429. Ответов 19
Метки нет (Все метки)

С помощью обработки я создаю новый документ, встала проблема заполнить данные Табличного поля, в обработке ТП называется ТабОтветственных, в документе ТабОтветственных. Подскажите как заполнить ТП в документе
http://www.cyberforum.ru/1c-custom/thread1249865.html

1C
1
2
3
4
5
6
7
    Док=Документы.ЗаявкаЕдиноеОкно.СоздатьДокумент();
    Док.Дата=ДатаПоставки;
    Док.ЛицевойСчет=ЛицевойСчет;
    Док.Причина=Примечание;
    Док.ТипЗаявки=ТипЗаявки;
    Док.Статус=Перечисления.СтатусЕдиноеОкно.Открыта;
    Док.Записать(РежимЗаписиДокумента.Проведение);
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
13.10.2015, 18:06
Я подобрал для вас темы с готовыми решениями и ответами на вопрос 1C 8.x Работа с табличным полем (1С):

Работа с табличным документом (Расшифровки)
Я хочу чтобы при двойном клике на ячейку создавался документ как сделать где...

Работа с полем со списком
Здравствуйте! Мне нужно выбрать значение поля со списком, которое берется со...

Отчет по табличным частям документа
Есть документ который содержит 3 табличные части (рис прилагается), первая...

Запрос к трём табличным частям, выгрузка в ТЗ
Выбираем на форме документ из Справок..., после чего ДокОбъект1 =...

Создание справочника с Табличным полем программно
Нужен пример создания справочника с табличной частью. Справочник создается...

19
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 09:53 #2
Ermak27, Из обработки в конкретный документ перегнать данные?
Ссылка - это ссылка на документ.
1C
1
2
3
4
Для Каждого Строка Из ТабОтветственных Цикл
НоваяСтрока = Ссылка.табответственных.Добавить();
ЗаполнитьЗначениеСвойств(НоваяСтрока, Строка);
КонецЦикла;
1
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
14.10.2015, 11:29  [ТС] #3
Разобрался, спасибо!

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
    Док=Документы.ЗаявкаЕдиноеОкно.СоздатьДокумент();
    Док.Дата=ДатаПоставки;
    Док.ЛицевойСчет=ЛицевойСчет;
    Док.Причина=Примечание;
    Док.ТипЗаявки=ТипЗаявки;
    Док.Статус=Перечисления.СтатусЕдиноеОкно.Открыта;
    
    Для Каждого Строка Из Ответственных Цикл
        НоваяСтрока=Док.ТабОтветственных.Добавить();
        НоваяСтрока.ФИО=Строка.Наименование;
        НоваяСтрока.Должность=Строка.Код;
        НоваяСтрока.Статус=Перечисления.СтатусЕдиноеОкно.Открыта;
    КонецЦикла; 
    Док.Записать(РежимЗаписиДокумента.Проведение);
Добавлено через 1 час 16 минут
1c-k, Подскажите как при добавлении строки в ТЧ колонка принимает значение Открыта
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 11:37 #4
Ermak27, в смысле?
не понял совсем.
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
14.10.2015, 12:03  [ТС] #5
1c-k, Есть Табличная часть в Документе, нужно чтобы при добавлении новой строки в ТЧ колонка Статус принимала значение Открыта
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 12:07 #6
Ermak27, так у вас же написано, что передается перечисление.
НоваяСтрока.Статус=Перечисления.СтатусЕдиноеОкно.Открыта;
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
14.10.2015, 12:24  [ТС] #7
1c-k, Я уже про сам документ имею ввиду, я не могу понять какое Событие использовать для ТЧ
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 12:29 #8
Ermak27, на форме ТЗ ПередНачаломДобавления например.
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
14.10.2015, 14:41  [ТС] #9
1c-k, что то не работает

1C
1
2
3
4
5
Процедура ТабОтветственныхПередНачаломДобавления(Элемент, Отказ, Копирование)
    Для Каждого Строка Из ТабОтветственных Цикл 
            Строка.Статус = Перечисления.СтатусЕдиноеОкно.Открыта;
    КонецЦикла;
КонецПроцедуры
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 15:12 #10
Ermak27,
1C
1
2
3
4
5
&НаКлиенте
Процедура ТабЗначПриИзменении(Элемент)
    ТекущиеДанные = Элементы.ТабЗнач.ТекущиеДанные;
    ТекущиеДанные.Состоянике =  Перечисления.СтатусЕдиноеОкно.Открыта;
КонецПроцедуры
Тогда так
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
14.10.2015, 16:40  [ТС] #11
1c-k, У Табличной части не события При изменении
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
14.10.2015, 16:53 #12
Ermak27, тогда я не знаю, что на картинке.
0
Миниатюры
Работа с табличным полем  
Dethmontt
Модератор
Эксперт 1С
2577 / 2384 / 391
Регистрация: 10.03.2011
Сообщений: 8,424
Записей в блоге: 1
Завершенные тесты: 1
15.10.2015, 01:09 #13
В обычных формах у тч нет события при изменении

Добавлено через 4 минуты
Делай в событии передначаломизменения проверку на:
Если новаястрока тогда
элемент.текущиеданные.статус = нужныйстатус;
0
1c-k
15.10.2015, 07:23
  #14

Не по теме:

Ermak27, Dethmontt, давно и привычно фигачу тонкого клиента, я и забыл что бывает толстый))

0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
15.10.2015, 08:33  [ТС] #15
1c-k, Как тогда быть
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
15.10.2015, 09:09 #16
[OFF]Ermak27,
Цитата Сообщение от Dethmontt Посмотреть сообщение
Делай в событии передначаломизменения проверку на:
Если новаястрока тогда
элемент.текущиеданные.статус = нужныйстатус;
- так.
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
15.10.2015, 10:55  [ТС] #17
1c-k, Как проверить на новую строку
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
15.10.2015, 11:03 #18
[OFF]Ermak27, при чем здесь новую? На любую.
Ну проверить статус - если не установлен установить, если установлен ну не трогать.
0
Ermak27
4 / 4 / 1
Регистрация: 16.01.2013
Сообщений: 1,195
15.10.2015, 12:39  [ТС] #19
1c-k, Как проверить что эта новая строка?
Вот как сделал,но это не правильно работает
1C
1
2
3
4
5
6
Для Каждого Строка Из ТабОтветственных Цикл
        Если Строка.Статус="" Тогда
        Строка.Статус = Перечисления.СтатусЕдиноеОкно.Открыта;
    Иначе
        КонецЕсли;
    КонецЦикла;
0
1c-k
325 / 303 / 40
Регистрация: 20.08.2014
Сообщений: 1,198
Записей в блоге: 1
15.10.2015, 13:03 #20
Строка.Статус = Перечисления.СтатусЕдиноеОкно.ПустаяСсылка();
1
15.10.2015, 13:03
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.10.2015, 13:03
Привет! Вот еще темы с решениями:

работа с табличным документом
Задача вот какая:есть табличный документ, и в определенные ячейки со свойством...

Работа с памятью: можно ли в массив объектов с полем типа "Родитель", вписать объекты с полем типа "Потомок"
Здравствуйте. Предположим, что у нас есть массив из структур в которых...

работа с полем со списком
В форме имеется поле со списком в котором отображается несколько значений из...

Работа с RTF полем
Здравствуйте! Вот столкнулся с проблемой, которую сам решить уже отчаялся ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
20
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru