Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.50/2: Рейтинг темы: голосов - 2, средняя оценка - 4.50
Андрюханыч
0 / 0 / 0
Регистрация: 23.10.2015
Сообщений: 3
1

Запрос к табличной части 1С

23.10.2015, 12:57. Просмотров 439. Ответов 6
Метки нет (Все метки)

Пожалуйсто помогите, очень хочу разобраться.
Студенты-справочник
Курс- таблична часть его

1C
1
2
3
4
5
6
7
8
9
10
11
12
&НаСервере
Процедура Надмите_меняНаСервере()
  выборка = справочники.Студенты.Выбрать();
        Пока выборка.Следующий() Цикл
            тча=выборка.Курсы.Количество();
    
                    если    
                    (тча=1)                 
                тогда
                    сообщить(выборка.Имя);
                      КонецЕсли
              КонецЦикла
выводит студентов у которых выбран 1 курс, как вывести сам курс?
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
23.10.2015, 12:57
Ответы с готовыми решениями:

Значение строки табличной части получить в табличной части другого документа
Есть документ ПриходнаяНакладная (товар приходит от поставщика по его цене), с...

Запрос к табличной части
Не могу понять в чем ошибка, делаю как в примере Запрос1 = новый Запрос;...

Запрос к табличной части документа
Здравствуйте, есть запрос: "ВЫБРАТЬ | Док.Работники.( | Работник,...

Запрос по табличной части справочника
Добрый день. Начинаю изучать 8ку поэтому прошу прощения за глупые вопросы. Есть...

Передача табличной части обработки в запрос
Здравствуйте. Делаю внешнюю обработку для Документооборота. Сделал запрос для...

6
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
23.10.2015, 14:18 2
1C
1
2
3
4
5
6
если    
                    (тча=1)                 
                тогда
                    сообщить(выборка.Имя);
                    сообщить(выборка.Курсы[0].Курс); //Курс - имя колонки табличной части "КУРСЫ"
                      КонецЕсли
1
Андрюханыч
0 / 0 / 0
Регистрация: 23.10.2015
Сообщений: 3
23.10.2015, 14:47  [ТС] 3
Спасибо, круто ! Работает. 0- это индекс?

Добавлено через 5 минут
А как быть, если тча>1 и надо вывести все курсы этого студента?
0
Phil
Эксперт 1С
404 / 281 / 86
Регистрация: 28.05.2014
Сообщений: 1,132
23.10.2015, 15:23 4
Андрюханыч, сделать обход результат запроса по группировкам.
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
23.10.2015, 16:38 5
Цитата Сообщение от Андрюханыч Посмотреть сообщение
А как быть, если тча>1 и надо вывести все курсы этого студента?
Сделать цикл.
0
Андрюханыч
0 / 0 / 0
Регистрация: 23.10.2015
Сообщений: 3
25.10.2015, 12:39  [ТС] 6
чо то не то написал, вылетает и зависает. Как написать это,
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
 выборка = справочники.Студенты.Выбрать();
        Пока выборка.Следующий() Цикл
            тча=выборка.Курсы.Количество();
    
                    если    
                    (тча>1)                 
                Тогда
        Пока выборка.Следующий() Цикл
 
  сообщить(выборка.Курсы[].Курс);
конецЦикл
 
                    сообщить(выборка.Имя);
                      КонецЕсли
              КонецЦикла
0
Dethmontt
Модератор
Эксперт 1С
2643 / 2436 / 415
Регистрация: 10.03.2011
Сообщений: 8,699
Записей в блоге: 1
Завершенные тесты: 1
26.10.2015, 00:15 7
1C
1
2
3
4
5
6
выборка = справочники.Студенты.Выбрать();
        Пока выборка.Следующий() Цикл
             Для каждого Стр Из Выборка.Курсы Цикл
                  Сообщить(Стр.Курс);
             КонецЦикла;
        КонецЦикла;
0
26.10.2015, 00:15
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
26.10.2015, 00:15

Отбор в табличной части
Всем привет! На обычных формах в табличной части на форме можно делать отборы...

Создание табличной части
Здравствуйте,форумчане! И это снова я,нубас!)) В общем пишу диплом,хочу...

Заполнение табличной части
Есть документ "Учебные поручения", в нем есть реквизит Дисциплина (Тип...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
7
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru