Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/25: Рейтинг темы: голосов - 25, средняя оценка - 5.00
_leon4uk_
2 / 2 / 0
Регистрация: 06.12.2009
Сообщений: 11
1

Кнопка "Выбрать" на форме выбора или как выполнить нажатие кнопки "Выбрать"

20.01.2016, 23:07. Просмотров 4612. Ответов 7
Метки нет (Все метки)

Добрый день!

Обычное приложение.

Какие мысли есть, чтобы выполнить нажатие на кнопку "Выбрать" на форме выбора документа/справочника?

в открытой форме делаю отбор по ссылке, полученной из формы владельца.

кликать мышкой и СОМ не предлагать делаю автоматизацию.

хотелка: в форме выбора симитировать нажатие кнопки "Выбрать".
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
20.01.2016, 23:07
Ответы с готовыми решениями:

1С 8.3 Розница 2.1.4.9 "Текущая цена розницы" и "Остаток" в форме элемента "Номенклатура"
Есть ли готовое решение, можно через внешнюю форму нужно контроль "Текущая цена розницы" и...

Ошибка Ошибка при вызове метода контекста (Выполнить) Ожидается выражение "ВЫБРАТЬ"
Выдает ошибку. Была пропущена точка. Исправила. Выдавал другую ошибку теперь опять эту. ...

Отсутствует кнопка "Печать" на форме документа.
Вот как сделать, чтобы такая - же кнопка появилась и на другой форме? Помогите плз

Из документа "Смена учетных параметров" выбрать нужный документ по серийному номеру и номенклатуре
У меня есть серийный номер и номенклатура, мне нужно из документа "Смена учетных параметров"...

Как вызвать функцию формы "Обработки" из "Общего модуля"?
В Обработке реализована некая функция. Как мне вызвать ее из Общего модуля? Эта функция собирает...

7
Yanush
162 / 158 / 62
Регистрация: 28.09.2013
Сообщений: 293
Завершенные тесты: 1
21.01.2016, 00:59 2
Форма (Form)
Закрыть (Close)
Синтаксис:

Закрыть(<ПараметрЗакрытия>)
Параметры:

<ПараметрЗакрытия> (необязательный)

Тип: Произвольный.
Параметр закрытия формы, открытой в модальном режиме. Это значение будет возвращено как результат метода, открывающего форму модально.
Описание:

Закрывает форму. Если закрываемая форма была открыта в модальном режиме, то метод может передать команду закрытия методу, открывшему форму.

Доступность:

Толстый клиент.
Примечание:

Если форма является владельцем другой модально открытой формы, то данную форму нельзя закрыть до тех пор, пока не будет закрыта дочерняя модально открытая форма.
Пример:

Закрыть("ОК");
0
_leon4uk_
2 / 2 / 0
Регистрация: 06.12.2009
Сообщений: 11
21.01.2016, 08:55  [ТС] 3
Yanush,
Спасибо за отклик.

Не совсем понял, как вернет мне в моём случае значение.
мой код:
1C
1
2
3
4
5
6
7
8
9
10
11
Процедура ВыполнитьВыборВФормеВыбора(Ссылка, Форма)                  //параметр "ссылка" это ссылка из реквизита формы документа; параметр "форма" это форма документа, с которой открываю формы выбора из полей выбора на форме документа
    ФормаВыбораСправочника = Справочники.Банки.ПолучитьФОрмуВыбора(,Форма,Ссылка);
    ФормаВыбораСправочника.Отбор.Ссылка.Использование = Истина;
    ФормаВыбораСправочника.Отбор.Ссылка.Значение = ссылка;
    ФормаВыбораСправочника.ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Ложь;
    ФормаВыбораСправочника.Открыть();
    Если ФормаВыбораСправочника.Открыта() Тогда
        ФормаВыбораСправочника.Активизировать();
    КонецЕсли;
    Закрыть("ОК");
КонецПроцедуры
0
SHIFT_969
Злой самаритянин
178 / 179 / 94
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
21.01.2016, 10:20 4
_leon4uk_, У того же поля событие ОбработкаВыбора(). Туда попадет ПараметрЗакрытия.
Кликните здесь для просмотра всего текста
ОбработкаВыбора (ChoiceProcessing)
Синтаксис:

ОбработкаВыбора(<ВыбранноеЗначение>, <ИсточникВыбора>)
Параметры:

<ВыбранноеЗначение>

Тип: Произвольный.
Результат выбора в подчиненной форме. В случае множественного выбора возвращается массив выбранных значений.
<ИсточникВыбора>

Тип: Произвольный.
Форма, где осуществлен выбор.
Описание:

Возникает на клиенте при выборе объекта в одной из подчиненных форм или при вызове в одной из подчиненных форм метода ОповеститьОВыборе".
0
21.01.2016, 10:20
Xomych
812 / 625 / 102
Регистрация: 01.11.2012
Сообщений: 2,247
21.01.2016, 10:24 5
А зачем ты это делаешь? У тебя же уже есть нужная тебе ссылка?
Тебе нужно, чтобы на экране мигнула форма выбора?
0
_leon4uk_
2 / 2 / 0
Регистрация: 06.12.2009
Сообщений: 11
21.01.2016, 10:32  [ТС] 6
Как бы это выглядело с точки зрения кликанья мыши:
1. Открыть документ.
2. Тыкнуть на кнопку "Выбрать" в поле выбора на форме документа. (с условием что значение заполнено).
3. В открытой форме выбора найти этот же элемент.
4. Выбрать его.
5. Нажать на кнопку "Выбрать" на форме выбора.

вот так...
0
Xomych
21.01.2016, 10:39
  #7

Не по теме:

Для чего так делать нужно? Просто инетерсно, что за задача такая? о_О

0
_leon4uk_
2 / 2 / 0
Регистрация: 06.12.2009
Сообщений: 11
21.01.2016, 11:09  [ТС] 8
Вроде решил задачу...пару прогонов теста.

Добавлено через 17 минут
Пока работает вот так:

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
Процедура ВыполнитьВыборВФормеВыбора(Ссылка, рек) //параметр "ссылка" - это ссылка значения на форме документа; "рек" - текущий элемент формы, т.е. поле выбора
    ФормаВыбораСправочника = Справочники.Банки.ПолучитьФОрмуВыбора(,Рек,Ссылка);
    ФормаВыбораСправочника.ЭлементыФормы.СправочникСписок.ИерархическийПросмотр = Ложь;
    ОткрытьФорму(ФормаВыбораСправочника,,рек,,,,,);
    
    Если ФормаВыбораСправочника.Открыта() Тогда
        ФормаВыбораСправочника.Активизировать();
    КонецЕсли;
    
    ФормаВыбораСправочника.ТекущийЭлемент.ТекущаяСтрока = ссылка;
    ВыборЭл = ФормаВыбораСправочника.ТекущийЭлемент.ТекущаяСтрока;
    
    если ВыборЭл = неопределено или НЕ значениезаполнено(ВыборЭл) тогда
        Сообщить("Значение "+Ссылка+" не было найдено в форме выбора справочника");
    иначе
        ФормаВыбораСправочника.ОповеститьОВыборе(ВыборЭл);
    КонецЕсли;
    
КонецПроцедуры
0
21.01.2016, 11:09
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
21.01.2016, 11:09

Как создать колонку "Цена" и "Количество" в справочнике номенклатура
Подскажите как создать колонку &quot;Цена&quot; и &quot;Количество&quot; в справочнике номенклатура?

На форму списка товаров добавить "ТабличноеПоле" с типом значений "ДеревоЗначений"
1С.8.0 На форму списка товаров добавить &quot;ТабличноеПоле&quot; с типом значений &quot;ДеревоЗначений&quot;. При...

Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода"
Для документа &quot;ПродажаТоваров&quot; на форму списка добавить &quot;ПолеВвода&quot; с типом...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
8
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru