Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.67/9: Рейтинг темы: голосов - 9, средняя оценка - 4.67
MaxKor
0 / 0 / 0
Регистрация: 22.11.2015
Сообщений: 5
1

Внешняя обработка

02.03.2016, 17:09. Просмотров 1808. Ответов 2
Метки нет (Все метки)

Всем привет!
Помогите пожалуйста составить такой вот код - (перебирает целые числа от 0 до бесконечности и выводит на экран те, которые делятся без остатка на количество разрядов (знаков) этого числа (т.е. те двухзначные, которые делятся на 2, трехзначные на три и т.д.). Выполнение обработки должно остановиться в тот момент, когда всего будет выведено N (задается пользователем) таких чисел.)
Нужен для внешней обработки. Спасибо, заранее!
0
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
02.03.2016, 17:09
Ответы с готовыми решениями:

Внешняя обработка
Нужно создать внешнюю обработку. Ввести в поле ввода дату. По кнопке "Сформировать" получить дату,...

Внешняя обработка
Здравствуйте! как из формы внешней обработки сформировать типовой отчет и передать необходимые...

Внешняя обработка печати
Добрый день, не разу не работал со внешней обработкой печати, подскажите что не так. Работаю с УТ...

Внешняя обработка из Далион
Ситуация такая имеется обработка из 1С:8 далион, надо переделать в 1С:8 розницу, соответственно в...

Внешняя обработка, создание формы
Всем доброго времени суток. Народ, подскажите, пишу с нуля внешнюю обработку для загрузки данных в...

2
GreenkA
Модератор
Эксперт 1С
2990 / 1911 / 520
Регистрация: 25.06.2009
Сообщений: 6,784
02.03.2016, 18:20 2
MaxKor,
1C
1
2
3
4
5
6
7
8
    N = 0;
    Если ВвестиЧисло(N, "Введите количество", 15, 0) Тогда
        Для к = 0 по N Цикл
            Если к%(СтрДлина(к)) = 0 Тогда
                Сообщить("Число " + к + " делится без остатка на " + СтрДлина(к));
            КонецЕсли;
        КонецЦикла; 
    КонецЕсли;
0
Tklwegsd
Эксперт 1С
762 / 556 / 189
Регистрация: 24.07.2013
Сообщений: 1,918
02.03.2016, 19:33 3
GreenkO, С функцией СтрДлина(к) будут проблемы для чисел начиная с 1 000, из-за неразрывного пробела (а вообщем, строковое представление числа зависит от региональных настроек).

Не по теме:

Это общее замечание, автору топика подумать (GreenkO, думаю, в курсе).

0
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
02.03.2016, 19:33

Внешняя обработка для копирования документов
Здраствуйте, создаю внешнюю обработку для копирования документов. Не могу понять как застить ее...

Внешняя обработка для создания документа
Нужно создать внешнюю обработку для созданию общего заказа поставщику из остальных заказов с...

Планирование статей бюджетов и внешняя обработка
Добрый день! Подскажите алгоритм(хотя бы на пункта три, уже будет прекрасно) действий в...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
3
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru