Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
HikiLoner
0 / 0 / 0
Регистрация: 12.03.2016
Сообщений: 5
1

Получение реквизита из справочника в табличную часть документа

12.03.2016, 17:50. Просмотров 936. Ответов 5
Метки нет (Все метки)

Доброе время суток!Скорее всего мой вопрос очень глупый , но прошу помочь.
имеем справочник Санатории в них стандартный реквизит наименование и реквизит цена
Вопрос: как сделать так что бы при выборе тура в табличной части подставлялась цена , а затем производился расчет:
Цена*Колво=Стоимость;Точнее как написать эту процедуру
0
Миниатюры
Получение реквизита  из справочника в табличную часть документа  
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
12.03.2016, 17:50
Ответы с готовыми решениями:

Получение реквизита из справочника в табличную часть документа
Помогите пожалуйста! Как только ни пробовала, не могу понять в чем дело.... Есть справочник...

Получение реквизита из справочника в табличную часть документа
Здравствуйте, полный нуб в 1с. Прошу больно не пинать. Вопрос самый простой и глупый. Есть документ...

При выборе реквизита справочника выводить табличную часть другого справочника
Помогите пожалуйста сделать выборку. Есть справочник с реквизитами сотрудника и табличной частью с...

Данные из справочника в табличную часть документа
Здравствуйте. Ситуация следующая: Существует справочник "Маршруты" с реквизитами ПунктЗагрузки и...

Из табличной части справочника в табличную часть документа
1С:8.2! Здраствуйте, имеются объекты: 1) справочник "Продукция" реквизиты:"Наименование"(указаны...

5
GreenkA
Форумчанин
Эксперт 1С
3004 / 1924 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
12.03.2016, 23:03 2
HikiLoner, на событие поля Тур ПриИзменении прописать:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
&НаКлиенте
Процедура ТурПриИзменении(Элемент)
 ТекСтрока = Элемент.Родитель.ТекущиеДанные;
 ТекСтрока.Цена = ПолучитьЦенуНаСервере(ТекСтрока.Тур);
 ПересчитатьСтоимостьСтроки(ТекСтрока);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьЦенуНаСервере(Тур)
 Возврат Тур.Цена;
КонецФункции
 
&НаКлиенте
Процедура ПересчитатьСтоимостьСтроки(ТекСтрока)
 ТекСтрока.Стоимость = ТекСтрока.Цена * ТекСтрока.Количество;
КонецПроцедуры
Я бы на вашем месте ПересчитатьСтоимостьСтроки(...) вызывала еще при изменении Цены и Количества(количества так точно).
1
HikiLoner
0 / 0 / 0
Регистрация: 12.03.2016
Сообщений: 5
12.03.2016, 23:36  [ТС] 3
Спасибо! Но тут похоже дело в моей кривой конфигурации либо в ограничениях учебной версии в которой разрабатывалась конфигурация. Взгляните на конфигурацию ,если вас это не затруднит.
0
Вложения
Тип файла: rar 1Cv8.rar (62.3 Кб, 4 просмотров)
GreenkA
Форумчанин
Эксперт 1С
3004 / 1924 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
13.03.2016, 00:36 4
HikiLoner, дело не в конфе или ограничениях, а в руках или лени...
1
Вложения
Тип файла: zip 1Cv8_изм.zip (30.0 Кб, 11 просмотров)
HikiLoner
0 / 0 / 0
Регистрация: 12.03.2016
Сообщений: 5
13.03.2016, 13:41  [ТС] 5
Спасибо! Похоже я не знаю ничего про синтаксис, буду искать материал для изучения.

Добавлено через 1 минуту
Я понял что не могу сам доработать конфигурацию тк не имею достаточно знаний .
Имеем: Готовое ТЗ и собственно конфигурацию которую я ранее загружал.
Вопрос:Могли бы вы сделать конфигурацию за определенную плату? или мне следует обратится в соответствующий раздел?
0
GreenkA
Форумчанин
Эксперт 1С
3004 / 1924 / 520
Регистрация: 25.06.2009
Сообщений: 6,817
13.03.2016, 20:11 6
HikiLoner, можете обратиться в раздел фриланса.
0
13.03.2016, 20:11
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
13.03.2016, 20:11

Автозаполнение из табличной части справочника в табличную часть документа
Здравствуйте , помогите пожалуйста с кодом Мне нужно чтобы автоматически заполнялась табличная...

1С запрос из табличной части справочника в табличную часть документа
Здравствуйте! У меня есть справочник "Концерты" с табличной частью "Цены" (1 и 2 рисунки). Строки...

Ввод значения из реквизита в табличную часть
Добрый день! Есть документ " Проекты", в котором есть реквизит "Наименование". Также в данном...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
6
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.