Форум программистов, компьютерный форум, киберфорум
Наши страницы

1С: Собственные программы

Войти
Регистрация
Восстановить пароль
 
Gokusa
Заблокирован
#1

Свойство "защита" в поле табличного документа - 1С

14.03.2016, 18:25. Просмотров 2361. Ответов 4
Метки нет (Все метки)

всем привет.
как поставить защиту на ячейку и / или область табличного документа.
или как-то иначе запретить редактирование данной области/ ячейки.
свойство "защита", установленное в конфигураторе ни на что не влияет, как мне показалось.
0
Надоела реклама? Зарегистрируйтесь и она исчезнет полностью.
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
14.03.2016, 18:25
Я подобрал для вас темы с готовыми решениями и ответами на вопрос Свойство "защита" в поле табличного документа (1С):

Активизировать поле табличного документа - 1С
проблема. сделал отчет с собственной расшифровкой, неограниченный уровень вложенносчти отрабаотывает, две таблицы выводит диаграмму...

1C 8.x (тонкий) 8.3: В поле табличного документа вывести список значений ? - 1С
Задача предоставить пользователю возможность выбрать в ячейке таб.документа на форме одно из нескольких значений. Вариант с обработкой...

1C 8.x Открыть форму и заполнить поле табличного документа - 1С
Привет, народ! подскажите, как открыть форму программно , сформировать макет и выводить этот макет в табличное поле на этой форме? ...

1C 8.x Как программно вставить область в поле табличного документа? - 1С
Есть поле табличного документа (который аналог листа Екселя), туда пользователем тупо вставляются данные (ctrl + v), как программно...

1C 8.x Поле Табличного Документа - выделить все (аналог Ctrl + A) - 1С
Вступление: 1С 8.1, Форма, на ней ПолеТабличногоДокумента Вопрос: Как выделить все ячейки этого ПоляТабличногоДокумента... как бы...

1C 8.x Автоматическое заполнение поля "Комментарий" документа "заказ покупателя" - 1С
Всем здравствуйте! Помогите, пожалуйста, решить такую задачку: С сайта (на Битриксе) выгружаются заказы покупателя, необходимые мне...

4
Yanush
159 / 156 / 46
Регистрация: 28.09.2013
Сообщений: 288
Завершенные тесты: 1
14.03.2016, 22:04 #2
1.
ТабличныйДокумент (SpreadsheetDocument)
Защита (Protection)
Использование:

Чтение и запись.
Описание:

Тип: Булево.
Содержит признак защиты таблицы от редактирования и копирования. В режиме защиты таблица может быть только распечатана.
Истина - защита включена.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.

2.
ТабличныйДокумент (SpreadsheetDocument)
ТолькоПросмотр (ReadOnly)
Использование:

Чтение и запись.
Описание:

Тип: Булево.
Содержит признак того, что табличный документ открыт в режиме просмотра. В режиме просмотра в таблице не доступны для редактирования ячейки и рисунки, у которых установлено свойство Защита.
Истина - режим просмотра.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).
Примечание:

Если табличный документ расположен на форме, то у него могут возникать события Выбор и ОбработкаРасшифровки только в режиме просмотра.
0
Gokusa
Заблокирован
15.03.2016, 10:31  [ТС] #3
это все конечно хорошо.
только это не работает
я ставлю
тд = новый табдок;
тд.защита = истина;
далее вывожу в него области макета.В которых управляю защитой ячеек.
и в итоге ничего не получаю,
защитные свойства ячеек целиком засисят от защиты тд.
на области им наплевать.
вопрос
как в одном табдоке вывести разные по уровню защиты ячейки?
если состояние уровня их защиты изменено по сравнению со значением по умолчанием в макете.

Добавлено через 6 минут
карочи
суть
есть макет защита выкл

пишу
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Если ЗначениеЗаполнено(ВыборкаДетальныеЗаписи.ЧисленностьОбучающихся) Тогда  // проверить только первый элемент по сути надо
            область1.Параметры.ЧисленностьНаучныхКадров = ВыборкаДетальныеЗаписи.ЧисленностьОбучающихся;
            ЧисленностьЗаполнена = Истина;
        КонецЕсли;
    КонецЦикла;
    Если ЧисленностьЗаполнена Тогда
        // делаем ячейку редактируемой 
        область1.защита = Ложь;
     КонецЕсли;
    
    тд.Вывести(облПодготовкаНаучныхКадров);
    тд.Присоединить(Область1);
    //тд.Присоединить(
у тд защита вкл.
в итоге все вкл.

Добавлено через 47 минут
карочи разоббрался.
эта хрень корректно работает только на ячейках.
0
Yanush
159 / 156 / 46
Регистрация: 28.09.2013
Сообщений: 288
Завершенные тесты: 1
15.03.2016, 15:46 #4
Ну нужно было внимательно прочитать 2й пункт моего сообщения, а именно: "В режиме просмотра в таблице не доступны для редактирования ячейки и рисунки, у которых установлено свойство Защита".
И вопросы бы отпали сами собой =)
0
Gokusa
Заблокирован
15.03.2016, 16:21  [ТС] #5
аааа
вовсе не отпали бы
что тогда значит и какой смысл имеет установка свойства защита в истина на область.
при отключенной защита у всего табличного документа.
и включенной защита у ячейки?

Добавлено через 1 минуту
другой вариант
область выкл.
табл док выкл.
ячейка вкл ---???
третий вариант
табдок вкл, область выкл, ячейка вкл.
/////////////////
получается область ни на чте не влияет?
//////////
з.ы. спасибо за сообщение.
0
15.03.2016, 16:21
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
15.03.2016, 16:21
Привет! Вот еще темы с ответами:

1C 8.x Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода" - 1С
Для документа "ПродажаТоваров" на форму списка добавить "ПолеВвода" с типом "СправочникСсылка.Контрагенты". На событие формы "ПриОткрытии"...

Ошибка при выполнении проведения документа "Бухгалтерская Операция" - 1С
При проведении документа БухгалтерскаяОперация выдает: Поле объекта не обнаружено(Хозрасчетный) Ошибка при выполнении обработчика -...

Заполнение табличной части документа "Инвентарных номеров" - 1С
Здравствуйте многоуважаемые форумчане. Обращаюсь к Вам за очередной помощью. После долгих исканий и читаний сайтов и книг. Я наконец-то...

1C 8.x Внешняя обработка заполнения документа "Заказ покупателя" - 1С
Всем опять здравствуйте! Я опять вернулась к этой проблеме, потому что она так и не решилась. Попробую объяснить ее еще раз. ...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
5
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Рейтинг@Mail.ru