Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 4.80/5: Рейтинг темы: голосов - 5, средняя оценка - 4.80
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
1

Заполнение поля

16.03.2016, 16:06. Просмотров 940. Ответов 16
Метки нет (Все метки)

Имеется форма для заполнения реквизитов документа.
Как сделать так, чтобы:
При заполнении Поля ФИО заполнялось поле Должность, которое привязано в справочнике Сотрудники?
Т.е.
1) Петров Петр Петрович - Программист
1) Петрова Марина Петровна - Директор.

Заказываю контрольные, курсовые, дипломные и любые другие студенческие работы здесь.

0
Лучшие ответы (1)
Similar
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.03.2016, 16:06
Ответы с готовыми решениями:

Заполнение тч поля из справочника(заполнение ссылочного поля)
Здравствуйте! Существует док с полем Справочник.Ссылка.Номенклатура и спрНоменклатура вопрос...

Автоматическое заполнение поля
У меня есть документы: ПоступлениеТоваров и ОплатаКонтрагенту Регистр накоплений: ДолгКонтрагентам...

Заполнение табличного поля из запроса
Столкнулся с такой проблемой: есть один документ, у него несколько табличных частей которые...

Автоматическое заполнение поля Сумма в табличной части документа
Скажите можно ли сделать так чтобы когда заполняю документ Приходная накладная я записываю цену...

Заполнение поля макета
Доброго времени суток! Решила создать базу данных и столкнулась с проблемой: как сделать так, чтобы...

16
Phil
Эксперт 1С
427 / 300 / 90
Регистрация: 28.05.2014
Сообщений: 1,208
16.03.2016, 16:11 2
Dutenass, сделать событие приИзмениии, для поля ФИО, чтобы автоматом проставлялось должность.
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
16.03.2016, 16:25  [ТС] 3
1C
1
2
3
4
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Элементы.Должность = "123";
КонецПроцедуры
Вот так?
0
Phil
Эксперт 1С
427 / 300 / 90
Регистрация: 28.05.2014
Сообщений: 1,208
16.03.2016, 16:45 4
Dutenass, тип того
1C
1
 = Сотрудник.Должность
0
16.03.2016, 16:45
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
16.03.2016, 16:47  [ТС] 5
1C
1
    Элементы.Должность = Справочники.Сотрудники.Должность;
Ничего не происходит...
0
Phil
Эксперт 1С
427 / 300 / 90
Регистрация: 28.05.2014
Сообщений: 1,208
16.03.2016, 16:51 6
Dutenass, у тебя на форме есть сотрудник?
1C
1
Сотрудник.должность
Добавлено через 1 минуту
на основании чего должность то должна заполняться) Мы ФИО заполняем новому сотруднику? логика какая?
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
16.03.2016, 16:58  [ТС] 7
Не понял вопроса...
Я выбираю ФИО сотрудника из справочника

Добавлено через 3 минуты
Я хочу, чтобы при выборе ФИО вводилось значение Должность в поле на форме "Должность", которое привязано к ФИО в справочнике

Добавлено через 2 минуты
1C
1
2
3
4
5
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Элементы.Должность = "123";
 
КонецПроцедуры
А вот так
После выбора ФИО выводится ошибка: поле недоступно для записи
0
SHIFT_969
Злой самаритянин
178 / 179 / 94
Регистрация: 24.04.2014
Сообщений: 686
Завершенные тесты: 1
16.03.2016, 18:55 8
1C
1
2
3
4
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Объект.Должность = Объект.ФИО.Должность;
КонецПроцедуры
Если в ФИО у тебя действительно ссылка, а не строка.
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
17.03.2016, 04:58  [ТС] 9
Поле объекта не обнаружено..
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
17.03.2016, 10:02 10
Dutenass, выложите вашу конфигурацию. Непонятна структура справочника и документа.
0
Briolin
58 / 63 / 11
Регистрация: 13.11.2014
Сообщений: 909
17.03.2016, 12:25 11
Можно и без программирования обойтись в полне-на форме, у реквизита ФИО выберите нужный путь данных
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
17.03.2016, 15:48  [ТС] 12
https://yadi.sk/d/7qXAxwy0obv9r
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
17.03.2016, 15:56 13
Dutenass, прикреплять файлы необходимо во вложении
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
17.03.2016, 16:14  [ТС] 14
От не может опознать...
0
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
17.03.2016, 16:27 15
Dutenass, предварительно заархивируйте.
0
Dutenass
3 / 3 / 5
Регистрация: 05.01.2011
Сообщений: 157
17.03.2016, 16:32  [ТС] 16
От не может опознать...
0
Вложения
Тип файла: rar 1Cv8.rar (32.9 Кб, 3 просмотров)
GreenkA
Форумчанин
Эксперт 1С
2996 / 1926 / 520
Регистрация: 25.06.2009
Сообщений: 6,804
17.03.2016, 17:14 17
Лучший ответ Сообщение было отмечено Dutenass как решение

Решение

Dutenass, у ФИО тип - Строка, а не СправочникСсылка.Сотрудники. Тогда видимо надо так:
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Объект.Должность = ПолучитьДолжностьНаСервере(Объект.ФИО);
КонецПроцедуры
 
&НаСервереБезКонтекста
Функция ПолучитьДолжностьНаСервере(ФИО)
 Сотрудник = Справочники.Сотрудники.НайтиПоНаименованию(ФИО);
 Если Сотрудник.Пустая() Тогда
  Возврат Справочники.Должности.ПустаяСсылка();
 Иначе
  Возврат Сотрудник.Должность;
 КонецЕсли;
КонецФункции
1
17.03.2016, 17:14
MoreAnswers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
17.03.2016, 17:14

Написание кода заполнение поля Оплаты 2
&НаКлиенте Процедура ПереченьНоменклатурыОплаченноПриИзменении(Элемент) //Установить что уже...

Написание кода заполнение поля Оплаты
Помогите, пожалуйста!!! Написать код. Мне нужно, чтобы в документе "ОказаниеУслуг" в поле...

Программное заполнение табличного поля данными из справочника
Я пытаюсь заполнить табличное поле данными из таблицы, но в результате оно остается пустым. Я...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
17
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Рейтинг@Mail.ru