Форум программистов, компьютерный форум, киберфорум
Наши страницы
1С: Собственные программы
Войти
Регистрация
Восстановить пароль
 
Рейтинг 5.00/3: Рейтинг темы: голосов - 3, средняя оценка - 5.00
Volexovich
203 / 178 / 30
Регистрация: 24.10.2011
Сообщений: 721
1

Как на мобильном клиенте проверить корректность введенного адреса эл. почты?

16.03.2016, 16:20. Просмотров 564. Ответов 9
Метки нет (Все метки)

Как на мобильном клиенте проверить корректность введенного адреса эл. почты?
0
QA
Эксперт
41792 / 34177 / 6122
Регистрация: 12.04.2006
Сообщений: 57,940
16.03.2016, 16:20
Ответы с готовыми решениями:

Проверка на корректность введенного e-mail адреса
Доброго времени суток! Написал программу связанную из http-запросов, но не могу написать проверку...

Проверка введенного url адреса на корректность
Здравствуйте, требуется ваша помощь не могли бы подсказать как организовать проверку введенного...

Как проверить работоспособность адреса электронной почты?
подскажите, как проверить работоспособность адреса эл.почты, не отправляя на него письма. возможно...

Нужно проверить на корректность ввода E-mail адреса
Допустим пользователь вводит _____@___.___ Как мы можем проверить эти три ↑ ..... ↑.... ...

Разработать программу, которая вводит адрес электронной почты и проверяет синтаксис введенного адреса
В имени пользователя могут быть только следующие символы: буквы латинского алфавита, цифры, дефис...

9
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
17.03.2016, 08:09 2
А что подразумевается под корректностью?
Проверить, что в строке есть "@" и чуть дальше "."?
0
Volexovich
203 / 178 / 30
Регистрация: 24.10.2011
Сообщений: 721
17.03.2016, 10:08  [ТС] 3
Да, но в ручную проверять лень, вот думаю, может метод есть какой.
0
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
17.03.2016, 10:24 4
Volexovich, открой любую типовую или БСП и посмотри, как там делается.
0
17.03.2016, 10:24
Volexovich
203 / 178 / 30
Регистрация: 24.10.2011
Сообщений: 721
17.03.2016, 10:40  [ТС] 5
Вообще весь смысл вопроса в том что, есть ли метод на мобильном клиенте для проверки, проверить на регулярное выражение не проблема, интересно наличие встроенного метода.
0
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
17.03.2016, 10:47 6
Volexovich, нет. В синтакс-помощнике смотри "Почта".

Вот кусок из типовой (УТ 11)

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
Функция АдресЭлектроннойПочтыСоответствуетТребованиям(Знач Адрес, РазрешитьЛокальныеАдреса = Ложь) Экспорт
    
    // Допустимые символы для email.
    Буквы = "abcdefghijklmnopqrstuvwxyzабвгдеёжзийклмнопрстуфхцчшщъыьэюя";
    Цифры = "0123456789";
    СпецСимволы = ".@_-";
    
    // Проверяем любые сочетания спецсимволов.
    Если СтрДлина(СпецСимволы) > 1 Тогда
        Для Позиция1 = 1 По СтрДлина(СпецСимволы)-1 Цикл
            Символ1 = Сред(СпецСимволы, Позиция1, 1);
            Для Позиция2 = Позиция1 + 1 По СтрДлина(СпецСимволы) Цикл
                Символ2 = Сред(СпецСимволы, Позиция2, 1);
                Комбинация1 = Символ1 + Символ2;
                Комбинация2 = Символ2 + Символ1;
                Если Найти(Адрес, Комбинация1) > 0 Или Найти(Адрес, Комбинация2) > 0 Тогда
                    Возврат Ложь;
                КонецЕсли;
            КонецЦикла;
        КонецЦикла;
    КонецЕсли;
    
    // проверяем символ @
    Если СтрЧислоВхождений(Адрес, "@") <> 1 Тогда
        Возврат Ложь;
    КонецЕсли;
       
    // проверяем две точки подряд
    Если Найти(Адрес, "..") > 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Приводим строку адреса к нижнему регистру.
    Адрес = НРег(Адрес);
    
    // Проверяем допустимые символы.
    Если Не СтрокаСодержитТолькоДопустимыеСимволы(Адрес, Буквы + Цифры + СпецСимволы) Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Разбираем адрес на local-part и domain.
    Позиция = Найти(Адрес,"@");
    ЛокальноеИмя = Лев(Адрес, Позиция - 1);
    Домен = Сред(Адрес, Позиция + 1);
    
    // Проверяем на заполненность и допустимость длины.
    Если ПустаяСтрока(ЛокальноеИмя)
        Или ПустаяСтрока(Домен)
        Или СтрДлина(ЛокальноеИмя) > 64
        Или СтрДлина(Домен) > 255 Тогда
        
        Возврат Ложь;
    КонецЕсли;
    
    // Проверяем наличие спецсимволов в начале и в конце частей адреса.
    Если ЕстьСимволыВНачалеВКонце(ЛокальноеИмя, СпецСимволы) Или ЕстьСимволыВНачалеВКонце(Домен, СпецСимволы) Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // В домене должна быть минимум одна точка.
    Если Не РазрешитьЛокальныеАдреса И Найти(Домен,".") = 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // В домене не должно быть символа подчеркивания.
    Если Найти(Домен,"_") > 0 Тогда
        Возврат Ложь;
    КонецЕсли;
    
    // Выделяем зону (TLD) из имени домена.
    Зона = Домен;
    Позиция = Найти(Зона,".");
    Пока Позиция > 0 Цикл
        Зона = Сред(Зона, Позиция + 1);
        Позиция = Найти(Зона,".");
    КонецЦикла;
    
    // Проверяем зону домена (минимум 2 символа, только буквы).
    Возврат РазрешитьЛокальныеАдреса Или СтрДлина(Зона) >= 2 И СтрокаСодержитТолькоДопустимыеСимволы(Зона,Буквы);
    
КонецФункции
1
Volexovich
203 / 178 / 30
Регистрация: 24.10.2011
Сообщений: 721
17.03.2016, 11:31  [ТС] 7
Спасибо конечно, но я увидел анонс обновления к мобильной версии и там было написано " улучшен механизм проверки корректности адреса электронной почты", вот мне и интересно где это механизм.
0
OrkVasya
о_____О
Эксперт 1С
221 / 221 / 36
Регистрация: 19.11.2010
Сообщений: 1,061
Завершенные тесты: 1
17.03.2016, 11:39 8
Volexovich, можешь кинуть ссыль, где видел? Я не вижу ничего такого не в СП ни в информации к платформе.
0
Volexovich
203 / 178 / 30
Регистрация: 24.10.2011
Сообщений: 721
17.03.2016, 11:47  [ТС] 9
Теперь найти не могу, похоже не там смотрел, видимо запутался.
0
Dethmontt
Модератор
Эксперт 1С
2701 / 2465 / 432
Регистрация: 10.03.2011
Сообщений: 8,937
Записей в блоге: 1
Завершенные тесты: 1
22.03.2016, 04:07 10
Жаль запросы без обращения к БД нельзя делать на клиенте

1C
1
2
выбрать (&адрес ПОДОБНО "[^0-9!@;$%?/\|*+-=)(^]%@[^0-9!@;$%?/\|*+-=)(^]%.[A-z][A-z]" 
    или &адрес ПОДОБНО "[^0-9!@;$%?/\|*+-=)(^]%@[^0-9!@;$%?/\|*+-=)(^]%.[A-z][A-z][A-z]") КАК АдресСоответствует
0
22.03.2016, 04:07
Answers
Эксперт
37091 / 29110 / 5898
Регистрация: 17.06.2006
Сообщений: 43,301
22.03.2016, 04:07

Разработать программу, которая вводит адрес электронной почты и проверяет синтаксис введенного адреса. Результат проверки выводится в виде сообщения
Домен не может заканчиваться дефисом. Например, недопустим адрес: p_pg@m12-.it.mail.ru

Разработать программу, которая вводит адрес электронной почты и проверяет синтаксис введенного адреса. Результат проверки выводится в виде сообщения
Дефис в доменном имени может быть только одиночным. Например, недопустим адрес:...

Как проверить корректность логина?
мне известно username и password подскажите пожалуйста как можно из Domino C/C++ API проверить...


Искать еще темы с ответами

Или воспользуйтесь поиском по форуму:
10
Ответ Создать тему
Опции темы

КиберФорум - форум программистов, компьютерный форум, программирование
Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.